TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

2018 Trial version
Read 510 times
* May 04, 2018, 08:08:46 AM
I downloaded the new version last night and installed it to my home computer, it installed OK and I was able to activate it using the 30 day code when I tried to open it the window asking for the permanent code when purchased came up I selected later and the window closed and nothing else happened. It does not open the program. Later I tried to open the 2017 version and it would not open. I went to the task manager and it shows 2018 is open and it is not letting 2017 open either. When close 2018 in the task manager then 2017 will open. I downloaded the new program twice and got the same results. Is there a problem, I will probably buy the program but I want to test run it first. I have convinced the place I work to buy this but not until I look it over.
  Myron  TC10 to current

Logged


* May 04, 2018, 08:15:48 AM
#1
Have you checked if there is a menu on the "backside" there are waiting for an input,  like if it's covered of other programs that run at the same time

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


May 07, 2018, 02:20:13 AM
#2
To restate Torfinn's suggestion: Try minimizing each window on your screen in order to see if there are hidden popups requesting a decision as that can interfere with proper operation.  Alternatively, you can use the <Alt><Tab> key combo to slide through the available windows.


Jeff
« Last Edit: May 27, 2018, 12:41:35 AM by Jeffin90620 »

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* May 26, 2018, 10:06:47 PM
#3
I have same problem!

Logged


* May 27, 2018, 09:04:00 PM
#4
I've run into similar problems in the past, but I would go back and double-click on the desktop icon and the program started. It seems that it only completes the registration and then forgets to start the program.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* June 01, 2018, 04:49:54 AM
#5
I am running version 2015.  I had similar problems with that.

The biggest PITA I have come across with TurboCAD is that it does not play nicely unless running as an administrator.
If you have any issues like this, start or re-install whilst logged into an administrator account, it doesn't always follow that a program will ask for permission from an admin account when logged in as a standard user.

Logged


June 04, 2018, 02:17:56 AM
#6
The biggest PITA I have come across with TurboCAD is that it does not play nicely unless running as an administrator.

I wasn't paying attention and installed 2018 without going into Administrator mode.  So far, I have not noticed any problems (or, at least, any problems that no one else is having).


Jeff
« Last Edit: June 04, 2018, 06:07:43 PM by Jeffin90620 »

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1