TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

"Select" Not Selecting - on just one drawing?
Read 310 times
* May 02, 2018, 03:28:28 PM
I've suddenly lost the Select command - apparently on just one drawing!

The toolbar arrow symbol is still there and apparently switched on (normal shade and pressed in), but I can't pick any component of the drawing.

I've could not see anything in the Manual about turning Select off - but as it's so fundamental to using the entire package I wouldn't expect that anyway. It'd be analogous to turning the selection-highlighter off in 'Word'.

I ferreted through assorted menus; found nothing untoward. I saved the work, closed and re-opened TurboCAD but that made no odds. I tried a couple of other drawings and Select works fine in them.

So obviously I've somehow set that one drawing to disable the Select tool! Or have I somehow invoked TC's version of read-only without going through the File menus to do so? It did briefly flash up some odd message about read-only graphics on something.

Can anyone think what the Hell I've done and how to correct it? (I suspect mis-keying or something like that, perhaps inadvertently hitting two keys at once with the incorrect one taking precedence or acting as an arcane combination-key, so I wouldn't know what I'd done.) 

Logged
Nigel.

On TC Deluxe 19: hobby use.


* May 02, 2018, 03:36:09 PM
#1
Have you locked a layer or layers?

Logged


* May 03, 2018, 01:47:05 AM
#2
Yes - I wondered if that was the problem.

I know approximately what layers do, I see construction lines are on their own layer by design. I've also the impression that if you group things into blocks they become a layer of their own. However I don't understand layers enough to risk making multi-layer drawings deliberately, so I keep to single layers. These are also straightforward 2D creations too, with the title above the main tool-bar having the legend "World Plan" attached automatically to my own words. 

I've tried:

     Examining both Blocks and Layers. The Blocks field was just as a black rectangle with a little tool-bar, so empty. Layers show all as intended, one drawing layer plus the automatic one for the construction-lines I'd used.

   Program and Drawing set-up displays, as far as I can interpret them, show nothing out of the ordinary.

    File Properties with TC off, via the normal Windows file-managing functions. It's not marked as read-only, and I could see nothing untoward with its properties.

   Drawing a random little line away from the main drawing so less likely to be affected by any editing on that. That too, is non-selectable. 

   Re-opening TC having closed it down and turned off the computer completely for the night: no joy. It wasn't some glitch cleared by re-setting. The Select button is as it should be - sharply defined with the "pushed in" appearance: nothing like other tools shown as inactive by being flat, faint grey.

   Opened two other recent works over the top of the faulty one: they both work fully, and I can Select various entities on them as normal. No part of the faulty drawing can be selected: outlines, centre-lines, text boxes, random test-line!

Logged
Nigel.

On TC Deluxe 19: hobby use.


* May 03, 2018, 03:03:45 AM
#3
Just to add, I don't know if it will help, but I'll describe what I was doing up to the point I broke it.

An exercise, although intended for a real project: a simple but custom pipe connector to link a plastic hose to a fixed bulkhead union. Conventional form, with two mating flanges drawn together by a union-nut loose on the hose fitting, engaging a thread on the larger, fixed flange: three pieces of metal. (I'd not yet drawn the union nut and olive to secure the plastic pipe to the connector inlet.)

I'd drawn most of it and was attempting a half long-section of the hose fitting. This entailed  Trimming complete, transparent outlines back, and making assorted lines Meet at right-angles, hoping then to cajole them into a Polyline I could cross-hatch. I interrupted that Trimming etc to add a detail I'd missed but would show in section; and the strange, very brief warning then image-locking occurred while constructing that.

Despite finding that Polyline system very difficult and chancy,  I was attempting nothing new to me. I was not trying to be too clever with unfamiliar commands; certainly no 3D attempt. It was just a set of lines, rectangles and circles symmetrical about set axes on a single plane, plus a couple of text labels.


Logged
Nigel.

On TC Deluxe 19: hobby use.


* May 03, 2018, 05:00:35 AM
#4
The property bar on the program's header has the provision to lock the layer inadvertantly if you're unfamiliar, the lock is between the eye, for visibility, and the object's colour.  Once you've locked it and nothing's selected, you can't access the lock from the program's header.  Instead, go to "format" menu, the first item is layers, invoke that.  The layers dialogue will open up and if you've locked the layer, the lock will show as I've ringed it, click it so that the little lock greys out and you should be good to close the layers box and select your objects again. 

Logged


* May 03, 2018, 07:13:12 AM
#5
Got It!!

Thank you very much!

Thinking about it, I can see the sense in being able to lock a layer, but I had no idea you can do that, or how - the little lock sign is fairly discreet, too.

Logged
Nigel.

On TC Deluxe 19: hobby use.


* May 05, 2018, 05:47:54 AM
#6
I've overlooked the obvious, too.  The layers icon is on the property bar at the left of the eye (visibility) button, immediate access to the layers box from there.

Logged


* May 05, 2018, 01:38:20 PM
#7
Easily done on a screen-border full of tiny symbols!

I still have no idea how I managed to lock that drawing's one layer. I am nowhere near trying deliberately to use such an advanced feature, so must have stumbled across some combination-key control simply by clumsy typing, without knowing what I'd actually pressed.

I tend often to strike two keys together, the intended one and one somewhere nearby. The computer normally only responds to the first to activate, but if it is a control-key, or the two give a short-cut pair, then they produce accidental effects without me knowing what I've done. This is irrespective of the software I'm using at the time. (I can't use even "full-size" lap-tops, let alone those scaled-down versions, because their keyboards are physically so fiddly.)

Logged
Nigel.

On TC Deluxe 19: hobby use.