TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Cannot trim a line
Read 219 times
* April 25, 2018, 11:47:24 AM
I can seem to trim some lines in the drawing but not others. The ones that won't trim are not doubled-up lines. They are single lines simply crossing each other and will hi-lit but won't trim. I tried even changing snap settings to see if that would do any good. Is there some property(ies) of a line that won't allow it to be trimmed?

Logged


* April 25, 2018, 12:27:03 PM
#1
Maybe they are on a different workplane's, then they will not Trim.
It can be just a fraction of a millimeter and by system they are on a different workplane.
If the drawing is just 2D, set workplane by world, select all the object and then "Place on Workplane", Shift+Alt+W

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* April 25, 2018, 02:37:45 PM
#2
Thank you, the Shift-Alt-W worked!
Sure enough, some of the lines (newer ones), somehow, got on a different work plane. How can that happen?

Logged


* April 25, 2018, 02:53:15 PM
#3
Maybe you are in 3D mode and draw only 2D, then it it 100 % sure it will happen at a point, maybe you also have turned of the warning, else TC will warn you about it everytime it may happen.

Toggle to 2D mode down on Inspector bar if you should draw only 2D or open the selector Properties next to Toggle and set it to  2D/3D depending, then it should always draw on workplane if drawing 2D object's.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB