TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

render manager redsdk same settings different results
Read 522 times
* March 13, 2018, 05:38:29 AM
In trying to learn how to create and use redsdk materials I've been watching Don Cheke's video on drawing a model dynamo.  In one of the segments he shows how to create new materials using the render manager redsdk.  I've attempted to duplicate his materials using turbocad pro 2016 and so far I can't get the same results using the same values  Attached are two screen shots, one is of Don's shiny aluminum and the other is the one I did.  His is light gray & very shiny and mine is almost  black. While not visible I did verify that the color values matched what Don used.  The value that seemed to make the most difference was the transparency IOR value.  When I used 15 it turns the sample almost black.  Are there other values for redsdk outside the render manager that I need to change to get  my results to match what Don was able to do?

Logged


* March 13, 2018, 08:52:52 AM
#1
I gave it a try and got the same results as you. Hopefully Don will be around later to explain.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* March 13, 2018, 09:16:43 AM
#2
Double sided it not checked both places.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


March 13, 2018, 09:31:42 AM
#3
YOu need to change the RM Render Engine Options from the default render Manager settings from Raytrace Preview to at least Raytrace Standard:

See attached

Logged
Daz...
V2017 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows7 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* March 13, 2018, 09:40:14 AM
#4
Is it just in the manager, or within TC itself. 

It seems OK here in the manager.  What settings do you have in the render manager settings screen (click the 'gear' icon), as this affects how the preview appears in the manager.

My settings are below, BUT I doubt others are using the same settings, best to experiment to see which settings one prefers.

## EDIT ## I see Darrel posted whilst I still tying ## End Edit ##

Logged


* March 13, 2018, 09:42:33 AM
#5
And this is what i get with Don's setting in imperial, about

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* March 13, 2018, 09:44:36 AM
#6
Thanks changing the raytrace in  the render manager settings fixed it.  Thanks.

Logged


* March 13, 2018, 10:24:30 AM
#7
Along with the Render Manager Options change, I had to turn "off" the Fresnel option to get the same results as Don and others, though the screenshot of Don's material shows it being "on". ???

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


March 13, 2018, 10:28:58 AM
#8
Along with the Render Manager Options change, I had to turn "off" the Fresnel option to get the same results as Don and others, though the screenshot of Don's material shows it being "on". ???

I did a test a while ago and this is correct. The higher the Fresnel value the less the Fresnel effect so reflections get closer to a metallic look. As I remember about 25 was the same as unticking Fresnel (off).

Logged
Daz...
V2017 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows7 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* March 13, 2018, 11:41:09 AM
#9
A full pic of the way i have it

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* March 13, 2018, 02:16:41 PM
#10
Thanks Tor, now I see where my problem was. I saw the IOR as being at the default of "1.5", whereas in reality, it was at "15". Now it renders properly.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit