TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

You are working on an invisible layer
Read 790 times
* March 13, 2018, 05:05:27 AM
Hello all, I just got a different laptop and installed TurboCad Designer 2017 on it. I am familiar with TurboCad 18 which is on my previous computer but I am getting stumped on some differences between the two versions. In 18 to move geometry between layers you simply selected the portion of the drawing you wished to move then opened the new layer, then closed or made the previous layer invisible, this moved the drawing to the new layer and you could work with it there in the new layer. Fast forward to Designer 2017 on net computer, the only way I can find to move drawings from one layer to another is through properties (select drawing geometry, access properties vis right click and assign it to whatever layer you would like). works great......until you try to modify it, you get the warning that you are working on an invisible layer, seems no matter what settings I use in the layers I cannot get it to work. I'm sure it's something simple that I am missing, anyone have any suggestions?

Logged


March 13, 2018, 05:57:09 AM
#1
Hi,

I have tried following your query and find that TurboCAD Designer 2017 appears to be working okay, in this respect.
However, is it possible to post an example file to look at?

Was the file created entirely within Designer, or imported from version 18, for instance?

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2017 and TurboCAD Pro. Plat. 2016/2017/2018 + Lightworks (64-bit versions).


* March 13, 2018, 07:01:37 AM
#2
It's happening with both, files imported from 18 as well as ones created in Designer 2017

I attached the file that is giving me fits

Logged


March 13, 2018, 07:44:09 AM
#3
Hi,

briefly, two things.

It is a good idea/practice to keep layer 0 always visible.
This is likely why you are getting the error message.

When opening the file initially, it mentions objects not supported by Designer.
I would suggest selecting No, unless you particularly need to reopen and show these in a another TurboCAD version.
Always save under a different name, if you so wish.

I hope this helps.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2017 and TurboCAD Pro. Plat. 2016/2017/2018 + Lightworks (64-bit versions).


* March 13, 2018, 08:49:44 AM
#4
layer 0 may not have been visible when I saved the file but I have already tried that, still doesn't work. Now that I clocked yes on that popup message how do I reverse that?

Logged


* March 13, 2018, 09:11:17 AM
#5
I also failed to mention (slaps forehead) that it's dimensioning that is giving me the trouble, I can add to and edit the drawing but can't dimension. I am trying to dimension the "angle iron end" layer but it wants to drop the dimensions on the "west" layer. Also is using the properties the correct way to change what layer geometry is placed on?

Logged


March 13, 2018, 09:15:08 AM
#6
Clicking Yes, when you open the file initially, will load the objects, but not display them.
They will remain in the drawing, but can be removed by clicking No, the next time the file is opened, and then saving the file.
It's your choice.

So far, I have found no problems in editing/modifying any of the elements in your drawing.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2017 and TurboCAD Pro. Plat. 2016/2017/2018 + Lightworks (64-bit versions).


* March 13, 2018, 09:20:47 AM
#7
Tim, looks like we overlapped responses, can you please try to dimension the "angle iron end" layer with all others (except 0 of course) turned off and see what happens?

thanks so much for your help!

Logged


March 13, 2018, 09:28:59 AM
#8
Tim, looks like we overlapped responses, can you please try to dimension the "angle iron end" layer with all others (except 0 of course) turned off and see what happens?

thanks so much for your help!

It would be a good idea to give your layers different colours, as it is very easy when dimensioning, to click on one line on one layer and another line on another, if this makes sense.
The first line/vertex selected will dominate the layer it will be saved to.
With the way you have your drawing organised, it might be best to dimension each layer, with all other layers off (except layer 0).

I hope this helps.

Regards Tim


Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2017 and TurboCAD Pro. Plat. 2016/2017/2018 + Lightworks (64-bit versions).


March 13, 2018, 09:32:16 AM
#9
I also failed to mention (slaps forehead) that it's dimensioning that is giving me the trouble, I can add to and edit the drawing but can't dimension. I am trying to dimension the "angle iron end" layer but it wants to drop the dimensions on the "west" layer. Also is using the properties the correct way to change what layer geometry is placed on?

Yes, that's the way I do it, in Designer.   :)

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2017 and TurboCAD Pro. Plat. 2016/2017/2018 + Lightworks (64-bit versions).


* March 13, 2018, 09:34:07 AM
#10
I cannot put dimensions on the angle iron end layer, the dimensions go on to the west layer, with every point I drop the "you are currently working on an invisible layer" popup shows up and the dimension is invisible as well because it is on the west layer.

I went so far as creating a new drawing in 2017 on layer 0, put one line on layer 1 and the other line on layer 2, if I am on layer 2 (and layer0 on as well) the dimensions are on layer 0

Logged


March 13, 2018, 10:12:48 AM
#11
Ah yes, problems with Dimensions.

I started a Normal drawing, added two lines and two new layers.
First line went onto new layer 1.
Second line went onto new layer 2.
I then dimensioned both lines and these were placed on the default Dimensions layer, something TurboCAD does. ::)
The programme tries to second-guess which layer dimensions should go on, if not the default.

I have found, if I remember correctly, that if you place the dimensions, for the most part, on one layer, say layer 6, TurboCAD thinks that's where you want all dimensions.

I tend to keep dimensions on one layer only (Dims, for instance), unless I specifically require them elsewhere.

In the example above, it is a simple matter to relocate the dimension/s onto the required layer/s.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2017 and TurboCAD Pro. Plat. 2016/2017/2018 + Lightworks (64-bit versions).


* March 13, 2018, 10:21:13 AM
#12
So what you are saying is layer 0 is now my default dimension layer?! that seems ridiculous some of my larger drawings will get VERY cluttered with all the dimensions piled into one layer, especially with having separate components of a large job separated by only layers....

Logged


March 13, 2018, 10:50:50 AM
#13
Hi again,

Take a look at the attached file.
You can move the dimensions to any layer you like, as I've stated above.

If you wish to have dimensions on more than one layer then you must be careful when dimensioning, that the dimensions are actually placed on the layer you require.
Generally, it's better to use layer 0 for initial creation of various objects, moving them to a relevant layer as necessary.

This has frustrated me and others I'm sure, but is resolved by careful drawing practices/planning.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2017 and TurboCAD Pro. Plat. 2016/2017/2018 + Lightworks (64-bit versions).