TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Facet Offset
Read 828 times
March 06, 2018, 03:31:59 PM
Hey guys...
I thank you in advance who can help me with this issue.

(Sorry my english, another native language)

When I use the "facet offset" tool many times when I click on the solid all facets are selected.
The solid not appear "clear and thin" so you choose the facet you want to edit.

In simple solids this is not a problem because I can deselect quickly, the problem is the complex solids where going from facet to facet can take dozens of minutes literally.

When this happens, how can I unselect all facets immediately and leave none selected so I can use the tool?

Sometimes I'm working on a solid so complex that there are facets that I can not unselect preventing me from using the tool.

As I am dealing with the subject, I would like to know if I can to do the reverse, that is, instead of selecting facet by facet with the mouse cursor if you have how to select several at a time. Selecting many and removing those you do not need a quick way.

Thank you very much.

( TurboCAD 19.2 64Bit Platinum)




Logged
TurboCAD Professional 19.2 64-bit - Platinum Edition


* March 06, 2018, 04:19:19 PM
#1
The "Escape" key or Cancel will deselect everything. "Facet Offset" only allows selecting one facet at a time, whereas "Facet Edit" allows you to drag a selection window. Hold the "Shift" key to select or deselect facets.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* March 06, 2018, 04:35:54 PM
#2
That is quite a challenging puzzle,  I've no idea, looks to me like a long standing 'flaw' in the program, as its the same in TC 2017,  escape etc. is no good in the situation I tried, TC just automatically selects multiple faces as soon as one clicks the object, which then have to be unselected one by one.

Logged


* March 06, 2018, 06:08:20 PM
#3
In case anyone wants to test the situation, I've attached a v19 file, which was deliberately created to be, kind of faulty, (I've no idea what type of file MSouto is using).  This may possibly show what can happen, the lack of being able to de-select multiple faces does slow things down when only one or two faces are wanted.

Note - I don't know if the problem will show up on different computers.  And, I'm only guessing that this is the actual problem being enquired about.

Logged


* March 06, 2018, 08:52:09 PM
#4
I see what you mean. It selects a bunch of random(?) faces, not all of them or the one clicked upon. Maybe Igor can shed some light on this.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* March 07, 2018, 08:39:29 AM
#5
I have experienced the problem, too -- but not in the posted Facet_offset1.tcw.

Henry H

Logged


March 08, 2018, 09:49:18 AM
#6
The "Escape" key or Cancel will deselect everything. "Facet Offset" only allows selecting one facet at a time, whereas "Facet Edit" allows you to drag a selection window. Hold the "Shift" key to select or deselect facets.

Again personal greetings.

John,
when I read what you wrote I wonder if I did not try this (Amazing if not) or if it does not really work. But pressing ESC or Cancel the object is still selected by the "facet offset" tool so that the correct facet is chosen? Otherwise such procedure is not useful. I am currently working on an important file and I was not able to test your suggestion, but as soon as the problem arises I will that.  Thank you.

Andy H,
It's more or less what happens, I did not open your file yet but the image you can perceive. My problem is a little more serious because the geometry of the object is very complex and facets that I have to unmark are numerous and there are those that I can not because they are positioned in places without access.

My thanks for the answers.

Strange, I did not receive any email notifications about posted on my topic. I must have missed something.

Logged
TurboCAD Professional 19.2 64-bit - Platinum Edition


March 14, 2018, 04:03:09 AM
#7
Strange, I did not receive any email notifications about posted on my topic. I must have missed something.

I had that problem for a couple months around a year ago.  Very annoying, especially as I was going into my Profile and making sure the proper settings were invoked.

The attached image shows how to get where you need to be, and the preferred radio buttons to activate.


Jeff

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


June 21, 2018, 06:18:15 AM
#8
Strange, I did not receive any email notifications about posted on my topic. I must have missed something.

I had that problem for a couple months around a year ago.  Very annoying, especially as I was going into my Profile and making sure the proper settings were invoked.

The attached image shows how to get where you need to be, and the preferred radio buttons to activate.


Jeff

Thank you Jeff

Logged
TurboCAD Professional 19.2 64-bit - Platinum Edition