TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.

Distribute Command Broken in v19.2
Read 537 times
February 28, 2018, 08:14:17 PM
The Distribute Command in my v19.2 appears to be broken when trying to distribute objects vertically.  It gives an Error Message: "Cannot Distribute Objects in this way".  Mine will not distribute either squares or circles, (the only objects I tested).  My only work-a-round was to use Horizontal Distribute, and then, (more steps here), rotate the results.  Can this be fixed?
(I have Build 54.2)


* February 28, 2018, 10:55:41 PM
Straight from 2017PP help file:
"Distributing Objects
Distributes all currently selected objects, relative to a specified location on the objects (top, left, center, etc.). There must be at least three objects selected for this function to be available. Objects are distributed between the two most extreme objects, i.e. the farthest left and the farthest right, or highest and lowest. Object order is maintained (top to bottom or left to right)."

Can you post an example file?

Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best

March 02, 2018, 02:20:11 PM
I know how the command is supposed to work.  All you did was say what what the manual says.  Please re-read my post, and test if possible -- anyone with the same version I have.  The NEXT level, I will post a file.

Update:  If I try this command all alone, in a New Drawing, it works.  If I re-try the vertical Distribute Command in my drawing, again with small, identical circles, copied with the Rubber Stamp, and with Ortho on, Vertically, it does not work.  I chose carefully so that no other Objects, other than the circles were selected.  The only difference I can discern, is that, in My Drawing, I have chosen a "Workplane by Facet".

So, is the Distribute Command working only in some default Workplanes?
« Last Edit: March 02, 2018, 02:36:27 PM by T. Karlmann »


* March 02, 2018, 02:45:48 PM
Works fine here using v19,  however care needs to be taken, as workplane by facet tool can rotate the axes, so what one thinks is vertical (Y) is actually horizontal (x) as far as the distribute command is used.


March 02, 2018, 03:23:40 PM
So, according to these repliers, having a broken Distribute command is just fine?


* March 02, 2018, 03:40:54 PM
So, according to these repliers, having a broken Distribute command is just fine?

Hi, That is not what I said nor meant.   You asked for it to be tested in the same version, hence my reply that it worked fine for me in that version.

I (obviously wrongly) thought you would go to the 'next level', and post a sample file of it not working, so someone can check the problem with your file.


* March 02, 2018, 03:43:47 PM
So, according to these repliers, having a broken Distribute command is just fine?

No, it is not fine. Several possibilities come to mind (and I have experienced all of these)...

1. It's a temporary aberration that will go away if you close the drawing and then reopen it.

2.  The tool is indeed broken in your installation, in which case it can probably be fixed by running the TCad installer again, with the "Repair" option enabled.

3.  The drawing in which the problem appears has become corrupt. Stuff happens.

4. You're not using the tool correctly.

Henry H


March 02, 2018, 05:08:38 PM
As typical, my file is rather large, by my humble standards, and the design is unique.  I would rather not share that file.  As I stated, in a new workspace, it works fine.  It appears we are at an impasse.  I can always use Array Fit Copy, but I don't want to share my file.  I just thought I would point out that the Distrubute Command is broken, in case anyone cared.