TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Print Style Manager
Read 1657 times
* February 28, 2018, 10:03:46 AM
Hi all,

I seemed to be getting on relatively well with TurboCad after some initial problems, but now I've hit a problem with Print Style Manager and would like to know if this is solvable or just a constraint of the version I am using and not worth wasting any more time trying to resolve.

Basically, I used to use a plot style table in AutoCad LT which allowed me to print certain lines in colour. So far with TurboCad I have just set the print parameters to 'Black' and haven't bother with a style table, but I now need to be able to print a plan which will have a Red polyline visible on the print out (or PDF)

But when I use the Print style manager, all I get is the box as the attached screenshot. It feels as if it's not quite all there. None of the buttons except 'cancel' seem to do anything and when I try to import an AutoCad plot style table, it doesn't allow me to find the .stb file I need.

I've tried clearing out the built in folder (what a pain that is, just when you've got the program set up the way you like it) but that has no effect.

Searching on here only brought up a couple of items.

Using TurboCad 2017 Expert

cheers

Logged


* February 28, 2018, 10:51:42 PM
#1
Can you post the drawing?

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* February 28, 2018, 11:49:00 PM
#2
Try close TC and close your pc, then restart ( coldstart ) everything again as Expert have Print style manager and will open in both M and P space, it is something on your system that hang i believe.

Maybe try open a new from scratch drawing first to check if it is only that drawing that have the problem.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* March 01, 2018, 02:37:08 AM
#3
Hi,

Thanks for the replies Darryl W & Torfinn.

Not sure the drawing itself is the issue, and it's for a client so I am hesitant to publish on a public forum.

The issue has been around for a while now, after many sessions.... in fact one of the reasons I just opted to do the print in Black option was because I couldn't figure out why I couldn't import or create a plot style table.

I've now used a PDF editor to put the red line onto the plan, but I would still like to resolve this for future projects.

The other thing I notice is that the lines are very thick compared to AutoCad. I have line thicknesses set to 0mm in the Layer Manager, but on some items which I have copied over from AutoCad drawings where the line thickness is 0.05mm it shows on the PDF very much thinner than the 0mm.

Also, I added a line (actually a couple of Arrows) to a plan in paperspace and that line was much more the size I was expecting to see generally i.e much finer than the 0mm width of the modelspace item.

There's an extract attached. The two arrows I have drawn on the stairs are using a layer I imported from another drawing created in AutoCad and with a line width of 0.05mm.
The line widths of the TurboCad layers appear to only be adjusted via the drop down box which gives widths as 0, 0.1, 0.2, 0.3 etc.


Logged


* March 01, 2018, 03:25:58 AM
#4
Quote
I've tried clearing out the built in folder (what a pain that is, just when you've got the program set up the way you like it) but that has no effect.

I don't know if you do this or not, but after setting TC the way you like it,  Tools menu (or Tools menu - Workspace) - Customise,  in the options tab, under the 'Save In' button, type in a name for your workspace, then click 'Save In'.  The next time you need to delete the built in folder or reset the workspace, one can use 'Load From' to easily restore quite a bit of your configuration.

Quote
Not sure the drawing itself is the issue, and it's for a client so I am hesitant to publish on a public forum.

Very understandable,  can I ask, did you try Torfinn's suggestion of a new from scratch drawing to see if the print style dialog is OK there, I'm guessing that it is possible TC got confused if it found an AutoCAD style it didn't understand.

I don't have Expert version so can't be of any use, but, if a new from scratch is OK, could you copy and paste a tiny portion of your drawing into a new blank drawing, say just a few different lines, and if it exhibits the same problems with print styles, you could post the new drawing for someone who has expert version to test. 

Logged


* March 01, 2018, 03:42:28 AM
#5
The tick lines in the PDF is a RedSDK problem i think to remember, but it should be possible to set different linethicknes in the default's some place,, even if i dont think it will effect the print.

John R had a comment about it not so long time ago, you can open the Explorer palette, find the Default >> Line thickness and change/ add some more.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* March 01, 2018, 08:29:21 AM
#6
*Thought I'd posted a reply but it doesn't seem to be here, so I'll try again*

Hi Andy H,

Thanks for the tip about saving the workspace setup - that will be very useful!

I did try the new drawing from scratch and with TC rebooted as well, but no change. Print style manager has no functionality on my machine. I am wondering if a complete re-install might be required, unless someone can come up with a solution.

Torfinn - Thanks for the heads-up about the Explorer pallette - very useful, as I can now specify any line width I want!
The PDF I had attached was just Hidden Line, not RedSDK.

Out of curiosity, is the Lightworks render engine worth buying? I think it's another £100 or so for my version, but not sure what it will bring to the game.

I have another problem....which I will post as a new query.


Logged


* March 01, 2018, 09:10:00 AM
#7
I talk about RedSDK as "Native Draw", and if i understand the last answer that you dont have LW i believe you was not in GDI mode, but in RedSDK mode.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* March 01, 2018, 09:51:32 AM
#8
Try going to "Options / Print Styles" first and set it to "Use color dependent…", then "OK".
Now go to the "Print Style Manager" and see if you can find a CTB file.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* March 01, 2018, 08:32:28 PM
#9
I used to use the old "autocad" method as John explained,Great for 2d drawings.
But I found that they don't work for hidden line viewports.
My solution was to use layer templates. I have one layer template with all  pretty colours to make it easier to draw.
And another set up with all the layers set to black or the colour I prefer.
I apply the black template before printing and switch back to the coloured version when on the drawing.
 You do need to work with colour by layer, and the line weight ("value") - by layer.
I always use the same layers with similar drawings so you only need to set up the layer templates once - remember to save them because they don't save with the file.

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* March 01, 2018, 11:32:01 PM
#10
Thanks for the reply John R, but unfortunately it made no difference.

Curiously, the 'print styles' setting doesn't appear in my 'Options' drop down box, but only in the 'Drawing Setup' box once selected.

Is this normal, or a glitch?


Logged


* March 01, 2018, 11:33:23 PM
#11
Thanks Nikkipollard.... I will have to look into that... once I get my head around the concept!

Logged


* March 02, 2018, 01:21:16 AM
#12
Just uninstalled and reinstalled, rebooted....the lot.

Made.No.Difference.Whatsoever.  :(

Logged


* March 02, 2018, 02:59:52 AM
#13
The other thing you can try - but it's time consuming.
You can specify the colour of a layer in a viewport so one viewport can show an object as one colour and the other viewport can show the same object with different properties - as long as the objects properties are set to by layer.
Once you set up a viewport select it and go into floating modelspace  in the layer palette the last few columns control the properties for each layer for that viewport. You would need to do this for each viewport though. I tested this in the 32 bit version.
I don't know how to change it back to the original settings so make a copy of the sheet before you try it.
« Last Edit: March 02, 2018, 03:08:46 AM by nikkipollard »

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* March 02, 2018, 04:03:10 AM
#14
Thanks for the reply John R, but unfortunately it made no difference.

Curiously, the 'print styles' setting doesn't appear in my 'Options' drop down box, but only in the 'Drawing Setup' box once selected.

Is this normal, or a glitch?

Platinum 2017 > Working in "Default" User Interface Style and "Default" Workspace "Print Styles" and "Print Style manager" is located under the "File" menu.

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2018-2017, TurboCad Platinum 21.Using Lightworks and Redsdk, Anilab lab 5. ATI Mobility Radeon HD 4500/5100


* March 05, 2018, 08:19:54 AM
#15
Here's an interesting thing:

I've opened an old AutoCad drawing in TurboCad and the Print Style Manager is functioning correctly.
I've saved the drawing as a TurboCad file and we still have a functioning Print Style Manager.
In this TurboCad session I have started a drawing from scratch and Print Style Manager works.

I have opened the drawing I was previously trying to get the print style manager to function in and it is there and working......

....however.....

In model space, I no longer have any rulers shown to the perimeter of the workspace and if I zoom in on the drawing... it disappears after a few clicks of the middle mouse wheel.
When I zoom out, the model reappears....but is slightly out of square.
Sorry can't post the drawing file, as it's for a client.

Concerned that it may be corrupted....  :-[

Logged


* March 05, 2018, 08:21:54 AM
#16
Panic over!

It was the perspective camera setting. Switched that off and everything returned to normal
 8)

This can't be good for my blood pressure.

Logged


* March 05, 2018, 09:07:27 PM
#17
Okay, we're getting there.

Having had a few issues with TurboCad when I first stating using it, and not knowing if the problem was me or the program (it was me) I looked on here for tips and one of these was to run the program as "administrator".

So, that is what I have tended to do, unless I forget and just double click a drawing file to launch the program.

But this seems to be the root of the problem I am experiencing with the Print Style Manager.

Running as "administrator" means Print Style Manager doesn't function, but running TC normally means everything works fine.

 :-\

Logged


* March 06, 2018, 12:08:51 AM
#18
It's not run as admin that make problem i believe, at least it dont do at my end, but it's not recomended to doubleclick on a file to open it, use the correct open command, (Select and then click open in the menu) and see if it helps.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* March 06, 2018, 01:18:36 AM
#19
Thanks for the input Torfinn.

Unfortunately, while I now seem to have a working Print Style Manager........

....it doesn't seem to be having any affect on the actual print output.

I have two styles:
Normal - which is supposed to print the line whatever colour the layer or individual object is set to.

Style 1 - which is supposed to print out in Black, regardless of what colour the layer or object is set to.

But everything is printing out in colour (except when Black is specifically chosen for the Layer or object)

I'm obviously missing something here, and it's probably annoying to have to put up with me fumbling around in the dark, so I'll just have to keep experimenting until I crack it!

Logged


* March 06, 2018, 02:38:39 AM
#20
A long shot, do you connect the object to the prinstyle you want to use ??

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* March 06, 2018, 07:08:30 AM
#21
are you working in 2d or 3d?

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* March 06, 2018, 11:47:37 AM
#22
Torfinn,

I have tried setting the printstyle on the object, in this case a block of a North Arrow, both on the Block in Modelspace and also edited the block to set it's components as well.

Still outputs in colour.

Nikkipollard,

2d for this drawing

Logged


* March 06, 2018, 12:12:00 PM
#23
I can still set the prinstyle of the Block..
After making it to a Block i select the Block inside Block Palette, click on Edit Content, Select the Object i want to change prinstyle for     ( the Arrow and brush ), finish edit Block, insert the Block in to the drawing,  Select print and set it to use prinstyle( New table ), print to TurboPDF or a Brother printer, select preview of current view, and result is attached as a jpg.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* March 17, 2018, 03:27:45 AM
#24
Ok, we finally got there.

Here's the situation:

I can start a brand new, clean drawing and select the print style table I want to use during the drawing set-up process.

But, when I try to select a style for a particular layer, my only option shown is 'normal'

Unless, that is, I previously select one item of the drawing (a line, a wall, whatever) and select the print style for that item in it's properties dialogue.

That seems to force TurboCad to then recognise that a print style exists and makes it available from then on via the Layer manager.

So we now have the ability to output in colour and Black & white, via the layer properties.

Phew!

Still have an issue with 'run as administrator' though as this definitely causes the Print Style Manager to malfunction on my machine. Open TurboCad normally and it works fine.

Are there any known conflicts with other software, such as Norton?

Thanks all for the useful suggestions and help.  ;D

Logged


* March 17, 2018, 03:38:19 AM
#25
I dont know if it still exist, but i believe there is/ was with AVG antivirus

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* March 17, 2018, 09:21:18 AM
#26
I am glad you sorted it out. I gave up a long time ago. Sometimes normal isn't even available as a print style.

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* March 18, 2018, 01:28:01 AM
#27
Yeah, the interesting thing is I have also installed TC on a laptop and the same issue exists there, so it's not just my desktop machine, though both are running Norton. But I tried TC with Norton switched off and the inoperative Print Style Manager still occurred under 'administrator'

I know many of my issues with TC are because I haven't fully mastered it yet.

For example, the second project I tried with TC was created from scratch, but I had made the error of having blocks created on layers other than 0.
That has been rectified, and I can get the Print Style Manager to show up properly and can force the print styles to be available in the Layer Manager. However, for this particular drawing, it still prints everything out in colour regardless!!

I tried copying over the basic model to a new, clean drawing and discovered that the Slabs all went crazy, from being originally about 200mm thick they suddenly became over 4000mm thick.
So I deleted the slabs and replaced them with extrusions, but that still hasn't solved the print problem.
There must be something lurking in this file which is causing the problem..... I just have to keep digging.

 8)

Logged


* March 18, 2018, 04:49:44 PM
#28
still occurred under 'administrator'

There must be something lurking in this file which is causing the problem..... I just have to keep digging.


TC works best when your computer is run as in >> Your Account is the "Administrator" (Don't run it with "other" account users)

In settings .... Set it to >> Never notify.
The attached picture shows the way.

Cheers
Mike

Logged


* March 20, 2018, 01:43:07 AM
#29
Not sure I like the look of that!

You're saying I should set my computer to not notify me when  program makes changes to it (which as your screenshot shows is 'not recommended' by Windows) ?

Think this is more of an issue that the makers of TurboCad should rectify, not the users of it.

 >:(

Logged