TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

Text Resizing on it's own
Read 1571 times
February 26, 2018, 06:46:14 AM
Using TurboCAD Pro Platinum 2017 64-bit
When I insert text into my drawing it changes size on it's own after a few inserts. In All The info Boxes it still says the size is the same but on screen it is very large compaired to the original. To Continue inserting text I have to select text again.
O.K. I've finally got the text in, sonow I wan't to move it so after selecting and copying it I start to move it and suddenly it resizes larger but once again in the info boxes it is still the same size.
If I select one inserted text (ie 12.0 one the attachment) it will stay the same size. If I move or copy it , once again it gets larger.
On the attachment I have a screenshot showing:-
The original
The single copy and move
The group copy and move
When I select individual text the size dialogue box shows the text is sized at 4.94
Thoughts please.


Logged


* February 26, 2018, 09:11:36 AM
#1
You may have one of the "Intelligent Scale" features turned on in "Options / Advanced Preferences".

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


February 27, 2018, 05:39:07 AM
#2
Hi John R
Thanks for the reply.
Opened the drawing this am and found it just the same so went into Options/Advanced preferances found that all boxes under intelligent Scale unchecked. See screenshot 3.
Just to be sure I then checked them all and went and tried the copy move etc. still doing the same. I then went and unchecked the boxes and found the problem was still there. Oh! bother!!



Logged


February 27, 2018, 06:01:35 AM
#3
Just playing about with problem and it seems to be that if I select and increase to zoom percentage (%) bottom right from 7% to say 60% the copy made is smaller and of course when I go from 60% to 7% the text gets larger.


Logged


February 27, 2018, 06:49:04 AM
#4
Went and opened a blank drawing to try and reproduce the problem.
Those drawings behaved so I'm Puzzled apart that the problem is only in that drawing not in the programme.
I cannot think what I've done as I have spent over one hundred hours with the drawing and will probably have to live with it unless I can remedy the problem.

Logged


February 27, 2018, 07:34:45 AM
#5
When I navigate the drawing I zoom out, move then zoom in. If am still in a text insert box the scale will change.
If I'm out of the text insert box i.e. I have clicked anywhere on the layer and before positioning and selecting the next text the scale of the text will remain the same.
This seems to happen when I group text, copy, zomm out then in as well.
So is my problem only operators error, or is there a box checked/unchecked somewhere??
(Twilight zone theme tune playing in background somewhere)

Logged


* February 27, 2018, 01:54:09 PM
#6
Since it happens to just this drawing and not a new one, you could start a "New from Scratch" drawing, then use "File / Extract From" to copy your file into the new one. This will bring in all your paperspaces, etc., but hopefully not this bug. Otherwise, Support.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


February 28, 2018, 03:51:01 AM
#7
Tried Extract From into a fresh drawing but no success, problem still occurs; will try support.
In the meantime I will have to work round the problem.
I have a similar project on the cards so I might start and work on it and see if the problem re-amerges.
I have learned a few things from this post (and others)

Thanks for just now.

Logged


* February 28, 2018, 05:26:58 AM
#8
I don't know if this is the problem. but it is worth a shot under options space units there are 2 options for text size. Text box height (default) and character height above font base line.
I usually have the second one ticked. The first one doesn't make sense to me.

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* February 28, 2018, 02:51:45 PM
#9
Select the Text / Then go > Properties. (Right mouse click)

In the middle of the dialog box of Text Properties is "Mode"
Selections are Standard / Scalable / Flexible.

Set it to "Standard"

Also in the "Mode" section on the RHS ... are 2 tickables >> Non-rotating & Non-Zooming

Tick >> Non-Zooming

Cheers
Mike


Logged


March 01, 2018, 07:12:38 AM
#10
Nikki
Tried the text sizes switching them on, trying the drawing then back again to switch them off no luck.

Mike
Checked that out and settings were as you suggested; So once again I tried switching the settings but still no change apart from when I select individual texts on the selection the text size has changed from 4.99 to 2.96 even though it looks like over 25 (I'm working in decimal by the way I've also tried it in inches).

I've added in a screenshot as I know a lot of people like pictures.
 
 

Logged


* March 01, 2018, 03:34:06 PM
#11
Try the following ... I know that John suggested a New from Scratch drawing / File / Extract from .... But try this method

1: Create a New Blank Drawing file
2: Open up this troublesome drawing and using the Top Menu only ... EDIT / SELECT ALL / COPY
3: Switch to the Blank new file ... EDIT / PASTE.
4: Give the file a new name ... and SAVE AS / CLOSE
5: Reopen the New file ... and see if the issue is resolved.

Logged


March 04, 2018, 07:06:06 AM
#12
Thanks Mike
tried it and problem still exists.
I have sent a drawing and details to support so I think, it will be a wait and see.
If it really starts to bug me I'll uninstall and reinstall TurboCAD again.

Cheers
Cothy

Logged


* March 04, 2018, 07:16:59 AM
#13
Something I don't think you have yet tried:

Posting the problem drawing file here on the Forums for fellow Forum members to take a look at and see if they can replicate and/or diagnose the issue.
« Last Edit: March 04, 2018, 09:53:11 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* March 04, 2018, 09:58:28 AM
#14
Perhaps it has something to do with the Text Style (properties values assigned in Style Manager).

Looking at Design Director in the screen-captures you provided, I get the sense that this file was created in AutoCAD or other CAD program.  "Translation" of AutoCAD or other CAD created files into TurboCAD is seldom a hundred-percent without issues; there is often something wonky-- the more complex the drawing file, the more so.

Again-- Forum members utilizing the same version as you having access to the problem file will [likely] help to resolve the issue.
« Last Edit: March 04, 2018, 12:55:02 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


March 06, 2018, 08:06:57 AM
#15
Hi Alvin,
This file was started in december 2017 in TurboCAD Pro Platinum 2017 which I purchased as an upgrade as I was getting a lot of problems from the widows 10 upgrade (that will sound familiar to a lot of people).
I also upgraded my computer at that time (new one).
The file was started from scratch and I imported pictures (jpg) from file. These pictures I got scanned at my local copy shop.
After reading some of the other forum texts I removed the old turbocad programes and do not have any other CAD programes (paid or free downloads).
But since my last post I started a new drawing and today it is playing up as well. Design Director is not showing ANY layers. They are available in the menue boxes at the top.

So it's now definate; Uninstall/reinstall time has arrived.



Logged


* March 06, 2018, 03:03:28 PM
#16

Then try the following.

In this link  ... http://forums.turbocad.com/index.php/topic,21707.0.html
I have found that installing both 32 AND 64 bit systems solves problems.

The other item to try ... Run the program in Native View ... Turn OFF RedSDK .

Cheers
Mike

Logged


March 07, 2018, 03:13:16 AM
#17
Please find attached copy of file that is causing the problem.
I's a drawing of a scale model boat, and I've been tracing the body lines to make the frames.

I did do this post previously but it has disappeared. It will probably appear in some other post; Sorry.

Attachment has disappeared???
« Last Edit: March 07, 2018, 03:21:27 AM by Cothy »

Logged


March 07, 2018, 03:36:27 AM
#18
Hi Mike
Turned Redsdk off and it solved the move/copy rescaling but with nothing selected when I zoomed out the text seemed to remain the same size & occupied the screen totally.
I Then turned Redsdk on again then I was back to the original problem.
I did notice that the text that I had made previously, that's the text on the left under the vertical red lines was not having the rescaling problem so it must have happened between then and now.

Will download both 32 & 64bit files.
Cheers for now.

Still cannot find that attachment..

Logged


* March 08, 2018, 02:17:05 AM
#19
You mentioned a computer upgrade .. along with Win-10.

Could be your Video Card ... or Video Card software thats an issue.

I take it that all was fine prior to Win-10

I would post up a sample of your file for others to test.
I can't open TC 2017 files ... as i have TC Plat 2016

Cheers
Mike






Logged


March 08, 2018, 07:07:09 AM
#20
Hi Mike
Just to clarify my upgrade; I should really have said change, as I decided that my 15year old dell should be retired.
I purchased another Dell; an XPS8920
Intel core i7-7700, CPU @ 3.60Hz  3.60GHz, RAM 16.0GB System 64-bit.
Video card is a NVIDAGeForce GTX 1060with 6GB GDDR5 Graphics Memory
All software came preloaded (Office, McAfee, etc)
Windows 10 Home Built in.
After a couple of months I Upgraded TurboCAD v19 Pro Platinum to 2017 Pro Platinum. Downloaded from Imsidesign.com with a memory stick hardcopy.



Logged


March 08, 2018, 07:25:19 AM
#21
Before I uninstalled TurboCAD I noticed in Control/Programs & Features/ turbocad Pro Platinum that when I clicked it The bar above showed Uninstall/Change/Repair so nothing lost I chose Repair and when it stopped running the size column showed 1.8Gb instead of the 2.8GB previously.
When I opened turbocad the design director was now showing all the layers and filters.
The next day taking your advice I downloaded both 32 & 64bit versions. The size column then read 1.31GB.
No change in the scaling text problem.
Working on reducing the file size as at the moment it's too large to post, even Zipped.
Going to delete layers and embedded images then run a purge to see if that works. May have to open new post and put a link in. When I learn how to do that.
Hopefully will post reduced file later.

I like the idea about a computer with NO internet connection.


Logged


March 09, 2018, 07:41:21 AM
#22
At last got the file down to a post able size. I think it was the image manager's files that kept it large.
See Hopefully the attachment.

Logged


March 09, 2018, 07:53:16 AM
#23
Just had a thought and went back into programme. Then went to Save as/file type and was able to save as 2016 & 2015 Formats as well, so please find attached.


Logged


* March 09, 2018, 04:35:20 PM
#24
I downloaded and had a look at your file
i am using TC 2016 Plat


Cothy ....
Nothing wrong with your TC 2017 program ... so you can STOP looking in that direction.  :)

1: Click on World Plane ... Top ... (You already have this set)
2: WORKPLANES
You have it set to >> Auto Workplane by facet >> Set it to >> Plane by active view
3: Select a column of your Text >>> Now go >> Modify > Place on WorkPlane
4: (With the column of text still selected) Right Mouse Click >> Properties > Text > untick "Non Zooming" (leave the Non-rotating ticked at this stage)
5: Deselect (esc) and zoom in and out ... The TEXT you altered should behave as normal.
6: Select that TEXT you altered ... Right Mouse Click >> Copy then paste it to a new spot.
Now Zoom in and Out .... and it should be now OK

All the other TEXT on the file will still act weird ... As this needs to be altered, as you did with the TEXT instructions, as per above.

When i selected your Text and (in properties) un ticked "Non-rotating" ... Your text flipped Backwards >> As in ... it was facing away from you. Like looking out of a Shop window from the inside and the words on the glass are facing the street (Backwards).

You have created this TEXT on a WORKPLANE that was set in that direction .... So when you tried to look at it when you clicked "World Plan" .... it all looked backwards.

----------------------------------------------------------------------------------------------------------------------------------------------------

I then added Fresh Text to the file.
1: I used the normal default setting of the properties of the Text set to "Standard" and both "Non-rotating" and "Non-zooming" left UN-checked (NOT Ticked)

2: Then typed some words ... and all worked fine.

-------------------------------------------------------------------------------------------------------------------------------------------------------

So to conclude .....
Your problem has occurred due to "Workplane" selections and not using "Place on Workplane commands"  ;)

Hope the above gets you back on track ...  :)

Cheers
Mike


 
« Last Edit: March 10, 2018, 04:19:26 PM by Mike90RR »

Logged


March 10, 2018, 07:39:12 AM
#25
Hi Mike
It's working!!
Went slowly through the steps as instructed, and as you said it is now working.
I started with version 14 Deluxe and did not have the problems then, I must have followed the manual then and set the settings that I required with upgrades following those settings until 2017 pro came along. Which was a new upgrade in a new computer.
Your instructions are clear and precise and they took me step-by-step through the corrections.
Many posts that I read just threw in commands like "Cntrl+Alt+W" or "Plane by Active View" without the previous steps or setting locations which sent me in "Square Circles" where confusion and non learning lurk.
Your instructions did not do that and I learned from them.
So thank you again.
And also Alvin Gregorio for his input, much appreciated.
Thanks.

Logged


* March 10, 2018, 01:05:47 PM
#26
Hi Mike
It's working!!
...
And also Alvin Gregorio for his input, much appreciated.
Thanks.

Good deal.  It's always a good idea to attach the problem file when originally posting with a Problem.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)