TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Clipping an Image
Read 2389 times
* January 19, 2018, 08:47:34 PM
How do you clip an image in tcw2017PP, can someone please describe each step as there is no info in the 2017 help file that matches the ImageClipTutorial image below? ( Tutorial designed in V21PP )

All I have is the ImageClipTCW2017 tools available!



Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 19, 2018, 09:52:36 PM
#1
Try loading the "Classic" configuration or click on the "Default" button. Both have a complete "Image" toolbar. My custom configuration, which was made many versions ago, also has an anemic Image toolbar.

You can drag out the "Clip Raster Image" tool to the "Image" toolbar.

Use the "From File" tool to insert an image (upper left to bottom right).
Draw a closed 2D entity over the image; closed polyline, circle, ellipse.
Activate the "Clip Raster Image" tool.
Click on the image.
Click on the 2D entity.
You should now have a clipped image.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* January 19, 2018, 10:55:19 PM
#2
Hey John thanks mate, I just overlooked the tool in all commands.

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 19, 2018, 11:14:38 PM
#3
I still cant find the clipping tool, and changing to the classic config doesnt help either?


Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 19, 2018, 11:17:37 PM
#4
Not mentioned in the help file either!

tcw build


// serial number edited out  (mod)//
« Last Edit: January 20, 2018, 04:59:18 PM by Andy H »

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 19, 2018, 11:53:10 PM
#5
Okay found it in the help file.

But the tool Clip Raster Image is not found in tcw2017, tcw2016 or tcw21 pp. Not found in All Commands either.

Changing themes/configuration doesnt solve it either. ( Go figure, its a conspiracy haha, but not so funny )

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 20, 2018, 05:47:52 AM
#6
Ive checked my v21, v2016 & v2017 PP, clipping a raster image is not found in any of the versions mentioned. Not found in All Commands.

How can I resolve this?

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 20, 2018, 06:25:56 AM
#7
Check " image " in the Customize/ Toolbars >> Image

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* January 20, 2018, 06:41:28 AM
#8
Torfinn just tried your idea, have only got access to the attched image

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 20, 2018, 07:34:26 AM
#9
In my copy of TC 2017 Pro Plat I found the tool at Modify>Clip>Clip Raster Image.  Is this what you want? 

Just offhand, could you send an image of what you get when you go to Help>About TurboCad?  That would let us know the exact version and build you are using.

Wayne
« Last Edit: January 20, 2018, 07:53:57 AM by wrkempson »

Logged


* January 20, 2018, 08:30:54 AM
#10
I also have the Clip Raster in there+ UV mapping tool, i doubt that i have put it there from Customize/ Command, and i find it there aswell.
And also in the dropdown Modify menu.
In a new from scratch drawing, cfg = Default, metric system

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* January 20, 2018, 08:37:14 AM
#11
In the Customize>Commands page of my 2017 installation, it's called "Raster Image\Clip Raster Image."

Henry H

Logged


* January 20, 2018, 10:37:59 AM
#12
Ive checked my v21, v2016 & v2017 PP, clipping a raster image is not found in any of the versions mentioned. Not found in All Commands.

How can I resolve this?

I don't have it either, Darryl  ;D
64 Bit V19,20,21,2015,2016 and 2017.

BUT

I do have it in 2017 32 bit.
I wonder, I mean just a guess > maybe all their "new" 64 bit builds don't have it.
I recently updated all my builds from the "updates and patches".
I tried a repair in 64 bit, didn't do anything and I'm not doing that ridiculous builtin folder thing  :P

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2018-2017, TurboCad Platinum 21.Using Lightworks and Redsdk, Anilab lab 5. ATI Mobility Radeon HD 4500/5100


* January 20, 2018, 10:54:49 AM
#13
This is what I get in 2017 Platinum (24.0.62.2) 64-bit when I click on the Default button. There are no 32-bit installations on this computer.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* January 20, 2018, 11:20:38 AM
#14
I have the same as John R and like him, no 32 bit, Infact there has never been a 32 bit version on this machine as i stop testing 32 bit at v 19.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* January 20, 2018, 11:30:50 AM
#15
I have an old eMachines desktop that I inherited years ago and that gets the 32-bit versions of TurboCAD.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* January 20, 2018, 12:50:59 PM
#16
All of my 32 bit versions have it
and
all of my 64 bit versions don't  ;D

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2018-2017, TurboCad Platinum 21.Using Lightworks and Redsdk, Anilab lab 5. ATI Mobility Radeon HD 4500/5100


January 20, 2018, 01:17:48 PM
#17
All of my 32 bit versions have it
and
all of my 64 bit versions don't  ;D

Which begs the question, would removing the 32-bit versions and reinstalling/repairing the 64-bit versions resolve the problem?
Like Torfinn and John R, I only have 64 bit versions installed, with the 'missing' tool/s available.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2017 and TurboCAD Pro. Plat. 2016/2017/2018 + Lightworks (64-bit versions).


* January 20, 2018, 02:16:57 PM
#18
Had a pretty late night but I will check now In the 32 bit version. All my builds were updated recently.

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 20, 2018, 02:38:51 PM
#19
This is what I get in 2017 Platinum (24.0.62.2) 64-bit when I click on the Default button. There are no 32-bit installations on this computer.

Hey John I dont get ( clip raster image ) in the 64bit version, but I do have it in the 32bit version tcw2017 PP build 38.2.

Mine is the same as Deans setup, its not in any 64bit version only in the 32bit versions.

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


January 20, 2018, 02:40:48 PM
#20
I have never had 32 bit TC on my new computer either. Clipping has been available an every 64-bit version I have installed on it.


* January 20, 2018, 02:46:27 PM
#21
Can anyone confirm who is running an older 64bit version ie: NOT A RECENT UPDATE if they have ( clip raster image ) installed as a tool on their machine?

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


January 20, 2018, 02:47:59 PM
#22
Don't know if these are part of it but do you have these:


* January 20, 2018, 03:02:53 PM
#23
Yes Don both those files do exist in tcw2017PP 64bit install ( program64\draggers ) folder

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 20, 2018, 03:49:34 PM
#24
Can anyone confirm who is running an older 64bit version ie: NOT A RECENT UPDATE if they have ( clip raster image ) installed as a tool on their machine?

In my 21.2.59.0 64-bit installation, it's available via the Customize dialog.

Henry H

P.S. Also in my 20.2.51.3 64-bit installation.
« Last Edit: January 20, 2018, 03:53:59 PM by Henry Hubich »

Logged


* January 20, 2018, 04:19:26 PM
#25
Can anyone confirm who is running an older 64bit version ie: NOT A RECENT UPDATE if they have ( clip raster image ) installed as a tool on their machine?

In my 21.2.59.0 64-bit installation, it's available via the Customize dialog.

Henry H

P.S. Also in my 20.2.51.3 64-bit installation.


Those aren't their "New" builds Henry, that they put out a year or so ago.
i have all the "new" builds installed.

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2018-2017, TurboCad Platinum 21.Using Lightworks and Redsdk, Anilab lab 5. ATI Mobility Radeon HD 4500/5100


* January 20, 2018, 04:41:29 PM
#26
Can we get one of the developers / programmers to confirm if the tool was/is designed for use in either or both 32bit & 64bit versions.

Seems to me that a complie time buld switch might be the fault here or that the status of the windows version ( update ) is the problem. Not much else can explain why say Dons & Tims 64bit version has the tool and yet Dean & mine dont!


Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


January 20, 2018, 05:03:59 PM
#27
Can we get one of the developers / programmers to confirm if the tool was/is designed for use in either or both 32bit & 64bit versions.

Seems to me that a complie time buld switch might be the fault here or that the status of the windows version ( update ) is the problem. Not much else can explain why say Dons & Tims 64bit version has the tool and yet Dean & mine dont!



Have you tried uninstalling and reinstalling?

Have you tried seeing if using TC classic interface makes a difference if you are suing the new interface?


* January 20, 2018, 05:17:31 PM
#28
I have not tried Uninstall & reinstall, I have tried different configurations like JohnR suggested but this did not fix the tools visibility.

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 20, 2018, 05:22:35 PM
#29
Just used tcw2017 32bit version to overcome the need to use that tool in a tutorial. I guess for now I will use both the 32bit & 64bit for the remainder of the task ahead.

Thanks to all who contributed here, at the very least Im not stuck in limbo.
 ???

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 20, 2018, 07:51:23 PM
#30
Just thought I'd test my systems, 32 bit v18, 64 bit v19 to v2017, all 7 versions have clip raster.

On spare computer, which already had 64 bit 2016 build 61.2,  clip raster working,  installed 32bit 2016 latest build from forum updates page, raster working, closed program, re-opened 64 bit 2016, raster still available and working,  shut down computer (after windows had piled on a load of updates), restarted computer, 64 bit still has clip raster.

No help, I know, but from the above test, it seems like both 32 and 64 bit versions (on the same machine) are set up to utilise the clip raster.

Logged


* January 20, 2018, 10:08:16 PM
#31
I checked my laptop upstairs, a "Windows 10 Home" machine with TurboCAD 2017 Platinum (64-bit); it doesn't have the "Clip Raster Image" or "Image Manager" tools.
The workstation downstairs has "Windows 10 Pro". It has all the image tools.

I went back up and tried "Run as Administrator"; the image tools are there when this is used.
I shut down TC and restarted normally; no image tools.
Windows doesn't like something in those tools in that it blocks them from working.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


January 21, 2018, 08:16:20 AM
#32
Just used tcw2017 32bit version to overcome the need to use that tool in a tutorial. I guess for now I will use both the 32bit & 64bit for the remainder of the task ahead.

Thanks to all who contributed here, at the very least Im not stuck in limbo.
 ???

Another option would be to use a photo editing program to create 3 cropped images for the 3 views and insert them separately instead of clipping as is done in the exec jet tutorial.


* January 21, 2018, 08:25:47 AM
#33
I checked my laptop upstairs, a "Windows 10 Home" machine with TurboCAD 2017 Platinum (64-bit); it doesn't have the "Clip Raster Image" or "Image Manager" tools.
The workstation downstairs has "Windows 10 Pro". It has all the image tools.

I went back up and tried "Run as Administrator"; the image tools are there when this is used.
I shut down TC and restarted normally; no image tools.
Windows doesn't like something in those tools in that it blocks them from working.

I find that kinda disquieting.

Henry H

Logged


* January 21, 2018, 09:20:32 AM
#34
I checked my laptop upstairs, a "Windows 10 Home" machine with TurboCAD 2017 Platinum (64-bit); it doesn't have the "Clip Raster Image" or "Image Manager" tools.
The workstation downstairs has "Windows 10 Pro". It has all the image tools.

I went back up and tried "Run as Administrator"; the image tools are there when this is used.
I shut down TC and restarted normally; no image tools.
Windows doesn't like something in those tools in that it blocks them from working.

This reminds me of my version-11 not working 100% on a Windows-7 machine issue.  Where I (we) have to "turn off" Windows User Account Control to get that old version to work fully.  With UAC set to anything but "off", some tools are missing.

Just thought that might help someone(s) with diagnosing the underlying cause and perhaps remedy.

-Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


January 21, 2018, 09:28:28 AM
#35
I checked my laptop upstairs, a "Windows 10 Home" machine with TurboCAD 2017 Platinum (64-bit); it doesn't have the "Clip Raster Image" or "Image Manager" tools.
The workstation downstairs has "Windows 10 Pro". It has all the image tools.

I went back up and tried "Run as Administrator"; the image tools are there when this is used.
I shut down TC and restarted normally; no image tools.
Windows doesn't like something in those tools in that it blocks them from working.

This reminds me of my version-11 not working 100% on a Windows-7 machine issue.  Where I (we) have to "turn off" Windows User Account Control to get that old version to work fully.  With UAC set to anything but "off", some tools are missing.

Just thought that might help someone(s) with diagnosing the underlying cause and perhaps remedy.

-Alvin

Interesting. I am running widows 10 home and I do have my UAC setting set to never. I think I did, at one time, set TurboCAD TC 2017 to run as administrator and slid this to never so I would not get the control dialog pop up every time.

Great team work - sussing this out.


* January 21, 2018, 01:57:01 PM
#36
Confirm when I run as admin the clip raster image tool is available. I didnt get to try it yet as we just lost power to our house. So why is that the tool is only available when I run as admin and others have it.

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 21, 2018, 02:13:16 PM
#37
re: …So why is that the tool is only available when I run as admin and others have it.

Possibly due to the operating systems. The tools that are missing on my "Windows 10 Home" system are available in "Windows 10 Pro" system.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* January 21, 2018, 02:31:40 PM
#38
Ok so it would seem that it boils downto the Windows updates based on Johns feedback and I reckon thats about right. So with the benefit  of  hindsight those close to IMSI should point out that it maybe smart to put a permanent post up in the forum problems page about this topic in general, advising that if you have problems with functionality that you should make sure you have updated your windows software.  Thats my two bobs worth.

Don thanks for the tips!
Alvin thanks to you, your tips helped!
Dean can you confirm based on the  last couple of post how your system is now?

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 21, 2018, 02:46:31 PM
#39
Ok so it would seem that it boils downto the Windows updates based on Johns feedback and I reckon thats about right. So with the benefit  of  hindsight those close to IMSI should point out that it maybe smart to put a permanent post up in the forum problems page about this topic in general, advising that if you have problems with functionality that you should make sure you have updated your windows software.  Thats my two bobs worth.

Don thanks for the tips!
Alvin thanks to you, your tips helped!
Dean can you confirm based on the  last couple of post how your system is now?

Still don't have it  ;D
I never wanted to update to their "new" builds, but I did anyways.  ;D I should of followed my instincts.
My windows 7 is up to date.




Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2018-2017, TurboCad Platinum 21.Using Lightworks and Redsdk, Anilab lab 5. ATI Mobility Radeon HD 4500/5100


* January 24, 2018, 02:54:48 PM
#40
Previously used in the 32bit version only. But you can get it in the 64bit version. Run tcw2017 pp as administrator. Go to Customise - Commands - All Commands and the clip raster image tool is now available.

But why do you need to run as administrator to access to the tool? :-\

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best