TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


In 3D Isometric mode, selected elements do not highlight
Read 1090 times
* January 07, 2018, 08:48:25 AM
Using TC 2017 Deluxe on a Surface Pro 3 / i7 / 8GB RAM and external display.

If I select a 3D object while in 3D Isometric mode, the object does not highlight in magenta and does not move in a way I would expect. What am I doing wrong?

1. Start TC, put it into Isometric_SE view.
2. Choose 3D Box and draw two of them.
3. Press Space to change to Select mode.
4. Select one of the boxes. The cursor changes to a 4-arrow cross and I see "Edit the selected object(s)" in the status bar, but the chosen object does not highlight in magenta. Why not?
5. Press D. The box now changes to magenta, the mouse cursor now changes to the hand so I can set a new reference point and when I click the new point the RGB XYZ arrows appear.
6. If I click-and-drag to move the object, the object reverts to black, a second black copy of the object appears, and the second copy moves while the original stays in place. When I click its new position, the moved copy disappears and the original object in its original position changes back to magenta. If I then press Esc, the original object/position disappears and the object now appears in its new location. Why this behavior?

What have I done wrong with my setup that this is happening? In Paul Taylor's 3D object intro (admittedly created with Pro), the object immediately turns magenta when selected and shows none of the weird behavior I describe above.

Thanks.
« Last Edit: January 07, 2018, 08:59:40 AM by karlperry »

Logged


* January 07, 2018, 09:01:43 AM
#1
If the Reply form turns up blank when trying to "Preview", use the "Back" button to return to your original Reply page (your post should still be there), then try "Preview" again. You should then get a Preview and a filled Reply form.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* January 07, 2018, 09:52:12 AM
#2
"4. Select one of the boxes. The cursor changes to a 4-arrow cross and I see "Edit the selected object(s)" in the status bar, but the chosen object does not highlight in magenta. Why not?"

At the top of the Selection Info palette, click the icon that looks like a surrealistic eyeball ("Tooltip calls it "Highlighting.")

Henry H

Logged


* January 07, 2018, 06:11:03 PM
#3
"4. Select one of the boxes. The cursor changes to a 4-arrow cross and I see "Edit the selected object(s)" in the status bar, but the chosen object does not highlight in magenta. Why not?"

At the top of the Selection Info palette, click the icon that looks like a surrealistic eyeball ("Tooltip calls it "Highlighting.")

Henry H

I assume you wanted me to choose Tools, then Palettes, then click "Selection Info ...", and then choose the Highlighting button at the top of the palette that displays. It already appeared to be "pressed" but regardless of its state, it had no effect on whether an element changed from its default black color to the magenta "selected" color when I click on the element. This appears only to affect the color of the element, not whether its color changes to indicate that it is the currently selected item.

Any other thoughts?

Logged


* January 07, 2018, 06:33:37 PM
#4
I'm curious, karlperry:  What User Interface Theme are you using?  Can you provide a screen-capture of your full TurboCAD window?
If you can create that screen-capture while the "behavior" is occurring, that'd be even better.
Even better yet, if you have the ability to create a short animation illustrating the behavior-- a .gif would do--  that'd be the quickest path to resolving your issue.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* January 08, 2018, 07:47:44 AM
#5
Alvin, I'm using the TurboCAD Classic theme. The black theme of the new UI doesn't appeal to me and the scroll bars pretty much disappear into my display, making that theme difficult to work with.

Having problems getting my reply to post. I'll post this, then post the attachment.

I've attached an .AVI file illustrating the problem. Apologies for the low quality - the original high-res file at 15.9MB would not post. Hopefully this low-res 7.9MB file will.

Thanks again for helping.
« Last Edit: January 08, 2018, 07:59:17 AM by karlperry »

Logged


* January 08, 2018, 05:39:23 PM
#6
...I've attached an .AVI file illustrating the problem. Apologies for the low quality - the original high-res file at 15.9MB would not post. Hopefully this low-res 7.9MB file will....

I can't seem to open your .avi file without it crashing the program I am using to view it-- Windows Media Player and/or IrfanView.
I don't know if others are having the same issue; my computer is pretty lame.

Without some sort of image or video, it's going to be pretty tough to help with you with your issue.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* January 08, 2018, 08:27:06 PM
#7
Hi Alvin - thanks for trying. I downloaded it myself and of course it worked ... :o

I'm attaching six images:
1. After I have created two boxes, put TC into Select mode but haven't selected anything yet.
2. I clicked on the right-hand box. Notice it is the same color as before - I would have expected it to turn magenta as I selected it. Not turning magenta is not intuitive - I don't know which object I selected.
3. I chose "Edit Reference Point" and the box finally turned magenta. I've also noticed that if I click the box again (after the initial selection) it turns magenta then as well.
4. I am moving the box to be adjacent to the box on the left. The box is still magenta in its original position but black as I move it.
5. I've clicked again once the right box is adjacent and it simply disappears, leaving the magenta box in the original position. At this point I think the move operation has failed ...
6. ... but if I press Esc, the magenta box disappears from the original position and the black box reappears at the moved position.

I hope this makes sense and that you can provide some suggestions. Thanks again.

Logged


January 09, 2018, 02:22:00 AM
#8
Hi karlperry,

    does the problem still persist, when running without the external display?
    Have you tried running under GDI mode?

Regards Tim
« Last Edit: January 09, 2018, 02:54:27 AM by Tim Stewart »

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2017 and TurboCAD Pro. Plat. 2016/2017/2018 + Lightworks (64-bit versions).


* January 09, 2018, 02:44:35 AM
#9
I got the same behaviour as karlperry when using redsdk in 2017pp. When I started using gdi it stopped!

Logged
Thanks Daz
TCW V21, 2016 & 2017 PP, Animation Lab V5, Graficalc, TCMap, TurboPDF V2-V3 & Lightworks mostly
Windows 10 Home ed. i7 @ 3400Ghz, 16GB, Nvidia 960GTX 4GB ram, 2TB HD, 500GB SSD & 128GB SSD

Good better best
Never let it rest
Until your good is better
And your better is best


* January 09, 2018, 07:07:43 AM
#10
Tim, apologies. The problem persists regardless of whether I use the internal or external display. The images and video were done using the internal display. I should have pointed out that change.

I switched to GDI mode and now the box highlights as I select it - see the attached image.

Begs the question: how much performance increase is there with RedSDK vs. GDI?

Logged


January 09, 2018, 08:10:54 AM
#11
I use GDI + LightWorks almost exclusively, as I find it gives far fewer display problems.
The "devil" I know.  :)

Some prefer RedSDK, and it's very fast with complex hidden line renders and manipulation.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2017 and TurboCAD Pro. Plat. 2016/2017/2018 + Lightworks (64-bit versions).