TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Bend to path leaves artifacts in render
Read 171 times
January 04, 2018, 01:32:41 PM
I'm experimenting with easy ways to make scroll designs for blacksmithing. I created a wedge and drew a spline, then used the Bend to Path tool to bend the wedge to the spline. It looks fine in Wireframe and Hidden Line, but with Draft Render (Redsdk) there are some weird surfaces present in the inner portion of the curve that don't belong. Is this a Redsdk problem? or a Bend to Path problem?

Logged
Brian Yates
TCPro plat v18.2
TCPro plat 2016
Windows 10
GeForce GTX 950


* January 04, 2018, 01:53:15 PM
#1
The only problem I see is that the "Faceter Quality" should be moved to 100.

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* January 04, 2018, 06:30:25 PM
#2
The only problem I see is that the "Faceter Quality" should be moved to 100.\


That's still pretty faceted (to my eye).  I hate facets.  Work hard on creating a curved or compound-curved Object, and... facets.  They're a bummer.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* January 04, 2018, 07:05:50 PM
#3
The only problem I see is that the "Faceter Quality" should be moved to 100.\


That's still pretty faceted (to my eye).  I hate facets.  Work hard on creating a curved or compound-curved Object, and... facets.  They're a bummer.

It looks fine in my 2017 installation, Alvin. It's often necessary to save and then reopen the drawing after changing the Faceter Quality. (My own material, BTW.)

Henry H

Logged


* January 04, 2018, 07:55:12 PM
#4
The only problem I see is that the "Faceter Quality" should be moved to 100.\


That's still pretty faceted (to my eye).  I hate facets.  Work hard on creating a curved or compound-curved Object, and... facets.  They're a bummer.

It looks fine in my 2017 installation, Alvin. It's often necessary to save and then reopen the drawing after changing the Faceter Quality. (My own material, BTW.)

Henry H

Maybe John's posted image was a "before" (changing Faceter Quality to 100).  I never kick it up to 100 because of my limited and struggling computer; it usually can't handle it.
I'd say I need to stop chiming in on more-recent-than-version-21 topics.  Since that's the most recent I have.  I'll make more effort.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* January 04, 2018, 08:37:44 PM
#5
The only problem I see is that the "Faceter Quality" should be moved to 100.

That's still pretty faceted (to my eye).  I hate facets.  Work hard on creating a curved or compound-curved Object, and... facets.  They're a bummer.

It looks fine in my 2017 installation, Alvin. It's often necessary to save and then reopen the drawing after changing the Faceter Quality. (My own material, BTW.)

Henry H

Maybe John's posted image was a "before" (changing Faceter Quality to 100).  I never kick it up to 100 because of my limited and struggling computer; it usually can't handle it.
I'd say I need to stop chiming in on more-recent-than-version-21 topics.  Since that's the most recent I have.  I'll make more effort.

The left-side image is at 50 (original setting) and the right-side image is at 100. Copy-n-pasted together in PSP-X.

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


January 05, 2018, 04:26:14 AM
#6
That was exactly the setting I needed to adjust. Even bumping it up to 60 eliminated the erroneous feature. The perspective you were showing in the screen shot would've covered up the part I was having trouble with. If you change to a plan view and look toward the very center of the scroll you will see it, almost like a flange coming off the edge.
 Thanks again everyone!

UPDATE: It is still happening on a different drawing, even with the Faceter value up to 100. It's much smaller now, but still there. I'll have to try something else. If I give the wedge a little extra thickness (Quick Pull 0.1") and bend along the same spline, the result is perfect. Maybe the Bend to Path doesn't like dealing with very thin objects.
« Last Edit: January 05, 2018, 07:33:05 AM by bebo »

Logged
Brian Yates
TCPro plat v18.2
TCPro plat 2016
Windows 10
GeForce GTX 950


January 10, 2018, 12:33:41 AM
#7
UPDATE: It is still happening on a different drawing, even with the Faceter value up to 100. It's much smaller now, but still there. I'll have to try something else. If I give the wedge a little extra thickness (Quick Pull 0.1") and bend along the same spline, the result is perfect. Maybe the Bend to Path doesn't like dealing with very thin objects.

Bring up the ACIS popup menu again and click on the Expert Faceter Parameters radio button, then adjust the settings that are now not grayed out.

Best to experiment with one setting at a time, and probably one of the first three.


Jeff

Logged
TC Pro Platinum 2017, 2016 & 2015 (all with LightWorks) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1