TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


Inserting autocad files into Turbocad 2016 (windows)
Read 752 times
* December 29, 2017, 10:06:23 AM
Hi
I am new to using Turbocad, less than a week, so please excuse this question, if I am missing something obvious.
I am trying to create a 2d layout of a school hall into which I then want to "drop in" objects which I can then move around to get the best arrangement. very similar to doing an office desk arrangement.

I have created the basic layout of the hall in Turbocad without too many problems.
The objects I want to drop in, are all in Autocad files in DWG format. I have been trying to do this by inserting a file of each object into the hall drawing.
The problem is that the that the object, when inserted into the Turbocad hall plan is far bigger than it should be.

Can anyone help me with what I am doing wrong or what I need to do. There is an added pressure of time on this as I need to complete the drawing in the next few days.
Thanks
Huw

Logged


* December 29, 2017, 10:27:03 AM
#1
Try take away checkmark on " Convert Units after alteration..... in Options/ Space Units if it's on, and also pay attention to same thing in the import menu, there is another scale option.
For the stuff you have already inserted you can change the scale on it ( 1/ 25.4 = 0,03937007874015748031496062992126 )
but normally 6 decimals is close enough.

It can also be scaled before inserting, check if Modelspace in Options/ Space Units is Full size ( 1:1)

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* December 29, 2017, 12:43:03 PM
#2
Torfin
Convert Units check box is unticked. You mention an Import menu but I cannot see this, only an Insert menu, which is the one I have been using?
Modelspace in Options/ Space Units is set to full Full size.
Huw

Logged


* December 29, 2017, 01:55:40 PM
#3
Import/ insert menu, same same but different :)

But it can also be that the object are scaled already in AutoCAD, then you will need to scale them yourself, maybe.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* December 29, 2017, 11:29:01 PM
#4
If you are working with metric files, run a page setup wizard change imperial to metric and click next until page 6 and save.
This changes the default of your system to metric and when opening or importing dwg files they wont be opened with imperial setting. The other thing I do is open the dwg file check the sizes and save as a tcw file.

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


December 30, 2017, 12:41:26 PM
#5
Convert Units check box is unticked. You mention an Import menu but I cannot see this, only an Insert menu, which is the one I have been using?
Modelspace in Options/ Space Units is set to full Full size.

TurboCAD imports AutoCAD files in Metric.  If your default Template is Imperial, then imported AutoCAD objects will be 24.5 times larger than intended.

The quickest conversion is to pop up the Options / Space Units menu, select Metric, make sure the Convert units radio button is not active and click Okay.

Then bring up the Space Units popup again, select Imperial and make sure the Convert units radio button is active before clicking Okay.


Jeff

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1