TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Background color not printing ??
Read 1428 times
December 28, 2017, 12:24:31 PM
Hello, I am sure this is just something I am missing (Yeah, like a brain!!! :) ) but I have an image that needs a dark gray background. I have found the correct color and I changed the background on both Model and Paper space. But when I print (To PDF) the background is white?
Can see what I am doing wrong?? Its been a long day :(

Please help

James B


Logged
"Was" Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


* December 28, 2017, 01:20:09 PM
#1
I find that "Background Color" only works when in a rendered mode; when in Wireframe, it uses white (no color?).

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* December 28, 2017, 03:39:29 PM
#2
Are you looking for background within the Image to be dark gray?
Or the background that lies outside the boundaries of the Image?
Can you post the Image please.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


December 29, 2017, 10:07:30 AM
#3
Hello,
Ok so please see the attached image, as you can see i have the Image in Paper Space and it has a dark gray background. It is rendered using Raytrace Fine.
When I do the page setup (or preview) you can see that it show a white background???? I have tried this with Global Illumination Fine and its the same :(
Help Please Im so confused :)

James B



Logged
"Was" Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


* December 29, 2017, 10:33:17 AM
#4
This is just a preview, it dont take effect from your rendermode.
It also seem like you use scale to fit, that is normally not a god idea as you dont know the size of printed Object.
If you need to scale anything it is better to do that with control, aka 1:100, 1:50 etc from viewport menu.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


December 29, 2017, 10:53:15 AM
#5
Hi Torfinn, Thanks for the quick reply, Im not 100% sure i understand your reply thou, yes it is a preview but that is the way it prints as well see attached screen shot 2
I only print these images to PDF and then use Snip tool to add them to the Datasheets/Website pics I produce so i am not sure why the scale would make a differance? I use it so that the image is centered and as big as possible.

James B

Logged
"Was" Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


* December 29, 2017, 10:57:27 AM
#6
Hello,
Ok so please see the attached image, as you can see i have the Image in Paper Space and it has a dark gray background. It is rendered using Raytrace Fine.
When I do the page setup (or preview) you can see that it show a white background???? I have tried this with Global Illumination Fine and its the same :(
Help Please Im so confused :)

James B


Hello James.  First off, I agree with Torfinn on the Printing Scale thing.  Best practice in Paperspace to leave it 1:1; Full Size.  Then control with "Fixed Scale" in Viewport Properties (or a zoomed-in View, if in Perspective; I like to use the Walk Tool, while in Floating Modelspace mode to do this)

Okay... that was the off-topic side-note.

Examining your posted image, and experimenting with the issue in my version-20ProPlatinum, what I think might be causing your issue is:

You have no Render Scene Environment.  Try this:  Go to Render Scene Environment, and select Background/Graduated.  Go into Edit/Luminance, and set a new one, with a Gray background.

I think that will work.  I think that maybe the only reason you have a "gray" background is that you have very little illumination in your scene either by Standard Lights and/or Luminance.  [edit: not so sure...]
« Last Edit: December 29, 2017, 11:15:39 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* December 29, 2017, 11:11:23 AM
#7
An example of what I recommended in my just-previous Post is attached here.  If you have the Lightworks plug-in, you should be able to open it with my Lightworks Environment and Luminance making the transition.  [edit:  whoops... I just noticed you are working with Deluxe; my Objects are ACIS Solids, so you won't be able to use my file effectively James]

If you have Lightworks, please see if you can open it James and if you have success printing Paperspace "Paper 4" to PDF.  It should look like the PDF also attached.

When opening my file, if TurboCAD gives you "prompts" such as adding Environment or Luminance types, click on "Rename" (or whatever it takes to get them added to your database).
« Last Edit: December 29, 2017, 11:28:11 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


December 29, 2017, 11:21:33 AM
#8
Hello,

I dont know enough about editing the Material or the Luminance or Environment. I tried to follow your instructions but hmmmmm.
I dont see where I can choose the color to change to?? See attached is this the right place?

Also I do want the Dark Gray back ground so I can match the images on our website. I have had to use Snip the image to use as a quick workaround.


« Last Edit: December 29, 2017, 11:23:25 AM by Jamesb »

Logged
"Was" Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


* December 29, 2017, 11:23:42 AM
#9
Hello,

I dont know enough about editing the Material or the Luminance or Environment. I tried to follow your instructions but hmmmmm.
I dont see where I can choose the color to change to?? See attached is this the right place?

Also I do want the Dark Gray back ground so I can match the images on our website. I have had to use Snip the image to use as a quick workaround.




I think there is a good chance this is your issue.  Someone with 2017 RedSDK will have to help you with creating and assigning an Environment Background.
Do you have the Lightworks plug-in?  You would have had to have purchased it.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


December 29, 2017, 11:41:21 AM
#10
Hi Alvin,

I figured it out :) Thank you, I "Snipped" an image of the color needed and then saved that in the same place as the Backgrounds ares saved and then i used that image as the Background File Name :)
And it worked :) so happy :)

Logged
"Was" Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


* December 29, 2017, 11:46:45 AM
#11
Hi Alvin,

I figured it out :) Thank you, I "Snipped" an image of the color needed and then saved that in the same place as the Backgrounds ares saved and then i used that image as the Background File Name :)
And it worked :) so happy :)

Glad it worked.  Maybe when you get a chance you can experiment with creating a RedSDK Environment that isn't an Image as a Background, but is a Color (or graduated Colors).  It's pretty simple, once you feel confident with editing Render settings-- such as RedSDK Environments.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


December 29, 2017, 12:19:13 PM
#12
Glad it worked.  Maybe when you get a chance you can experiment with creating a RedSDK Environment that isn't an Image as a Background, but is a Color (or graduated Colors).  It's pretty simple, once you feel confident with editing Render settings-- such as RedSDK Environments.
[/quote]

I will when I have some free time :)

Logged
"Was" Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


* December 29, 2017, 12:44:44 PM
#13
For what it's worth, for others reading this in the future:
   In my version-20ProPlatinum (Native Draw= GDI; Lightworks Rendering engine), I can get a Quality Rendered Viewport background color to print.  (without a Render Scene Environment assigned)
I have to set a Background Color in Modelspace and also in Paperspace.  They can even be different.  It might take a couple of Re-Draws, but it eventually has the correct-- Paperspace assigned-- Background Color, and it views and prints with it.

A Bug?  A quirk?  Who knows...
« Last Edit: December 29, 2017, 02:15:38 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* December 29, 2017, 01:09:22 PM
#14
If you only should snip it, why dont you do that from screen.
Alvin explained why 1:1
Attached snip from screen and from a TurboPDF Print, it dont get white within the pic in TurboPDF.
Both cases are RedSDK draft render and i did not care to make the color correct, only to show the grey color outside the pic, but Alvins suggestion about render scene background is better i think

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


December 29, 2017, 01:33:21 PM
#15
I print it to PDF to snip it because the quality is much better than showing on screen in TC

as you can see from the attached screen shots :) Unless agin I am missing something to make the image better on the screen in TC? I use deluxe BTW. Although I will be upgrading as soon as my boos gets back from his vacation.
« Last Edit: December 29, 2017, 01:38:20 PM by Jamesb »

Logged
"Was" Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


* December 29, 2017, 02:14:06 PM
#16
Thanks, yes i see it look sharper from the pdf.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB