TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Ambient Lighting with RedSDK Draft Rendering
Read 216 times
* December 28, 2017, 08:18:36 AM
I cannot get any lighting from the Ambient Light Source while in RedSDK Draft Rendering mode.  If I switch to Open GL, then the ambient light works.

The other light sources, Spot, Point, etc., seem to work okay.  When I have Ambient only, my model is completely dark.

This works the same on this laptop and my more capable desktop computer.

Am I missing something or is this how the program is supposed to work?

AMD A10-4600 APU Radeon HD 2.3 GHz
16 GB Ram  Windows 7 Home Premium SP1
Turbocad 2016 64b  Version 23.2 build 61.2



Logged


* December 28, 2017, 12:40:43 PM
#1
Go to "Options / RedSDK". In the "Draft Render" section, increase the "Ambient" value; try 70 (though 100 looks better).
« Last Edit: December 28, 2017, 12:45:19 PM by John R »

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* December 28, 2017, 02:09:32 PM
#2
I cannot get any lighting from the Ambient Light Source while in RedSDK Draft Rendering mode.  If I switch to Open GL, then the ambient light works.

The other light sources, Spot, Point, etc., seem to work okay.  When I have Ambient only, my model is completely dark.

This works the same on this laptop and my more capable desktop computer.

Am I missing something or is this how the program is supposed to work?

AMD A10-4600 APU Radeon HD 2.3 GHz
16 GB Ram  Windows 7 Home Premium SP1
Turbocad 2016 64b  Version 23.2 build 61.2

Yes,
something changed in 2016 and 2017 when using material. I don't know if it's a bug or as designed.
V21 and 2015 work as expected with ambient light and material.

what I found is that the +redsdk materials work with the ambient light.  ???
If you have any cut outs the Brass+Redsdlk works good, working the inner and outer color.

This only helps if you're working with color  ;D

I think John R was referring to pen color...
« Last Edit: December 28, 2017, 02:22:30 PM by Dean »

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* December 28, 2017, 03:07:17 PM
#3
Something happens when the sun was possible to use/ Adjust in Enviroment some time back, after that i need to up  the sun in Geo sun to see the shadows, i did report it back then.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* December 28, 2017, 04:24:58 PM
#4
<<<……

…This only helps if you're working with color  ;D

I think John R was referring to pen color...

When trying this out, I was only using my available “pen colors”. I don't have those fancy RedSDK materials. My preference has always been LightWorks.

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* December 31, 2017, 03:26:04 PM
#5
Thanks, everyone!

I tried models with line colors and with materials.  I also tried changing the Ambient RedSDK setting to 100 in the drawing setup.

In all cases, ambient lighting is not available in draft render view.

Though it is unfortunate that it is unavailable, I will use other light sources for draft render.  Draft render is fast and works well for my current project.

John Earl

TC 2016 Pro Plat 64b ver 23.2 build 61.2 RedSDK
Intel i5 6500 3.2G 8GB Ram Win7 Pro 64b SP1
MSI Z170-A Nvidia GTX960 Asus 27" 2560 x 1440

Logged