TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Material; Woodgrain: Delienations Detected
Read 317 times
* December 25, 2017, 04:58:40 PM
Hello All,

I'm working in version-20ProPlatinum.

Please reference the image and TurboCAD drawing file below.
What causes the "delineations" in the woodgrain Material where pointed out by the arrows.
How can it be avoided?

The model is a 48" cube with 3" fillets at all edges.  The fillets' tangency lines are shown; they don't correspond to the breaks in the woodgrain Material that I am referring to.

Also attached is the Textual Creations provided woodgrain image that is used for Wrapping in the Material.

Thanks, Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* December 25, 2017, 06:02:55 PM
#1
I haven't looked at your drawing, Alvin, but I'm wondering if you have "Renderable objects" enabled in the Render properties.

Henry H

Logged


* December 25, 2017, 06:53:03 PM
#2
I haven't looked at your drawing, Alvin, but I'm wondering if you have "Renderable objects" enabled in the Render properties.

Henry H

I do.  On purpose.  Also have Non-Renderable_Objects/Supress_Hidden_Lines enabled; that's just for some clarity in posting here.
The "break" in the Material that I'm wondering about happens regardless if Renderable and/or Non-Renderable is selected.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


December 25, 2017, 07:29:44 PM
#3
Have you seen this tip? http://www.textualcreations.ca/TurboCAD%20Tips/TurboCAD%20Tip%2014.pdf There is a discussion that looks at this starting on page 4.


* December 25, 2017, 07:51:08 PM
#4
I haven't looked at your drawing, Alvin, but I'm wondering if you have "Renderable objects" enabled in the Render properties.

Henry H

I do.  On purpose.  Also have Non-Renderable_Objects/Supress_Hidden_Lines enabled; that's just for some clarity in posting here.
The "break" in the Material that I'm wondering about happens regardless if Renderable and/or Non-Renderable is selected.
\

Try de-selecting both "Renderable" and "Non-renderable." Or, if you really want to use "Suppress Hidden Lines," click on the "Hidden Line" option in the Camera Properties dialog and enable "Suppress hidden tangency lines."

Henry H

Henry B

Logged


December 26, 2017, 03:13:38 AM
#5

How can it be avoided?


Hi Alvin,

for me the best way how can it be avoided is created own "seamless repeating textures". Special if the source texture/photo is small area from real texture (only like preview). It is posible do in the Photoshop, Gimp ... or other graphical software or is software for easy using for this purpose for example PixPlant -> https://goo.gl/cTjGDp

In the attachment is edited texture, pleas try it.

Logged
WorkPC->HP Z620 2x E5-2680v2 2,8GHz, 64GB RAM,Quadro K4000, 400GB SSD+2TB HDD, Win10 Pro 64bit
HomePC->i7-3770 CPU 3,40GHz, 16GB RAM, GeForce GTX 760, 120+60GB SSD, Win7 HP 64bit

TC Pro Plat x64
www.invent-dizajn.sk, www.facebook.com/marian.jurcak


* December 26, 2017, 03:34:22 AM
#6
Hello All,

I'm working in version-20ProPlatinum.

Please reference the image and TurboCAD drawing file below.
What causes the "delineations" in the woodgrain Material where pointed out by the arrows.
How can it be avoided?

The model is a 48" cube with 3" fillets at all edges.  The fillets' tangency lines are shown; they don't correspond to the breaks in the woodgrain Material that I am referring to.

Also attached is the Textual Creations provided woodgrain image that is used for Wrapping in the Material.

Thanks, Alvin

Issue is CNR on my side.
please see the attached ";ayout.png"file.

Logged
Rahama Shahad
SQAE
IMSI Design


* December 26, 2017, 06:09:57 AM
#7
...

Try de-selecting both "Renderable" and "Non-renderable." Or, if you really want to use "Suppress Hidden Lines," click on the "Hidden Line" option in the Camera Properties dialog and enable "Suppress hidden tangency lines."

Henry H

Henry B

Hi Henry.  I hope you and everyone else here enjoyed your Christmas day.

I just wanted to show you Henry that the Foreground Wireframe options aren't the issue I am referring to (see image below).

I'm going to assume it's a seam issue of the wrapping of the image.
I'll study Don's TurboCAD Tip that he referenced/linked, and experiment with Majo's supplied seamless textured image.

This Material was created while working through a Textual Creations tutorial "TurboCAD Pro V20 Modular Cabinets", using the tutorial's supplied Image for Wrapping, and using the tutorial's settings for the Material.

My hunch is that I am wrongly assuming that Materials such as wrapped woodgrains can be one size fits all-- that settings that work for the cabinets in the tutorial-- without visible seams-- will work for any size object in any other Drawing file.  Then again, perpaps Majo's edited image ("seamless repeating textures") is the answer.

I'll experiment and report back.

Thanks, Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* December 26, 2017, 06:14:12 AM
#8
...

Issue is CNR on my side.
please see the attached ";ayout.png"file.


Hello Rahama.  Thank you for your time in taking a look at this.

The issue I see with your rendering is that the woodgrain has seemed to dramatically changed from the woodgrain image I provided, which Majo edited and re-posted.
Grains are much too straight and uniform.

Thanks, Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* December 26, 2017, 08:23:03 AM
#9
In your case, Alvin > try using "Auto Plane" Wrapping with Majo's image

It gets it really really close  ;

Fuss around with the settings.

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* December 26, 2017, 08:47:02 AM
#10
OK, Alvin; now I see what you're referring to. I agree that a modified "seamless" image will fix the problem.

Henry H
« Last Edit: December 26, 2017, 09:06:27 AM by Henry Hubich »

Logged


* December 26, 2017, 10:02:28 AM
#11
Thanks all for the contributions.
Side-topic question, while I'm working through to learn this (Don Cheke's Tips #14 article on this is very helpful and informative):

When I opened the image provided by Majo in IrfanView, it reports being ~72dpi; the one Henry provided reports as being 200dpi.
How/why is that?
Does it make a difference in the resultant Material render?

-Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* December 26, 2017, 10:44:05 AM
#12
Thanks all for the contributions.
Side-topic question, while I'm working through to learn this (Don Cheke's Tips #14 article on this is very helpful and informative):

When I opened the image provided by Majo in IrfanView, it reports being ~72dpi; the one Henry provided reports as being 200dpi.
How/why is that?
Does it make a difference in the resultant Material render?

-Alvin

It might make a difference in the quality of the finished render, but it doesn't affect the parameters used in the Material.

Henry H

Logged


* December 26, 2017, 10:56:10 AM
#13
...
When I opened the image provided by Majo in IrfanView, it reports being ~72dpi; the one Henry provided reports as being 200dpi.
How/why is that?
Does it make a difference in the resultant Material render?

It might make a difference in the quality of the finished render, but it doesn't affect the parameters used in the Material.

Henry H

That's kinda what I figured.  How/why, do you assume Henry, your and Majo's image was so much different in DPI values?


Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* December 26, 2017, 10:59:04 AM
#14
What I've learned:

>Use a good image for the Wrapping
>Play around with the Material settings-- a lot!
>Just because the Material works for one Object in one Drawing, does not mean it will work well for all similar Objects in all Drawings
>Be prepared to invest a lot of time for each Object/Material
>Have a decent computer (mine is on its last legs)
>Keep in mind how realistic I need the Material to look (in the image below, I don't know that that seam at the tangency lines would really happen in real life-- I guess it would depend on how this cube was constructed)

I can see why people get addicted to this stuff.  And I can see why you all have hundreds(?) of Materials, many very close to being the same.

Thanks again for the input-- Alvin
« Last Edit: December 26, 2017, 11:06:57 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)