TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

Auto Hide Palettes
Read 645 times
* December 14, 2017, 11:35:07 AM
I am trying to set up another PC to similar settings as my main PC regarding Palettes.  I have mine on the right side and they move out when I hover over them (see attachment).  I can't seem to find any difference in the settings.  So how do you go about setting up the Palettes to auto hide and have the tabs viewable on the right like I have them on my main PC.

Also what does the Auto-Activate Palettes do?  I see no difference whether that box is checked or not.

Thanks.

 

Logged
EnvCons
TurboCAD 2015 Deluxe 64-bit, Dell XPS i7 7700 3.6 GHz
16 GB Ram, NVIDIA GeForce GTX 1050 Ti
 Window 10 Home


* December 14, 2017, 11:58:49 AM
#1
When the palette area is expanded, there is a x and a pin up in left corner, click on the pin it turn and stand vertical, then it will not move regardles if you hold the cursor over it or not, you can drag to make the size they use smaller or bigger.
If you dont have any palette, go to Tool/ Customize/Options>>Palettes and check the one's you want to show, it will turn up in the way you select/ check them, or later when it is open you can drag the folders to your like.
It is easy for the palettes to jump out of area when dragging, to drag them back again will set them in the bottom of palette, so i normally go in to menu and set them on in the way i want them to show in my palette area.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* December 14, 2017, 12:09:04 PM
#2
re: …what does the Auto-Activate Palettes do?
See Customize Palettes in the Help file. I've never used it.

To set up your second machine like the first, go back to your main machine. If you have a custom configuration, go to the "Customize" dialog, "Options" page. Click on the "Browse" button. This will open Windows Explorer to the "Config" folder for that TurboCAD version. Look for two files that have your customized configuration name on them. They will have a XCFG and XML extension. Copy them over to the same place in the new machine. Go to the "Options" page on that machine, select your configuration from the "Load From" list, then click on the "Load From" button. Your new machine should look like the main machine.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* December 14, 2017, 01:08:44 PM
#3
John,
Thanks.  But the UI theme is on Default, if that is what you are referring to.  If not, I cannot find any other customization setting.  And when customizing on the UI Theme there are drop downs with various Windows versions settings.  Maybe the 2015 Deluxe version just doesn't have the settings to enable this.

Torfinn,
Thanks, I'll play around with the position and sizing and see if I can get it the same.

Ok, I played around a bit and found you go to Options/Toolbars and Menus/Palettes and then Palettes Tab and select the individual palettes you want then under Tab Layout select Force Vertical.  This puts them all along the side and then you can click the pin to toggle whether to auto hide or not.  When I did this the Selection Palette stayed out by itself.  I had to pick it up and start dragging it.  When I did, the blue arrows appeared in the 4 compass headings and while still dragging moved the cursor to the heading I wanted (which was East).  When I clicked it docked into the right side with the rest of them.  Don't know why it didn't dock with the rest at first.
« Last Edit: December 14, 2017, 01:36:07 PM by EnvCons »

Logged
EnvCons
TurboCAD 2015 Deluxe 64-bit, Dell XPS i7 7700 3.6 GHz
16 GB Ram, NVIDIA GeForce GTX 1050 Ti
 Window 10 Home


* December 14, 2017, 01:39:20 PM
#4
Then you've customized your main machine's layout, but never saved it, so it can be recalled later or moved to another machine. Now you can create one.

On the "Options" page, highlight the current name in the "Save In" list.
Overwrite it with a custom name. This won't affect the overwritten configuration; you're just creating a new name.
Click on the "Save In" button.
This will save a copy of your current configuration to the "Config" folder.
These new files can be copied over to the other machine.

If things get outa place, or hotkeys disappear, reloading your custom configuration should return things to normal.
In the future, when you upgrade up to a newer version of TurboCAD, you can copy those two files and Load them into the new version.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* December 15, 2017, 07:00:40 AM
#5
Thanks, John.  It worked.  That was a good thing to learn.

Logged
EnvCons
TurboCAD 2015 Deluxe 64-bit, Dell XPS i7 7700 3.6 GHz
16 GB Ram, NVIDIA GeForce GTX 1050 Ti
 Window 10 Home