TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

Special Symbols - Question
Read 668 times
December 05, 2017, 12:02:06 PM
Hello Everyone,

When adding dimensions to a drawing, I am adding a dim to a line that is only 45 long but I need it to show as 149 long, this is easy enough, just over type in the attribute box. Done :)
I need to add a tolerance, which again, I can do by using the special code of %%P 0.1 (+/-0.1) in the attribute box.
But in this case I have to add a tolerance of +10.0 but -0.0 and I cannot find a way to do that without it looking like this 149.0+10.0/-0.0.
See attached for clarification

Is there a way to do this?

James B

Logged
Now Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


* December 05, 2017, 03:55:47 PM
#1
Try this in the dimension Text box, before placing the dimension:
<>\S+10.0^-0.0

<> = the actual dimension
\S = tells it you want to split the following text
the first text
^ = tells it to split here
the second line of text

See Dimension Formatting Codes in the Help file.
« Last Edit: December 05, 2017, 03:57:29 PM by John R »

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


December 05, 2017, 04:04:34 PM
#2
Hi John,

Thank you very much that's perfect :) and thank you for the link I have printed it and it now on my wall :)

James B

Logged
Now Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


* December 05, 2017, 04:16:04 PM
#3
You're welcome.  :)

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* December 06, 2017, 10:46:27 AM
#4
I was playing around a bit and see that "\~" is good for adding space in the formatting. It won't work if you're using the actual "Tolerance" option, but it does work in a custom format, like yours.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


December 06, 2017, 02:27:08 PM
#5
Nice :)

Logged
Now Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


December 19, 2017, 03:39:43 PM
#6
I was playing around a bit and see that "\~" is good for adding space in the formatting. It won't work if you're using the actual "Tolerance" option, but it does work in a custom format, like yours.

That is useful, but it would be far better if suitable for the actual Tolerance option.


Jeff

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1