TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Problem with editing materials
Read 1059 times
* November 18, 2017, 03:27:29 PM
I have been working though tutorials and things are going well. At one point I created some new redsdk materials and was able to edit them just fine but today when I tried it, it will not work. I bring up the materials pallet and right click to bring up the menu and click on edit redsdk materials. a few day ago that would have brought up a screen where I could work with materials menus and materials etc.
Today I get nothing. Once I click on edit redsdk materials nothing happens and anywhere I click on the screen i get a chime. Can't do anything more until I hit escape to get out of it. Tried turning everything off and on again. It's like it's wanting me to do something but I am not sure what. I get the same result if I try it by going to options/materials/edit redsdk materials. Any ideas out there?
Thanks

Logged
-John
using TC Pro Platinum 2017


* November 18, 2017, 05:10:58 PM
#1
In a recent post, a user was using 2 monitors, and when he went back to one monitor (laptop) the dialog was off screen and caused a similar problem to what you are experiencing, were you using more monitors previously by any chance, if so, try pressing windows key+shift+left arrow key (or right arrow - it doesn't matter).

In case the dialog is behind the TC window, make TC smaller, before trying the edit material, this should allow you to see if the dialog is behind TC.

If the dialog is just gone 'off screen' that's more fiddly as you won't know which direction its off, I've read that changing the windows screen resolution can help, but probably won't if the screen res is already at max, If you try the Alt+Space, then M, then arrow keys I'd be careful, I'd press the left arrow 2 or 3 times, and if no dialog appears, I'd return it to where it started using the opposite arrow, I'd do this with each direction.

If the dialog is 'hidden' i.e. a fault within TC, you could try resetting the configuration (this won't work if its a window fault)  tools - customise - optios - workspace, click load-from or default buttons.

All the above is just guesswork, as I haven't experienced the problem myself, so its just what I've read here or on the web..



   

   
« Last Edit: November 18, 2017, 05:31:26 PM by Andy H »

Logged


* November 19, 2017, 05:39:35 AM
#2
Wow! Thanks Andy H, I spent hours yesterday trying to figure out what I had changed and there it was... I had two monitors side by side and I wanted to put the second monitor over the laptop monitor, (to try and get me looking up and straighten my neck and back), and it was working fine until I changed the display so that I could move my mouse straight up and down and that was when the problem occurred. After reading your post I changed the display back and it works fine. I had a feeling it was just off screen but I didn't know where. I still don't know where and I can't seem to fix the problem with stacked display but if I leave the display side by side it solves the problem. I just have to get used to moving the curser to the right of the screen to get to the upper monitor. Thanks again.

Logged
-John
using TC Pro Platinum 2017


* November 19, 2017, 07:23:01 AM
#3
Is it not possibe to change what is screen 1 and 2 ??

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* November 19, 2017, 07:26:14 AM
#4
Wow! Thanks Andy H, I spent hours yesterday trying to figure out what I had changed and there it was... I had two monitors side by side and I wanted to put the second monitor over the laptop monitor, (to try and get me looking up and straighten my neck and back), and it was working fine until I changed the display so that I could move my mouse straight up and down and that was when the problem occurred. After reading your post I changed the display back and it works fine. I had a feeling it was just off screen but I didn't know where. I still don't know where and I can't seem to fix the problem with stacked display but if I leave the display side by side it solves the problem. I just have to get used to moving the curser to the right of the screen to get to the upper monitor. Thanks again.

In my Windows-7 system, on my year-2010 HP-G72 Laptop, I can right-click on the Windows Desktop to pull up "Screen Resolution".
There, I can set up the extra monitor, including telling Windows where it is in relation to the laptop monitor.  In your case, that would mean dragging the "2" monitor icon above the "1" monitor icon.  See the animation below; it starts with a right-click on the Windows desktop.  Click on the little preview image below to start the animation.

-Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* November 19, 2017, 08:52:47 AM
#5
Yes, that is how I set up the display but for some reason when the #2 monitor is on top, the edit materials window doesn't show.
Even if I reorder the monitors it doesn't help. If they are stacked I still have the same problem.
Anyway, I can deal with it, at least the puzzle is solved. I just keep them side by side.
Thanks for the help.

Logged
-John
using TC Pro Platinum 2017