TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

How to apply a layer set?
Read 257 times
* November 12, 2017, 12:00:50 AM
I'm trying to use layer sets and named views to display my drawing in different ways. I'm assuming that by selecting a layer set and a view I can recreate a particular display. I'm doing this in model space for now. Selecting views works fine, but selecting layer sets doesn't. (In paper space, I *can* associate layer sets with view ports and they remain associated)

In model space I have made two layer sets - one for a 3D rendering and one for a plan view with labels etc. When I use Edit Layer Sets these sets show the correct layers checked as visible.
When I select one of these layer sets with View/Layer Set I'm assuming that that layer set will be applied to the drawing in model space and I'll see only the layers checked as visible in the layer set. This is not happening, so I'm wondering if my assumptions about layer sets are wrong or there's some step I'm missing.
Can someone enlighten me?
Thanks, Tom

Logged


* November 12, 2017, 07:59:48 AM
#1
...
Thanks, Tom

Sounds like you are doing everything correctly.
Please upload/attach the Drawing file, so fellow Forum members can check if anything is not set correctly (or check to see if the issue is replicated in their installation of the same TurboCAD version/edition/build that you are using)

What version and edition (and build#) of TurboCAD are you using? (Example:  Version 2017; Pro Platinum edition.  Build# is available in Help/About)

« Last Edit: November 12, 2017, 08:05:30 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* November 12, 2017, 02:31:04 PM
#2
I attached a simple 4 layer project that shows what I mean. If you click on the EVENS set you get only those layers displayed in model space, same for the ODDS layer set. So far so good. However, in the design director, all 4 layers are shown regardless of which layer set is selected. And, unless a layer is marked visible in the design director, it won't be visible in model space when its layer set is selected. So if we mark all layers as visible, and go back and forth between layer sets EVENS and ODDS, the drawing in model space responds correctly, but now we have a design director list whose visibility options don't match what's on the screen or what layers are in the set. Is there a way around this contradiction?

In my perfect world, I want to select a layer set and have only those layers show in model space and in the design director. As a fallback, I could also work with selecting a layer set, seeing all layers in the design director, but having only those layers in the set marked as visible.

Sorry I forgot the this the first time: I'm on TC 21.2, 64-bit, Build 59. Windows 7.
Thanks,
Tom

Logged


* November 12, 2017, 02:44:30 PM
#3
I attached a simple 4 layer project that shows what I mean. If you click on the EVENS set you get only those layers displayed in model space, same for the ODDS layer set. So far so good. However, in the design director, all 4 layers are shown regardless of which layer set is selected. And, unless a layer is marked visible in the design director, it won't be visible in model space when its layer set is selected. So if we mark all layers as visible, and go back and forth between layer sets EVENS and ODDS, the drawing in model space responds correctly, but now we have a design director list whose visibility options don't match what's on the screen or what layers are in the set. Is there a way around this contradiction?

In my perfect world, I want to select a layer set and have only those layers show in model space and in the design director. As a fallback, I could also work with selecting a layer set, seeing all layers in the design director, but having only those layers in the set marked as visible.

Sorry I forgot the this the first time: I'm on TC 21.2, 64-bit, Build 59. Windows 7.
Thanks,
Tom

Ahhh... you added a very distinct clarification, compared to your last post:  "In my perfect world, I want to select a layer set and have only those layers show in model space and in the design director"

No can do-- via Layer Sets.  For that, you need to use Layers Filters.  ([EDIT]  Please see my post, Reply #6)
Also, You have to manually "sync"-- make the Layers the same within-- Layer Sets and Layers Filters.

_____________
RE: "And, unless a layer is marked visible in the design director, it won't be visible in model space when its layer set is selected".  That is by design.  That  is how it is intended.  It's never been an issue for me; I don't think it's a design flaw.

___________
Are you sure you attached the correct file?  The one you attached has no Layers other than 0, and there are no Layer Sets.
« Last Edit: November 12, 2017, 04:42:10 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* November 12, 2017, 03:18:50 PM
#4
Continuing on my just-previous post, attached is a little drawing file.
In addition to the 0-Layer and the $CONSTRUCTION-Layer, there are six additional Layers.

In addition to creating an "Odds" and "Evens" Layer Set of each, I created a corresponding Layers Filter for "Odds" and "Evens".
I almost always want the 0-Layer and the $CONSTRUCTION-Layer Visible and currently-viewable in the Layers Palette, so I included those in each Layer Set and Layers Filter.

__________
Viewing the GIF below, and exploring the attached Drawing file, might add some clarity on how to go about using Layer Sets and Layers Filters.
     (Note that my desktop-- Configuration-- is customized.  I have the "Layer Set" command up in the Menu Bar, not within the View Menu.)

-Alvin
« Last Edit: November 12, 2017, 03:23:43 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* November 12, 2017, 04:05:36 PM
#5
Expounding on my two just-previous posts...

Once they're established, we can use Layers Filters to control what Layers are Visible and Invisible in Modelspace*.
       I've attempted to show how that is done in the GIF below.  You can't see or hear the mouse clicks, so I don't know how clear it makes it.

____________
*The problem with using the above method in Modelspace instead of Layer Sets is that Layers Filters cannot be selected in a Paperspace Viewport Properties such as Layer Sets can.
« Last Edit: November 12, 2017, 04:40:20 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* November 12, 2017, 08:31:49 PM
#6
Thanks Alvin,
Your demo project is similar to the one I tried to send except you've added filters. (I just opened the one I sent and the layers have vanished...)  Your explanation and animation are very clear and I understand my options. Appreciate the warning about filters in paper space.
How do you get that layer tab in the palettes window? That's very useful in that it shows the actual layers in the set.
Cheers,
Tom

Logged


* November 13, 2017, 11:10:53 AM
#7
re: …How do you get that Layer tab in the palettes window?…

Click on the "Open as Separate Palette" icon in the Design Director header. It will open the Layer palette within the docked palette or possibly floating in the drawing area. Drag it by its header to the docked palettes and place it on the center ‘docking sticker’.

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* November 13, 2017, 05:44:48 PM
#8
...
How do you get that layer tab in the palettes window?...

Assuming, Tom, that you are asking how did I get the Layer Set command up in the Menu Bar, this is how:

>Go to Tools/Customize (also available via a right-click on any open area of a Toolbar, Palette header, etc.)
>While the Customize window is open, simply drag (click-&-hold-down the click, while dragging) the "Layer Set" command out of wherever you have it now-- I think I recall you stating that it is in the View menu in your configuration-- and drag it up to the Menu Bar.

-Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* November 13, 2017, 11:27:57 PM
#9
Does that work now?
It has never worked for me only the "all layers" layer set  is shown in the list.


« Last Edit: November 13, 2017, 11:36:45 PM by nikkipollard »

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* November 13, 2017, 11:38:02 PM
#10
Just tried it again I see that you need to drag each layer set out separately and then edit the space - to give it a name.
It is not permanent though - It does disappear when you leave Turbocad and start again.
« Last Edit: November 13, 2017, 11:41:50 PM by nikkipollard »

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* November 14, 2017, 05:51:12 AM
#11
Does that work now?
It has never worked for me only the "all layers" layer set  is shown in the list.

Just tried it again I see that you need to drag each layer set out separately and then edit the space - to give it a name.
It is not permanent though - It does disappear when you leave Turbocad and start again.

It (what I posted in Reply #9) works for me with consistency and dependability in versions/editions 11/Pro, 19Deluxe, 20ProPlatinum, 21ProPlatinum.
Maybe it doesn't work in future versions(?)

Another Forum member turned me on to this method a few years ago; it's been in my preferred custom Configuration ever since.
I sort of remember having the same issue you are describing Nikki when I first tried it; I sort of remember discovering doing one little thing wrong; don't recall now what that was.

-Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* November 14, 2017, 06:29:49 AM
#12
It is probably something I need to do. I just cant figure it out.

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* November 14, 2017, 05:36:04 PM
#13
It is probably something I need to do. I just cant figure it out.

If I remember correctly, the issue I was having that was similar to what you describe Nikki was:

I wasn't dragging the correct command/words out.
We need to drag the command/words "Layer Set".

Attached is my preferred custom Configuration file(s), with the "Layer Set" command/words in the Menu Bar.

-Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* November 14, 2017, 06:25:05 PM
#14
Does that work now?
It has never worked for me only the "all layers" layer set  is shown in the list.

I think we can't have the Command duplicated.  Meaning that it can't exist within the View menu and within the Menu Bar and have them both work as expected.
I just experimented with it in version-20, and that's what I get.

While in "Customize" mode,
   we can either drag the Command/words "Layer Set" out of where it is, into the Menu Bar; or
   we can drag out and thereby "delete" that Command/words from wherever it currently is, then in the Commands list drag that Command into the Menu Bar, being sure to drag out the Command/words as shown in the attachment below (not the Command/words under the word "View" in the left pane.

Anyway...

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)