TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

Cannot apply or edit object material
Read 190 times
* October 14, 2017, 03:32:05 PM
This was written with RedSDK in mind, but should work with Lightworks.

First to check is Camera properties,  right click the wireframe/render teacup an select draft, quality and advanced as necessary (deluxe doesn't have advanced),  ensure Render Type and Rendering Mode are not blank,  for exampe Draft = RedSDK type and RedSDK Draft,  Quality = RedSDK type and Raytrace standard Mode, Lightworks - full,     alter as required.

Not being able to apply materials may also be due to the material being on to individual a facets and not  the object as a whole,  this can occure deliberately or if 'Drag on Facet, is selected in the materials palette and materials are dragged onto the part, one may get an error message saying something like material applied will be ignored when rendering.

To remove facet materials, a couple of options are -

Select part and if in selection palette -  part tree it says 'Face Material',  right click each and deleting them all, this should remove the facet association and allow a single material to be applied to the object,

If there is no 'face material' shown then (or if part tree was not used) - options menu, drawing set-up section - ACIS, turn off part tree (editing history) if used, Select the facet edit tool, (may be in the edit menu depending on user interface used) click on the object and this will show a number of nodes depicting each facet, drag a selection window around all the nodes,  then right click and choose properties, click material part of the dialog box, then  -

If it shows Material as 'none',  change the material to none

If it shows Materials as something other than 'none' change the category to something else, like brick, but leave the material as 'none'

The above should remove the facet materials, click OK,  turn part tree back on if you are using it.  in the material palette, right click anywhere and ensure 'drag on facet' in not ticked.  You should now be able to assign a material to an object without messing with its facets.

Sometimes deleting 'face material' in the part tree it is enought, but other times it needs the facet edit tool.

Add your own method below,
« Last Edit: October 14, 2017, 03:51:24 PM by Andy H »

Logged