TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Black screen
Read 365 times
* September 09, 2017, 08:07:31 AM
I wish an end to the black screens I get in 2017 when TC is doing its recalculations, happens whenever TC takes more than a few seconds to change something, in previous versions I just got the spinning curser but in 2017 the screen goes black, obviously only happens when drawings get complicated, not a big problem - just a bit annoying.

Logged


September 09, 2017, 08:14:13 AM
#1
I have never experienced this Andy. Maybe my drawings are not complicated enough..  :P

Could be a GPU issue maybe?

Logged
Daz...
V2016 64-Bit & 32 Bit Platinum Edition - Build 61.2
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows7 Pro 64bit Lenovo W701 Laptop, 12GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


September 09, 2017, 10:41:18 AM
#2
HI Andy,

Will you please share the file with us? And if possible then please share the GPU information of your machine also.
Thanks!

Logged
Thanks & Regards,
Zunair Attif
Team Lead QA
IMSI Design
Email: [email protected]
Skype: [email protected]


* September 09, 2017, 02:14:05 PM
#3
I have never experienced this Andy. Maybe my drawings are not complicated enough..  :P

Could be a GPU issue maybe?

Possible Darrel, the old GTX 660 is a bit out of date nowadays.

HI Andy,
Will you please share the file with us? And if possible then please share the GPU information of your machine also.
Thanks!

The file is 35Mb on disk so a bit too big, but I can reproduce the effect with a new from scratch drawing, OK this may be an extreme test but illustrates the problem if you can reproduce the effect. 

Open TC - New from scratch drawing (by default this is in inches)
Draw box 1 inch x 1 inch x 1 inch
Draw diagonal line on top
Cylinder tool - mid snap to the line, 0.8 inch diameter, 1 inch high - delete line
Boolean add box and cylinder
Select object - array copy 1.5 (x), 1.5 (y) 0 (z) 100 100  (creates 10000 objects)
Zoom out, Select Boolean add tool - click an object, drag a window to select them all - click finish
After a few seconds Click left mouse button (anywhere)

For me in 2016 (using windows 10, i7 processor, gtx 660 graphics, 16 gig memory, TC uses classic (white) screen and RedSDK),   Tc remains as-is with the windows curser spinning for a while (as would be expected),   in 2017, TC turns black until its added everything together, note the last click of the mouse button is just for this test as the easiest way to show the problem (assuming it can be re-produced).

It may just be my computer, but it doesn't happen in 2016.
« Last Edit: October 05, 2017, 04:04:49 AM by Andy H »

Logged