TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Hatch overlapping
Read 391 times
* August 07, 2017, 02:12:02 PM
Could someone look at this elevation and tell me how to get rid of the overlapping hatches where I have circled them?
Thank You

Logged
Patrick


* August 07, 2017, 02:29:28 PM
#1
Hmm, one for the architectural experts (which I'm not).

But if it was me, I'd select the polyline which the hatch is applied to, go into edit mode (node edit), and alter the nodes to the shape of the roof - adding nodes where necessary, this should reshape the hatch better but not easy to tell from a pdf.

Logged


* August 07, 2017, 03:01:59 PM
#2
It is Pick Point hatching so it made the polyline itself

Logged
Patrick


* August 07, 2017, 03:11:40 PM
#3
You dont say what Version you use.
But if you have native draw set on RedSDK, try go to Options/ RedSDK and set the Transmition from 0.1 to 0
Then in render Property set it to render in RedSDK Hidden line and check for Nonrenderable Objects

Torfinn

Logged
V18, V19, V20, V21, 2015 Pro. Platinum
Deluxe V20, V21, 2015
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* August 07, 2017, 03:12:58 PM
#4
sorry - as I thought, I should have left it to the experts. 

You can node edit a pick-point hatch to shape it to what one desires irrespective of what object was used to apply pick-point, a drawback appears to be that arcs get converted to polylines (lots of nodes).

## Edit ##   Torfinn's idea sounds a lot better than mine  ## End Edit ##
« Last Edit: August 07, 2017, 03:15:07 PM by Andy H »

Logged


* August 07, 2017, 03:40:04 PM
#5
It is Version 21 I never use rdsk also if I do this it changes other elevations when I change nodes plus there don't seem to be enough nodes to go around where needed. Try to keep things simple so just not familiar with rdsk. I appreciate all the help

Logged
Patrick


* August 07, 2017, 03:56:34 PM
#6
Torfinn that looks good that is what I want it says something about graphics accelerator etc. when I try RedSDK. It is version TurboCAD Professional 21 - x64. This way when I go to other elevations is may have overlap also but the roof hatches stay the same if that makes sense.

Logged
Patrick


* August 07, 2017, 04:37:42 PM
#7
I believe that is because you have moved the nodes to fit the view in other places, so when you change view the brush will not fit anymore.
If using RedSDK TC will hide it for you, else you will need to adjust nodes for every view.
To add more node's just select it with Edit tool, keep the cursor over the line and rigthclick, and then select Add Node, or press Ctrl when the cursor is over line and you see a symbol for add or remove a node, click and it's set.

Torfinn

Logged
V18, V19, V20, V21, 2015 Pro. Platinum
Deluxe V20, V21, 2015
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* August 07, 2017, 06:59:14 PM
#8
Another method we have-- a little trick Henry turned us on to-- while staying in GDI Native Draw mode:

Insert the Hatch.  Make the Line  Pattern (the perimeter Line) "Invisible".
Explode what's remaining-- the Brush pattern-- twice.  (Might only need to Explode it once.  Try it, then try giving it a Thickness as described in the next step.)
Make that entity 3D, giving it a Thickness of whatever (I used .01" in the attached example).
Hidden Line Render, and it will show correctly-- from any view.  Same goes for a Hidden Line Render in a Paperspace Viewport.

(Tip:  I set the Hidden Line Render to the "Draw Intersections" option, so I didn't have to notch out that part where the roof intersects with the second-floor of the house in this view.  Just a quick way of getting a more seemingly correct presentation.)

-Alvin
« Last Edit: August 07, 2017, 07:13:30 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* August 07, 2017, 08:24:47 PM
#9
It seems like there ought to be a way to just hide the overlap. I really don't want to have to change nodes etc. for every elevation. Also can't seem to do what you said Alvin about making a brush have thickness and the Draw intersections did not seem to work either I do appreciate yalls help. Can you tell where I am from lol.

Logged
Patrick


* August 07, 2017, 08:33:42 PM
#10
You dont need to be in GDI to do that, RedSDK native mode >> HL/HL do the same in v 21, and we can also set the "Draw Intersection" in HL/H, when in RedSDK mode.
But we get a more "rough" pattern on the "brush", i use like 1 mm thickness when doing that.

Torfinn

Logged
V18, V19, V20, V21, 2015 Pro. Platinum
Deluxe V20, V21, 2015
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB