TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Selection Info Coordinates not updating
Read 198 times
* August 06, 2017, 05:35:28 PM
Hopefully this is something really simple.

I'm checking the position of 3D objects to match real world heights before I intersect them to get an excavation volume.

So I select Plane by World, draw a 3D polyline on a known set of points, look at the coordinates in Selection info, note how much it needs to move, move it then check the coordinates again - but no change is shown. I delete the 3D polyline and redraw it, check the coordinates and see that it has actually moved and is in the correct position.

How do I get the coordinates in selection info to update, or is my workflow just wrong?

Logged
2016 Pro Platinum


* August 06, 2017, 07:24:10 PM
#1
Hopefully this is something really simple.

I'm checking the position of 3D objects to match real world heights before I intersect them to get an excavation volume.

So I select Plane by World, draw a 3D polyline on a known set of points, look at the coordinates in Selection info, note how much it needs to move, move it then check the coordinates again - but no change is shown. I delete the 3D polyline and redraw it, check the coordinates and see that it has actually moved and is in the correct position.

How do I get the coordinates in selection info to update, or is my workflow just wrong?

I can replicate that.
I would report it as a BUG  ;D

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* August 06, 2017, 07:51:47 PM
#2
Great, at least it's not just the nut holding the wheel.
1. How do you report a bug?
2. Does anyone know a workaround/alternate method?

Logged
2016 Pro Platinum


* August 06, 2017, 07:52:10 PM
#3
Try the "Edit Tool". Drag a selection window around all the nodes (so that they turn magenta), then enter a height in the "Pos Z" field in the Inspector Bar. All the Vertices Z fields in the Selection Info palette should now change to that new height.
« Last Edit: August 06, 2017, 08:18:20 PM by John R »

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* August 06, 2017, 08:06:50 PM
#4
PAYRE - hmm,   my take on it - Disclaimer - this is my view on it, nothing official.

## Post edited - I decided I didn't explain it well (maybe still haven't)##

As far as I know the vertices are not reporting the actual object position in world space, but the position in relationship the objects own 3D Entity workplane which has nothing to do with the workplane you are currently working on,  this is not new, I tested back to v16 and it exhibits same behaviour,  again as far as I know - 3D objects have their own (what I call internal workplane), which is whatever plane was active when the object was created.

If you click the 3d polyline and click say vertices 0 in the selection palette, you should see a red dot (may have to zoom out), this dot is on the objects plane, the selection palette reports the vertices in relation to this plane, if you move the object the dot will also move, the way I look at it is - draw a dot on a piece of paper, melt a bit of glue and stick an object on it, move the object and the it stays the same distance from the paper/dot so is reporting like it hasn't moved,  if you melt the glue and move the object higher or a different location, the reported vertices will report a different location with respect to the paper/dot, which is essentially what happens when node editing.

In order for the selection palette to report the coordinate required one would need to force some changes to the object so it is on the correct plane, for example as John mentioned node editing.

As I say - just my view and the way I look at workplanes.

Andy
« Last Edit: August 07, 2017, 05:21:56 AM by Andy H »

Logged


* August 06, 2017, 11:24:25 PM
#5
If you explode the 3D pline, you can select all of the segments and edit the nodes of the endpoints as if it were a contiguous object.  Then select the individual segment with the vertex you want to verify, it's reported in selection info with start and finish coordinates, which do seem to update and report correctly.

Logged


* August 07, 2017, 03:37:11 PM
#6
Thanks Guys, this was the type of feedback I was hoping for, I now understand work planes more.

John R - Your solution describes something else I wanted to do with, but I'm finding that using the edit tool I only have Delta X, Y & Z options in the Inspector Bar, no POS Z?

Andy H - Your explanation makes sense thanks. So I was using the Selection Info because it's also where I get volumes, but Selection Info shows coordinates relative to the object's workplane, and to be fair that could be useful for other things. The real solution was staring me in the face all along - just select the object and change the reference point to the node you need coordinates for, and the Selection Bar shows the World coordinates you need. I admit I haven't been using the selection bar as much as I should because of display issues.


Logged
2016 Pro Platinum


* August 07, 2017, 04:47:44 PM
#7
I would still report it as a BUG.
The selection info palette is displaying "false information".  ???
Not very professional for a cad system.
Or maybe development will enlighten us  ;D

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* August 07, 2017, 04:54:38 PM
#8
re: …John R - Your solution describes something else I wanted to do with, but I'm finding that using the edit tool I only have Delta X, Y & Z options in the Inspector Bar, no POS Z?

When you have the nodes selected, go to the Local Menu and select "Selector Mode". The Inspector Bar fields will change and you'll get Position fields. You could also use the "Delta" fields to change the height.

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit