TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

Where is the Copy in place tool in TC 2016 Pro?
Read 1120 times
July 31, 2017, 05:20:06 AM
Hello,
as the subject of the topic says, where is the Copy in place tool in TC 2016 Pro? It should be under Edit menu, but I can'f find it there.

Logged
Windows 10 64bit
TC 2016 Pro 64bit, RedSDK
Lenovo M92p I5 3550 8GB RAM NVIDIA GForce GTX 1050ti 4GB


* July 31, 2017, 05:42:26 AM
#1
It should be available in the SDK menu - Selection, (I checked on both default workspace and classic workspace), one needs to select an object first before the tool will activate.

Logged


July 31, 2017, 05:56:14 AM
#2
It should be available in the SDK menu - Selection, (I checked on both default workspace and classic workspace), one needs to select an object first before the tool will activate.

There is no SDK menu  :o

Logged
Windows 10 64bit
TC 2016 Pro 64bit, RedSDK
Lenovo M92p I5 3550 8GB RAM NVIDIA GForce GTX 1050ti 4GB


* July 31, 2017, 06:03:34 AM
#3
Customising the menus and toolbars in TC is this simple: Right-click in the header space, the toolbar/palette/command customisation box will appear in the window.  You can also click view|toolbars in the menu to bring it up.  Click the commands tab.  First item in the left-hand list is "all commands", go to the right-hand list and scroll down to find copy in place.  Click the item on the list, hold it and drag it into the edit menu, or any menu or active toolbar that you want to put it in. 

Logged


* July 31, 2017, 06:20:18 AM
#4
Strange, I checked some more workspaces and it appears in all for me,

As Murray says - Check in the customise commands dialog if it is there,   I keep some tools that I use often (or are missing) on a custom toolbar for easy access. 

There are only two tools under the SDK menu, 'copy in place' and 'multi-Boolean add'  (multi add is probably mot use much now with the various window selection modes we have now).

« Last Edit: July 31, 2017, 06:21:58 AM by Andy H »

Logged


July 31, 2017, 07:50:21 AM
#5
No such command. I've read somewhere that in 64bit version of TC that tool is missing

Logged
Windows 10 64bit
TC 2016 Pro 64bit, RedSDK
Lenovo M92p I5 3550 8GB RAM NVIDIA GForce GTX 1050ti 4GB


* July 31, 2017, 08:14:36 AM
#6
I've read somewhere that in 64bit version of TC that tool is missing
The help files say its not available, but they are wrong,  back when 64 bit was introduced in v19, many of the SDK and Add-on commands were not working properly (if at all) in 64 bit, things got repaired but the help files were not updated.

The tools should be there so - all I can suggest is to run the installer again, and try repair if its available, or re-install and see if it appears (or use the make copy tool - tab once - press enter - turn off make copy method instead).   

Logged


July 31, 2017, 08:51:22 AM
#7
I've read somewhere that in 64bit version of TC that tool is missing
The help files say its not available, but they are wrong,  back when 64 bit was introduced in v19, many of the SDK and Add-on commands were not working properly (if at all) in 64 bit, things got repaired but the help files were not updated.

The tools should be there so - all I can suggest is to run the installer again, and try repair if its available, or re-install and see if it appears (or use the make copy tool - tab once - press enter - turn off make copy method instead).

OK, that tool isn't so important, I can do without it. Thanks anyway

Logged
Windows 10 64bit
TC 2016 Pro 64bit, RedSDK
Lenovo M92p I5 3550 8GB RAM NVIDIA GForce GTX 1050ti 4GB


August 01, 2017, 04:57:40 AM
#8
Hi tarmiricmi,

Have you done the complete installation of TurboCAD Pro 2016? As this tool is available in this version.

Also, I would recommend you to reset TurboCAD to defaults, follow the steps below:
1) Right click anywhere near toolbar to open Customize window
2) Switch to Options tab, Click Default button. It will reset the defaults.
3) Click close to close customize window. 

Let me know if this resolves the issue.

Logged


* August 01, 2017, 07:38:08 AM
#9
  ??? I also don't have it in 2016 and 2017.
I thought I did at one point, who knows.
I am not deleting any folders or re-installing, it's just a waste of time because for some unknown reason it will happen again.
They really need to to fix these "quirks" and improve "User experience"

> my "Guess" is there's a conflict with the .dll and windows, just a guess really  ;D
« Last Edit: August 01, 2017, 07:42:38 AM by Dean »

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


August 02, 2017, 04:07:41 AM
#10

You have to just reset your TurboCAD, it does not involve any reinstalling.  :P

Logged


* August 02, 2017, 08:05:55 AM
#11

You have to just reset your TurboCAD, it does not involve any reinstalling.  :P

Reset does nothing.
So. I would assume the next attempt to bring back the copy and place tool would be deleting folders and or re-installing  :P

I have lost hours of hard work doing that "Fix".
 > ;D Development needs to figure out why this happens. they wrote this stuff not the 'User".

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


August 02, 2017, 08:20:05 AM
#12
Hi.
In 2016 pro 64 bit you also can use "duplicate" in the copy toolbar to copy in place.

Logged
Torben Pind
Architect
www.katholm.dk

2016 Pro 64-bit


August 03, 2017, 12:27:52 AM
#13
I have it in V21, 2015, 2016 & 2017, but I had to load it into the Edit / Copy Entities menu and save the Configuration for V21.  You will have to position the command callout where you want it, too.


Jeff

Logged
TC Pro Platinum 2017, 2016 & 2015 (all with LightWorks) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


August 03, 2017, 03:29:31 AM
#14
Hi tarmiricmi,

Have you done the complete installation of TurboCAD Pro 2016?  YES As this tool is available in this version.

Also, I would recommend you to reset TurboCAD to defaults, follow the steps below:
1) Right click anywhere near toolbar to open Customize window
2) Switch to Options tab, Click Default button. It will reset the defaults.
3) Click close to close customize window. 

Let me know if this resolves the issue. NO


Logged
Windows 10 64bit
TC 2016 Pro 64bit, RedSDK
Lenovo M92p I5 3550 8GB RAM NVIDIA GForce GTX 1050ti 4GB


August 03, 2017, 03:32:13 AM
#15
Hi.
In 2016 pro 64 bit you also can use "duplicate" in the copy toolbar to copy in place.

Thanks, but that command does not exist in my TC 2016 pro 64bit installation.

Logged
Windows 10 64bit
TC 2016 Pro 64bit, RedSDK
Lenovo M92p I5 3550 8GB RAM NVIDIA GForce GTX 1050ti 4GB


August 03, 2017, 03:36:08 AM
#16
I have it in V21, 2015, 2016 & 2017, but I had to load it into the Edit / Copy Entities menu and save the Configuration for V21.  You will have to position the command callout where you want it, too.


Jeff

Thanks, but I don't have that command on the list of all commands.


Logged
Windows 10 64bit
TC 2016 Pro 64bit, RedSDK
Lenovo M92p I5 3550 8GB RAM NVIDIA GForce GTX 1050ti 4GB


* August 03, 2017, 04:08:05 AM
#17
Have you try'd to load the Default cfg in Customize/ Options>> Default and see if it is there then

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


August 03, 2017, 04:16:20 AM
#18
Thanks, but I don't have that command on the list of all commands.

*******
 EDIT ON
*******

I'm going to change my answer, because Henry's is simpler and, apparently, the best way to do it.  See http://forums.turbocad.com/index.php/topic,20835.msg125153.html#msg125153

********
 EDIT OFF
********

Well, this is just as fascinating as it is aggravating.

1. The first thing I would suggest is to find the instructions in the Sticky Notes (the posts at the top of this page that don't go away) for Common Troubleshooting Procedures for TurboCAD and delete the Built-In Folder (after you have exited TurboCAD, of course).  Then, re-start TurboCAD and check under Commands before you reload your preferred Configuration (assuming you are doing that).

2. If you find the Copy In Place command, great.  Now, load your preferred Configuration, then check the Commands list again to make sure that Copy In Place is still available.  If it has disappeared, then that's the cause of your problem.  You will have to delete your preferred Configuration and create a new one (but not just yet).

3. Now, exit TurboCAD, delete the Built-In Folder again, then re-start TurboCAD and load a different Configuration.  Check Commands to see if Copy In Place is still visible.  This should not happen with the supplied Configurations, but I am including it for completeness.  If the command is not visible, then you have a problem with more than one Configuration (I think this very unlikely).  Exit TurboCAD, delete that Configuration and delete the Built-In Folder again.

4. When you re-start TurboCAD, start modifying the default menu structure and icon placement to your preferred Configuration and save that as your new preferred Configuration.  Be sure to drag Copy In Place to your preferred location.

If you did not find the Copy In Place command at Step 2, then you will probably have to uninstall TurboCAD, possibly editing the Registry to remove any references to TurboCAD or IMSIDesign and re-install TurboCAD.

If that doesn't do it, then I would be inclined to think that there is a bug in the installation procedure that is related to the language choice you made (I notice that you list Bosnia and Herzegovina as your country of residence).  I haven't heard of this happening to anyone else, but it would seem to be the next logical choice for investigation if the steps listed above do not solve your problem.

Let us know your results and good luck.


Jeff
« Last Edit: August 04, 2017, 03:55:06 AM by Jeffin90620 »

Logged
TC Pro Platinum 2017, 2016 & 2015 (all with LightWorks) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* August 03, 2017, 05:51:01 AM
#19
Just for Information purposes  - an old thread on the same subject (though a different TC version) http://forums.turbocad.com/index.php/topic,20835.msg125153.html#msg125153

Logged


August 03, 2017, 06:18:14 AM
#20
OK, I'm in a middle of some rendering work in TC, this command isn't of big importance to me (I was curious to find out why it is missing), so I could troubleshoot this issue later.
Thanks for all useful comments though.

Logged
Windows 10 64bit
TC 2016 Pro 64bit, RedSDK
Lenovo M92p I5 3550 8GB RAM NVIDIA GForce GTX 1050ti 4GB


* August 03, 2017, 05:58:29 PM
#21
There's a third-party add-on from long ago that works in 32-bit but not in 64-bit (or erratically in 64-bit, IME), UCSViews, and part of adding it in was to put the UCSViews.dll in the C:/Program Files/ImsiDesign/Your TC Version/Program/Draggers folder.  I just jumped down that rabbit hole and found that CopyInPlace.dll is a thing, so if it's missing in your installation, get a copy of the appropriate .dll from somewhere, put it there and things will probably be jake at next start, as they say in Australia.... 

That means all good, BTW.
« Last Edit: August 03, 2017, 06:01:48 PM by murray dickinson »

Logged


* August 05, 2017, 08:47:44 AM
#22
Here is where I find it in the menus.

Edit: I vaguely recall that when you do an installation you need to select "Custom" and make sure that all the boxes are checked, as selecting "Full" does not install absolutely everything particularly the SDK.   

Matthew
« Last Edit: August 05, 2017, 10:07:02 AM by RCFlyingKnight »

Logged
Just a hobby user.
TurboCAD Vr. 18.2 Platinum
TurboCAD Vr. 2015 Platinum
TurboCAD Vr. 2016 Platinum
PC - Intel i7, 3.2 GHz, 32GB RAM, Window 10 64bit
Graphics ATI Radeon HD 5700 Series, 1GB RAM