TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


Totally lost in imprint and simple extrude
Read 252 times
* July 27, 2017, 01:29:36 PM
Gents,

I just wanted do some drawing w/o trouble and wanted draw an profile with cut in.

I made and shape I closed as polyline, I wanted to use this to cut an shape in the profile.

But as soon I choose the simple extrude the work plane swaps and the shape goes in 90 degree.
Event after tilted the profile and the shape the extruded goes wrong.

I also would believe the imprint will work, but no! Imprints works on pure circle NOT this shape.

The actually placement of cut is on the layer "shape wanted polyline"

What wrong do I do? 

Best regards
NeverStop




Logged


* July 27, 2017, 03:00:17 PM
#1
From the looks of it, I think you drew the profile (3D polyline) on the World Workplane, then rotated it into its current location. I believe that may be why it is extruding the wrong way. You would be better off establishing the workplane to that face, then redrawing with a 2D polyline. The extrusion will have smooth curves instead of the faceted curves generated by the 3D polyline.

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* July 27, 2017, 03:11:18 PM
#2
The profile is a 3D Polyline, which always extrudes along the Z axis of the Workplane in which it was created its own Workplane. Replace it with a new 2D Polyline and it should work OK.

Henry H
« Last Edit: July 27, 2017, 04:07:04 PM by Henry Hubich »

Logged


* July 27, 2017, 03:30:08 PM
#3
John and Henry, THANKS! (Today It was just to much)

For me it seems like TC has an tidy up task to do!

What I did to make the shape was.. circles and lines! Trim lines, and Join as polyline.
This after I just set out the square, offset to inside and extrude to create the main profile.

Change view to front I think! (away from my work station right now)
And drew the shape, direct on facet,, Some misatakes I had before to join polyline.

How should I know it beceme 3D polyline and not is working? And why not?

Again, thanks for helping me!

Best regards
NeverStop

Logged


* July 27, 2017, 03:33:16 PM
#4
I forgot to ask! Any Idea about imprint? Should it work?

Edit :-) I see the 3D poly only do Z axis.. But why?

NeverStop!
« Last Edit: July 27, 2017, 03:42:42 PM by NeverStop »

Logged


* July 27, 2017, 04:06:43 PM
#5
When you used the Join Polyline tool, the 2D/3D option may have been checked. If you select the polyline after creating it, the Selection Info palette will tell you kind it is; polyline or 3D polyline.

Imprint will work if the profile is 2D.

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* July 27, 2017, 04:34:22 PM
#6
John,

You have totally right I did see this 2/3D Icon and tried see what is happening!

I have properly learned a lesson here! But do not understand why its like this?

Logged