TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Changing the wheel function for a Logitech MX mouse TC 20.2 pro plat
Read 397 times
* July 24, 2017, 10:13:44 AM
I have used a Logitech wireless mouse for years. It has a function where if you are working in 3d and press down on the scroll wheel, you can then freely rotate your 3d object by moving the mouse about. I recently got a Logitech MX mouse which is better than the old one in all respects, except it won't do this. I have tried in the Logitech options program that comes with the mouse, and in the control panel of my laptop, but no good. Any ideas?

Logged


* July 24, 2017, 05:07:08 PM
#1
I believe you need to use the Right Mouse Button instead of the Wheel.

Shift+RMB = rotate the view.
Ctrl+RMB = Examine/orbit the view.
Ctrl+Shift+RMB = Pan the view.

I'm not sure what is used for Dynamic Zoom. I believe the button behind the wheel would work, but not seeing that in Windows 10. It just wants to open Search.

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* July 25, 2017, 12:51:13 AM
#2
Thanks John, That works, but not as easy to use as the old one. Th old one also zooms to extents when you press the wheel once which is useful.
In Solidworks you can change the mouse gestures in the program itself- is this possible in TC?

Logged


* July 25, 2017, 01:05:21 PM
#3
I went digging and found this old post…

That doesn't work with my Logitech Laser mouse (I guess that the Setpoint software is interfering with it).
Jeff

It worked OK with a MX Revolution. In the SetPoint dialog (Mouse Button Settings) I have TurboCAD V16 and V17 set up in "1a. Select Program" (Click on the "Manage Programs" button if you need to add TC to the list). In column 2 "Select Button", I have the wheel selected. At "3. Select Task", it's set to "Other" with the "Middle Button" function selected. Maybe something here will help.

The picture is long gone from that post, but I attached (re-attached) it below.

re: …change the mouse gestures in the program…
The "Customize" dialog has a "Additional Devices Setup" link. You can tweak its settings there. I believe changes here will only affect how the Middle Mouse Button (mentioned in quote) works and not the Right Mouse Button.

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


July 27, 2017, 02:04:07 AM
#4
It worked OK with a MX Revolution. In the SetPoint dialog (Mouse Button Settings) I have TurboCAD V16 and V17 set up in "1a. Select Program" (Click on the "Manage Programs" button if you need to add TC to the list). In column 2 "Select Button", I have the wheel selected. At "3. Select Task", it's set to "Other" with the "Middle Button" function selected. Maybe something here will help.

The picture is long gone from that post, but I attached (re-attached) it below.

re: …change the mouse gestures in the program…
The "Customize" dialog has a "Additional Devices Setup" link. You can tweak its settings there. I believe changes here will only affect how the Middle Mouse Button (mentioned in quote) works and not the Right Mouse Button.

That was a long-ago post and it is not in the current SetPoint software for the MX Master mouse.

To bring up the current configuration screen, go to the Windows Start popup (first image), enter "Logitech" and select the option shown.

With the new configuration screen, click where shown and choose the highlighted option.


Jeff

Logged
TC Pro Platinum 2017, 2016 & 2015 (all with LightWorks) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1