TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


Not Responding
Read 88 times
* July 16, 2017, 02:12:43 PM
I am running TC 2017 Plat Pro on a with Windows 10 Operating System.

Almost every time I open TurboCad I get the "Not Responding" message when I try to open an existing drawing or even if I try to load a new drawing from scratch.
After multiple times of trying and restarting my computer I can eventually open a drawing - then everything works perfectly.
I do not have this problem if I load TC2016.

Has anyone an idea what is causing this

Logged


July 17, 2017, 02:37:31 AM
#1
I would not be surprised if it was related to ACIS History.  One indicator is if TurboCAD will eventually display everything, but takes a long time (another is having a design file that is in the tens of megabytes).

As an example, I recently created a docking platform prototype for a MacBook Pro laptop.  To get that diamond pattern in the frame, I had to 3D Add dozens of Boxes to create the basic pattern, then I had to 3D Intersect with another solid that specified the boundaries of the main section, followed by a 3D Add of a Shell of that same boundary to get solid faces on the bottom and sides.

It literally took upwards of 5 minutes to do a Draft Render (maybe more... I got bored and did something else while I waited).

When it finally occurred to me to check the ACIS History, I Exploded all the components into ACIS Solids.

Rendering now takes about 2 seconds (IMSI should really update the ACIS History code to Multi-Threading).

To see if this is what is happening to you, bring up the Selection Info panel (the fastest way is the <Ctrl> <Shift> I hot key) and start clicking on objects (you may have to make all hidden Layers visible as there are a couple bugs relating to this).

Or it could just be the file size.  This same MBP Cradle does take a long time just to load to Wireframe display because it's 42 MB.


Jeff


Logged
TC Pro Platinum 2017, 2016 & 2015 (all with LightWorks) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* July 17, 2017, 04:50:10 AM
#2
something similar. I don't restart though. If I go into the task bar and stop the crash report delivery model Tc starts.

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks