TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

Saving and Loading materials
Read 173 times
* July 09, 2017, 12:43:14 PM
Hello to all,

at "Materials" I selected all "Categories", then all "Materials". By calling up the context menu and clicking on "Save Materials" I want to save all materials.
In the dialog box only the category "Metal" appears even if there are approx. 20 more categories. In the window "Selecting all" is active.

If now the Materials would be rally saved, then all the other materials are definitely gone respectively lost!
Only by "Restore Standard Materials" I will get the "Standard Categories" with the "Standard Materials". All materials created myself or changed material properties are lost.

In case files are loaded which contains materials different to the standard materials then these materials of just that file will be added to the materials library. By "Load Materials" the materials cannot be loaded because previously there was just stored only one category and the materials included in this category!

Is there a workaround or is this a software bug?

Did somebody try to save and load materials again?

I' am using the German version of TC 2015 Pro Platinum. Does this situation also occur in the English version?

I' am working with the LightWorks Plug-In, which shouldn't have any effect for saving and restoring materials!

ACER Aspire F 15
Windows 10, 64-bit

Logged


* July 09, 2017, 03:03:25 PM
#1
Do you have the "propin.dat" file selected when you attempt to save? That is the file that contains "all" the material settings; RedSDK and LightWorks.

I just tried using the "Save Material" from the Materials palette and encountered the same problem as you did. It is better to use the Options menu; "Options / Materials / Save Materials…". I had no problems with this method.

In the Wiki, see Save Materials and Load Materials.

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* July 11, 2017, 02:38:21 PM
#2
   Hi John,

with your described method I still have the same problem, just the category metal appears even when the propin.dat is selected!
I opened up the file in an editor where all materials are in. Even the changed and new ones are present. I made a copy of the propin.dat (propin2.dat). Then I saved the materials. After a few seconds the thumbnails got refreshed and as expected only the category "Metal" was present. I erased the propin.dat and copied the propin2.dat into the propin.dat. After refreshing the thumbnails everything was back like previously.
If I try to load materials from the proper propin.dat I get also just the category "Metal" to select. The other categories aren't displayed!
This seems for me that there is a bug which suppresses the other categories. If I use a material in the drawing out of an other category still there is only "Metal" present. So my thoughts that the last used category will be used is false!

Is there any chance to get this function back to work? In case of an software upgrade I wouldn't be able to transfer the materials over to the newer version!

Waiting for successful news that the function is back to work!

Logged


* July 11, 2017, 09:43:43 PM
#3
I'm using Version 22.2, Build 54.3.

You could try running "Repair" to see if that clears things up, otherwise try "Uninstall / Reinstall". Have your Serial Number handy.

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* July 16, 2017, 01:00:36 PM
#4
Hi John,
repairing respectively installing new doesn't change anything.
Even when you just load materials with the good propin.dat only the category metal is present!  :o

Logged