TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

OpenGL rendering greyed out
Read 212 times
July 05, 2017, 07:04:42 AM
Hello,
in Program Setup - Desktop, option OpenGL Hardware Acceleration is greyed out. I'm wondering why is that so?
I'm using Nvidia gtx 1050 ti with latest drivers on Win10 64bit. No problems at all with games or other programs.

Any thoughts?

Logged
Windows 10 64bit
TC 2016 Pro 64bit, RedSDK
Lenovo M92p I5 3550 8GB RAM NVIDIA GForce GTX 1050ti 4GB


* July 05, 2017, 07:11:52 AM
#1
Because you are in RedSDK mode i guess, in GDI mode it is not greyed out.

Torfinn

Logged
V18, V19, V20, V21, 2015 Pro. Platinum
Deluxe V20, V21, 2015
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* July 05, 2017, 07:48:04 AM
#2
As Torfinn says,  Contrary to what it may seem, in RedSDK mode when its greyed out it means it is turned on, its greyed out effectively to stop anyone turning it off. its the same with options menu - drawing setup - draw form building edges,  that's also greyed out (turning on) when in RedSDK mode.

Logged


July 05, 2017, 08:11:53 AM
#3
Yes, true, I'm using RedSDK. However Turbocad displays a warning that says something about graphics driver being uncompatible or something like that. I've checked on the RedSDK pages, and it is there recommended for my GPU that I use Nvidia's driver which I already use, so it's unclear to me why then Turbocad displays this warning at the first place  :o

Logged
Windows 10 64bit
TC 2016 Pro 64bit, RedSDK
Lenovo M92p I5 3550 8GB RAM NVIDIA GForce GTX 1050ti 4GB


* July 05, 2017, 09:38:15 AM
#4
That's most likely because Redway have a list of graphic cards and driver versions that have been tested with RedSDK,  and if any card or driver isn't on the list it can throw up a dialog box, under windows 10 it shouldn't be bothered about the driver, but the gtx 1050 was only released late 2016, so it would not be on any RedSDK list back in TC v2015, (I'm assuming the list is contained within the RedCore.dll - but not sure on that)

It should work fine no matter what the dialog box says,  there should be a tickbox (bottom right of the warning dialog box) for don't show the message again as there is on many warning messages.   
« Last Edit: July 05, 2017, 09:40:25 AM by Andy H »

Logged


July 05, 2017, 10:14:58 AM
#5
Thanks to all for the comments.

Logged
Windows 10 64bit
TC 2016 Pro 64bit, RedSDK
Lenovo M92p I5 3550 8GB RAM NVIDIA GForce GTX 1050ti 4GB