TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Inconsistent Position Reporting
Read 136 times
May 15, 2017, 05:37:37 PM
There are several concentric circles.  For all except the outer circle, the XY coordinates for the Inspector Bar and Selection Info are identical.

For the outermost circle, however, there is a significant difference.

Why is this and what do I do to correct it?


Jeff

Logged
TC Pro Platinum 2017, 2016 & 2015 (all with LightWorks) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* May 15, 2017, 06:39:00 PM
#1
You probably did that thing where you inadvertently put that circle on a different Workplane.  You know... the thing that creates the Warning Dialogs.  That thing that I am constantly pointing out.

(By the way Jeff:  Can you provide a screen-capture of your 3D Selector Properties settings.  What you had it set at when you provided that initial screen-capture.)
« Last Edit: May 15, 2017, 06:47:28 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* May 15, 2017, 07:24:26 PM
#2
Jeff,  As you will Know, if set to world then the position reported by the inspection bar is the reference point position,  however it appears the position reported in metrics is the reference point position when the object was drawn and on the workplane it was drawn on,  it will remain set at that position even after moving until one does a place on workplane.

As Alvin mentioned, I'm guessing the metrics can't handle the change in workplane that occurs with a 2D object in 3D space.
« Last Edit: May 15, 2017, 07:26:38 PM by Andy H »

Logged


May 16, 2017, 01:25:41 PM
#3
You probably did that thing where you inadvertently put that circle on a different Workplane.  You know... the thing that creates the Warning Dialogs.  That thing that I am constantly pointing out.

(By the way Jeff:  Can you provide a screen-capture of your 3D Selector Properties settings.  What you had it set at when you provided that initial screen-capture.)

Yeah, that's probably it, but when I Place on Workplane all the Circles (starting with the outer circle), Selection Info reports them all as being at (-0.339,-0.842) while the Inspector Bar reports any and all of them at (0.000,0.000).

I never really did learn how to manipulate Workplanes.

Okay... I fixed it.  I re-defined the Workplane Origin by specifying the center of the outer Circle and then de-selecting the Circle and re-selecting it.

The Inspector Bar and Selection info X & Y values are now the same.


Jeff




Logged
TC Pro Platinum 2017, 2016 & 2015 (all with LightWorks) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1