TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

RedSDK table rotation error
Read 492 times
* May 15, 2017, 04:00:17 AM
Accidentally rotated a table, and have a problem with undo on the rotation, visually it over-corrects even though the bounding box is correct, happens in 2017 / 2016 / 2015 RedSDK only,  its ok in GDI mode,  closing and re-opening the file shows it correctly.. 

Just another RedSDK anomaly

Logged


* May 15, 2017, 04:43:09 AM
#1
Confirm
A ctrl+z/ ctrl+z/ ctrl+y will fix it

Torfinn

Logged
V18, V19, V20, V21, 2015 Pro. Platinum
Deluxe V20, V21, 2015
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* May 15, 2017, 10:05:45 AM
#2
Thanks Torfinn for having a look.

The ctrl+z etc. didn't actually make any difference for me, but its not a problem the rotation wasn't intentional, I'll just be more careful.

Logged


May 15, 2017, 10:57:41 PM
#3
Andy

This usually happen when the workspace is rotated.
To resolve this go to View-> 3D view-> Plan-> By world.

Logged


* May 16, 2017, 01:48:47 AM
#4
Andy
This usually happen when the workspace is rotated.
To resolve this go to View-> 3D view-> Plan-> By world.

Hi,  the gif file above was done in world plan,  if the workspace was rotated I would expect the bounding box would have been rotated also,  I did find a workaround by exploding and then undoing the explosion, which then shows the object correctly, Just one of those odd things that happens with RedSDK I guess. 

Logged


May 16, 2017, 02:44:57 AM
#5
It is a RedSDK update problem.

I always have Program Setup/Native Draw/Miscellaneous/Caching of Model Space set to off/unticked.

Then flick to Paper Space and back to Model Space to force a RedSDK reload and it displays it correctly. Most RedSDK glitches can be overcome by this method.

Logged
Daz...
V2016 64-Bit & 32 Bit Platinum Edition - Build 61.2
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows7 Pro 64bit Lenovo W701 Laptop, 12GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* May 16, 2017, 04:44:57 AM
#6
Thanks Darrel.

I had done that (turned off caching) in previous RedSDK version when you mentioned it, but I forgot all about it for 2017,  it would be nice if they worked out these little quirks.
« Last Edit: May 16, 2017, 04:46:29 AM by Andy H »

Logged