TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

TurboCAD slow after Windows update
Read 496 times
* April 21, 2017, 04:46:25 AM
I run TurboCAD 2016 Delux on HP EliteBook running Windows 10. TurboCad started running slow following a Windows update. I tried reinstalling TurboCAD but no improvement eventually I restored the computer to a previous restore point prior to the update and TurboCAD was back up to speed. Now following another update it is slow again, and Windows has deleted the old restore point. By slow I mean you have to wait to selecting a tool and then wait for it to snap to a point. It is almost unusable - and I'm only using it for model - hobby use.
Can someone please help

Logged


April 21, 2017, 06:06:29 AM
#1
Hi Peter, welcome to the Forum  :)

Please go to Options menu and set Native Draw mode to GDI and checkmark Flicker free draw. Click yes to restart turboCAD.
I did this and it solved the problem.

Khadija

Logged


* April 23, 2017, 08:37:49 AM
#2
Thanks Kphool. I've been away for weekend. Just picked up your reply. 
Looks as if its solved the problem for me too.

Logged


* May 19, 2017, 08:37:59 AM
#3
This has worked fine. But TurboCAD now crashes when I close it. -   Save drawing then either hit close button or Exit from File menu, and I get a message 'TurboCAD 64 has stopped' and an invitation to send an error report. I've sent one but now just ignore it. I reaslise the is version 2016 - you'll probably tell me to update, but it does all I want.
Any ideas???
 

Logged


May 19, 2017, 10:11:07 AM
#4
Peter can you verify which build you are using? 
Also with regards to you're ability to use Redsdk, see this video- https://www.youtube.com/watch?v=MBUu8KEPTLQ&t=4s

It sounds like you might have an onboard GPU may be conflict as demonstrated.
« Last Edit: May 20, 2017, 07:54:06 AM by Dave Taylor »

Logged
Thanks,
Dave Taylor
TurboCAD Product Manager


* May 20, 2017, 01:53:58 AM
#5
I'm using version 23.2 build 61.2
The problem shown in the video is exactly the one I was experiencing. Unfortunately my HP Elitebook has only the Intel Graphics.
I'm not much of a computer buff (prefer mechanical things I can get my hands on) so it looks as though I'm stuck with it.

Logged


* May 20, 2017, 04:44:20 AM
#6
This has worked fine. But TurboCAD now crashes when I close it. -   Save drawing then either hit close button or Exit from File menu, and I get a message 'TurboCAD 64 has stopped' and an invitation to send an error report. I've sent one but now just ignore it. I reaslise the is version 2016 - you'll probably tell me to update, but it does all I want.
Any ideas???

Peter, does it just crash on just one file, or does it still crash even when starting a new from scratch drawing.

With regards the slowness, a quick look at the intel site suggests others are having problems with intel graphics after the creators update, maybe check with HP if they provide their own driver (which windows could have replaced) or if they are just using inter driver.

Logged


* May 20, 2017, 05:53:49 AM
#7
Open T'CAD new dawing - draw a couple of lines - hit close - save file =  Turbcad has stopped. File has been saved.

Logged


May 20, 2017, 07:50:24 AM
#8
just to be clear the bad behavior happens only in redsdk mode?

Logged
Thanks,
Dave Taylor
TurboCAD Product Manager


* May 20, 2017, 08:34:10 AM
#9
No. When I ran it in Redsdk - before the slow down -  I never noticed any problems. It is only after following Khadija's advice and changing to GDI (flicker free) that this started happening.
I appreciate your help, but at the end of the day I can do the drawings I want and save them, it is only annoying to get the crash and the error report window. Then if I forget to untick the box, TurboCAD restarts.

Logged