TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


Trying to Edit anything Lightworks Freezes/Crashes TurboCAD-- V20PP
Read 485 times
* March 07, 2017, 05:02:45 PM
Well this is a real bummer.  Remember a year or two ago I had the issue with my version-19-Deluxe freezing/crashing every time I clicked on "Edit"(a Lightworks feature).  Well... now it's happening in my version-20-ProPlatinum.

Just as with the version-19-Deluxe issue, no amount of doing the Built-in Folder thing or Repair, or Remove/Re-Install is remedying the issue.  Bummer.

Even with IMSI's helpful efforts on the V19 issue-- we tried everything-- the best I could do was to create a new User Account on the system and access TurboCAD that way when I wanted to edit some Lightworks stuff; same now in V20PP.   Did I say bummer?

____________
I don't expect any resolution.  Just wanted to report it here in case developers or somebody wanted to give it some thought.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* March 07, 2017, 05:42:14 PM
#1
I think I resolved the issue this time.
 
Using the TurboCAD installer ( 04TCP5202_TurboCAD_Pro_20-2_51-3_x64 (2).exe ), I Removed the program installation.
I went into Windows' Registry Editor and deleted the Computer\HKEY CURRENT USER\Software\IMSIDesign\20 entry.

Re-Installed.  Seems to be working.

I'll have to give that a try for my version-19-Deluxe this weekend.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


March 07, 2017, 11:50:32 PM
#2
Interesting.  With 2016, I just noticed a crash-without-save problem if I try to change from RedSDK to LightWorks.  Working on making it repeatable so I can submit a bug report.  Never encountered this problem before, so it's surprising it (may) go back several versions.


Jeff


Logged
TC Pro Platinum 2017, 2016 & 2015 (all with LightWorks) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* January 06, 2018, 05:24:42 AM
#3
I think I resolved the issue this time.
 
Using the TurboCAD installer ( 04TCP5202_TurboCAD_Pro_20-2_51-3_x64 (2).exe ), I Removed the program installation.
I went into Windows' Registry Editor and deleted the Computer\HKEY CURRENT USER\Software\IMSIDesign\20 entry.

Re-Installed.  Seems to be working.

I'll have to give that a try for my version-19-Deluxe this weekend.

An update on this topic, this topic that seems to have helped a couple of other Users with this seemingly otherwise unsolvable issue.

This "freezing" issue happened to me again in V19DL.
This time to resolve the issue I went with a less severe remedy:
>I didn't uninstall the TC V19DL program (I backed up my "Profile/Built-In" Folder to a different directory, though, before proceeding, to replace after running a Repair; I didn't want to have to re-build all my customized System Defaults settings)
>I did remove the Computer\HKEY CURRENT USER\Software\IMSIDesign\19\Deluxe\LightWorks Editor entry.  (this is the most important part)
>Launched the TC V19DL (latest/last build) installation .exe file; ran a "Repair". (After the "Repair", replaced the Profile/Built-In Folder with the old one; I can never remember in which .ini file(s) the System Defaults-- Program Defaults-- settings are contained, so I just Copy/Replace over the whole folder.  This step isn't critical for resolving the issue of this topic-thread.)
>Started TurboCAD V19DL.  Launched a LightWorks editor.  Issue is resolved.

_________
I think next time-- if there is a next time this is needed-- I would try just deleting that Registry Key entry (with the TurboCAD program not running), then start a new session of TurboCAD.  Perhaps not even running the "Repair" is needed.  Perhaps that Registry Key entry rebuilds itself after the next launching of the LightWorks Editor.   [edit:  See update to this update in Reply #6, this topic-thread]

-Alvin
« Last Edit: January 06, 2018, 06:48:13 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* January 06, 2018, 06:27:42 AM
#4
Thanks for taking the time to post this update, Alvin. 

I'm one of the users helped by your original solution.  I've bookmarked this update for future reference, if needed.

Mike

Logged
Platinum - V21, 2017 (w/LightWorks)
Deluxe - V17, V18, V19, V20

Intel Core i7 CPU @ 3.40GHz, 16GB Ram
NVIDIA GTX 1060 - 6GB
Windows 10 Home  64-Bit


* January 06, 2018, 06:46:57 AM
#5
Thanks for taking the time to post this update, Alvin. 

I'm one of the users helped by your original solution.  I've bookmarked this update for future reference, if needed.

Mike

You're Welcome Mike.

Another update:  Just tested in my V19DL-- Sure enough, all I had to do was Delete that Registry Key entry (with TurboCAD not running), start TurboCAD, Launch a LightWorks Editor, and the Registry Key entry re-built, and LightWorks Editor functions without freezing TurboCAD.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)