TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


Mouse wheel panning facility
Read 1922 times
* March 03, 2017, 02:21:13 AM
I am having problems with being able to pan by using the depressed mouse wheel. What am I or have I done wrong. Can anyone point me in the right direction to look please

Logged


* March 03, 2017, 03:39:37 AM
#1
I am having problems with being able to pan by using the depressed mouse wheel. What am I or have I done wrong. Can anyone point me in the right direction to look please

What brand and model of mouse are you using?

If I recall correctly, there is a known issue with Wheel Assignments when using a Microsoft Wireless mouse.  That is the type of mouse I use, so I have experienced this for a number of years.  Even disassociating TurboCAD from the mouse in the mouse setup doesn't resolve the issue for me.
What I have gotten to work reliably for panning is:  Hold the right mouse key down while also holding down the CTRL and SHIFT keys, while moving the mouse around.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


March 04, 2017, 03:56:02 PM
#2
I had problems with older Logitech mouses.  Fortunately, the old one I had broke and the new one works great.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* March 04, 2017, 11:01:28 PM
#3
The default for depressed middle mouse button is "dynamic examine" not pan.
Have you changed it to pan via "additional device setup" in the customize toolbar palette?

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* March 05, 2017, 05:50:21 AM
#4
Adding to what Nikki posted Barry:
My version-20 Default Workspace configuration has Hold + Shift + Ctrl as the Wheel assignment for the Dynamic Pan command.  Perhaps it's the same in your current Workspace configuration.

(Again, that doesn't work for me, using my Microsoft wireless mouse; I have to substitute the right-click button for the wheel.)

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* August 26, 2018, 03:12:36 PM
#5
Hi all,
yes I know this is an old post but for new/occasional users the problems are still new....
The problem with the dynamic pan is it is sooo dynamic!
All I want is a simple Pan/drag across the drawing, not a complete 3d change of view that I now have to figure out how to undo.
Via "Plan view" ? I suppose tho not instantly intuitive.
The "additional settings" via toolbar, customize, "Options" page, only gives the dynamic views as an option for the combo, hold-ctrl-alt.
Why not able to assign any function to whatever button your mouse has?
cheers
ian

Logged
Tcd Deluxe17 64bit W10 - Mod eng


* August 26, 2018, 05:46:01 PM
#6
I've only ever used generic mice, using zoom to centre with the scroll wheel, zoom extents with the button click and while I don't know what you mean by "simple pan/drag" that's what  ctrl + shift + scroll button hold does by my definition.  Yes, it involves pushing keyboard buttons while you're multitasking the scroll button, but it does work right now, whatever else you might be wishing for or bemoaning the lack.  ctrl + shift + W recovers your workplane plan view too.  There are about 7 billion different opinions about what's intuitive on this planet. 

Logged


* August 26, 2018, 10:18:06 PM
#7
Did you try Dynamic pan instead of dynamic examine? That pans as expected for me.

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks