TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

Rendering With Materials
Read 4554 times
* May 29, 2016, 10:54:23 PM
Hi Everyone,
New here & to TurboCAD.
I have TurboCAD Deluxe 21.2 64-bit & can't seem to render correctly when selecting materials?
As a test I drew a simple 3d box & used the advanced render & it renders with the default black color.
When I select the box then select a Material-Wood in this instance then use the advanced render it still renders in the default Black color no matter what material I select?

Obviously I am missing something being a Newbie to this, any help would be appreciated.

Thanks

Logged


* May 30, 2016, 12:40:04 AM
#1
Maybe you are in wrong render mode, using ReSDK render on a Lightwork material, or the other way around.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* May 30, 2016, 01:26:19 AM
#2
Hi Torfinn,

Thanks for the reply!
You are more than likely correct, how can I check this out to make sure?

Thanks


Logged


* May 30, 2016, 03:27:36 AM
#3
Open Material Palette, select the material, right click it and at the bottom you will what kind of possebility you have for edit it, if i.e. RedSDK is greyed out it is a LightWork material.
Rigthclick at the "teacup"then it will show you what rendermode you are in, change there if if you need

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* May 30, 2016, 04:06:50 AM
#4
Hi Torfinn,

I opened the Materials palette as suggested, selected a Material, went right click & it has "Edit LightWorks Materials" at the bottom.
I then Right Clicked the Tea Cup & it has
Rendering Type:
LightWorks

Rendering Mode:
Full

Still no luck & can only render with the Black default render?

Thanks


Logged


* May 30, 2016, 04:17:33 AM
#5
You have light on ??
Open Design Director Palette, little bit down from Layear at the top of the palette, click on Light and this menu will open, is there open light there, as a yellow bulb, open Headligth and otr Ambient if not, not the eye, that only make it visible in Wireframe if you want adjust it somehow.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* May 30, 2016, 05:06:32 AM
#6
Hi Torfinn,

Yes, the Light was on & I changed it to headlight etc & you can see the light shading change but still no Materials render, can only get it to Grey now with better Lighting?

I will have to try again tomorrow, very late here now.

Thanks for the help so far, any more suggestions for tomorrow, besides throw the computer out the window ;D.

Thanks

Logged


* May 30, 2016, 05:20:03 AM
#7
any more suggestions for tomorrow, besides throw the computer out the window ;D.

You could post the file here for Torfinn or someone to have a look at.

Logged


* May 30, 2016, 08:26:08 AM
#8
Hi Torfinn,

I opened the Materials palette as suggested, selected a Material, went right click & it has "Edit LightWorks Materials" at the bottom.
I then Right Clicked the Tea Cup & it has
Rendering Type:
LightWorks

Rendering Mode:
Full

Still no luck & can only render with the Black default render?

Thanks

Did you actually apply the material to the object? Select the object; click on a material in the Materials palette; while still in the Materials palette, right-click to open the Local Menu and then click "Set Material."

...And the object is a 3D Box, right? You can't render a 2D Rectangle.

Henry H

Logged


* May 30, 2016, 09:18:35 AM
#9
...
When I select the box then select a Material-Wood in this instance ...
Thanks

It sounds to me like maybe you are selecting the Material Category "Wood", but not an actual Material within that Category.
In other words, that "None" is the current selection in the Material field-box... the field-box under the Category field-box.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* May 30, 2016, 10:13:01 AM
#10
And another guess :)

Can you see the material in the Material Palette, in other words, you see how that material look like there, not only the name of it.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* May 30, 2016, 11:25:56 AM
#11
Hi Everyone,
New here & to TurboCAD.
I have TurboCAD Deluxe 21.2 64-bit & can't seem to render correctly when selecting materials?
As a test I drew a simple 3d box & used the advanced render & it renders with the default black color.
When I select the box then select a Material-Wood in this instance then use the advanced render it still renders in the default Black color no matter what material I select?

Obviously I am missing something being a Newbie to this, any help would be appreciated.

Thanks

Hi,
Deluxe 21 comes with sample drawings. Load the "testing materials" drawing located in the 3D samples folder. All you should need to do is click on the tea cup to render. This might be a good way for you to troubleshoot any problems. Then you can study how John R (the author) set up everything.

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2019-2018-2017, TurboCad Platinum 21.Using LightWorks, Anilab lab 5. ATI Mobility Radeon HD 4500/5100 and HP all in one desktop with Nvidia Geforce 210, open gl 3.3


* May 30, 2016, 02:46:24 PM
#12
Thanks for the replies,

I have been doing it as suggested still with no luck, I can see the material in the palette & I also set Material etc.

I have attached a file of a simple Picket Fence I was playing with, when I try to render it:
I select it first, then Set Material, then go Advanced Render but it just renders with the default Black color?

I have attached a Screen Shot of this as well.

I appreciate the help with this, it has me buggered why it's not working correctly?

Thanks

Logged


* May 30, 2016, 03:53:57 PM
#13
Blocks, don't think anyone guessed that  ;)

either
Select everything and explode once, you can then apply any material wished. (this will sever the link to the blocks and turn the objects into TC surfaces)
OR
With the block palette open, select a block, click the EC button (edit contents) and apply the material there, click the green tick when done.

« Last Edit: May 30, 2016, 03:56:49 PM by Andy H »

Logged


* May 30, 2016, 04:14:02 PM
#14
Blocks, don't think anyone guessed that  ;)

:):)

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* May 30, 2016, 04:45:24 PM
#15
Hi Andy H,

Yep your correct, thank you very much, it works perfectly now ;D.

Thanks to everyone for helping, much appreciated!
 8)

Just one question, if I use the Explode example can I then return to using Blocks somehow?

Thanks
« Last Edit: May 30, 2016, 04:48:18 PM by willeng »

Logged


* May 30, 2016, 05:39:13 PM
#16
Hi Andy H,

Yep your correct, thank you very much, it works perfectly now ;D.

Thanks to everyone for helping, much appreciated!
 8)

Just one question, if I use the Explode example can I then return to using Blocks somehow?

Thanks

Sure. You can format any object as a Block. Just remember that if you need to make changes to a Block: select it in the Blocks palette, click the EC icon ("Edit Content"), make the changes, click the green checkmark ("Finish Edit Content"). That will update every copy of the Block in your drawing. Exploding a copy in the drawing erases its "blockness."

Henry H

Logged


* May 30, 2016, 06:29:39 PM
#17
Hi Henry,
I see, thank you for that information, very helpful!

Thanks to everyone once again.


Logged