TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

v2016 camera problem
Read 3037 times
* March 10, 2016, 07:56:24 PM
I installed full (paid for) 2016 after uninstalled the trial and built in folder, then installed Animlab from the link in the 2016 updates section of the forum,

My 2016 doesn't seem to be able to cope with animating using an added camera, in the png file, left is the whole scene, middle is the file saved back to 2015 for testing and shows the correct camera view when animating, however in 2016 the camera shifts to the upper corner - which is pretty bad.

Just wondered, before I start trying to narrow down the problem (reinstalling AL etc.), if there is any known problems with camera's in 2016, with or without AnimationLab, attached is the file saved back as 2015, if anyone tries it, the view is set but it will require using 'restore down' on the window to gain access to the 2nd window behind and deleting it so it just leaves the camera view only, just needs animating no settings need altering (unless one wants to render it).

Thanks 

Logged


* March 10, 2016, 10:38:18 PM
#1
If I move back far enough, it will create an animation, but not when I'm close to the subject. It makes me think that the Cut Plane feature is on or something like it.

I drew out a 3D polyline pointing to the box and then entered its start/end coordinates into the Position/Target fields. When I clicked OK, the polyline was in the upper right, not in the middle of my view, where all I should see are the rotation handles and a dot for the polyline. Something is broken in Camera Properties.

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* March 11, 2016, 06:51:55 AM
#2
Thanks for checking this John, I'll send a note to support.

Logged


* March 11, 2016, 10:33:03 AM
#3
Andy, I'm not following you. I get the exact same results and view upon opening the file in 2015 0r 2016,I run animation and the box rotates. I tile the windows and run animation and the box rotates. What's the problem?

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* March 11, 2016, 11:01:31 AM
#4
Hi Dean,  for me if I run the scenario in 2015 it runs as expected to the box rotating in the centre of the animation window (which is set as 1280 x 720), as shown in the centre 'screenshot' in the png above.

However in 2016, when I run the same file the view is ok until I try to animate, when TC closes and the animation window pops up, the camera view has shifted to the corner so the box can no longer be seen.

Logged


* March 11, 2016, 11:18:43 AM
#5
Are you saying that this only happens when creating and saving to file an animation?
2016 > When I run scenario,(save frames unchecked) everything is ok. I also notice that you don't have a saved view.

>Edit<
I just saved the animation to file and it worked ok, I'm in wireframe. what type of render style are you using?
« Last Edit: March 11, 2016, 11:24:04 AM by Dean »

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* March 11, 2016, 11:53:11 AM
#6
confusing  :-\  this is what I see when animating doesn't really matter and whether render or wireframe, the file is the same - just saved in two different names so it could be opened in 2015 and 2016,  https://www.youtube.com/watch?v=iM-LW3zz3A8

Logged


* March 11, 2016, 12:17:04 PM
#7
Andy,
It's probably a good idea to post your specs.  ;D
Maybe it has to do with windows version or display adapter, I don't really know much about all that stuff.

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* March 11, 2016, 12:40:26 PM
#8
Thanks for looking at the file Dean.

Computer is a few years old now (except for OP), intel i7-3770 (3.5GHz), 24 Gig ram, Windows10 64bit, Nvidea GTX660 Ti card.

I must admit I don't know what difference various computer components make on the use of TC between two versions of the program, maybe IMSI will know.

## Edit ## should mention I'm using the first release of 2016 v23.0 build 17.3,  ## End Edit ## 
« Last Edit: March 11, 2016, 01:08:38 PM by Andy H »

Logged


March 11, 2016, 01:43:39 PM
#9
I am wondering if this is related to something we found after TC 2016 started shipping and plan to address in our next update.
The Animation Lab frame output is linked (limited) to the Save As |Resolution setting for the same format.

According to development, that is the way it was in TC 2015.2  However I do not recall that ever being the case. 

Logged
Thanks,
Dave Taylor
TurboCAD Product Manager


* March 11, 2016, 02:38:56 PM
#10
This is a movie that I made of Andy's file. I made a "copy" of the file to use in 2016. I cut out some of the animation process to keep it short.

Andy, I tried to watch your movie, but it's "Private".

https://youtu.be/_HqXJbu36VQ
« Last Edit: March 11, 2016, 02:40:38 PM by John R »

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* March 11, 2016, 03:25:39 PM
#11
This is a movie that I made of Andy's file. I made a "copy" of the file to use in 2016. I cut out some of the animation process to keep it short.

Andy, I tried to watch your movie, but it's "Private".

https://youtu.be/_HqXJbu36VQ

Oops, reset to public now, but your video shows it much better with yours being rendered.

Logged


* March 11, 2016, 03:27:44 PM
#12
I am wondering if this is related to something we found after TC 2016 started shipping and plan to address in our next update.
The Animation Lab frame output is linked (limited) to the Save As |Resolution setting for the same format.

According to development, that is the way it was in TC 2015.2  However I do not recall that ever being the case.

Dave,  Whilst possible, it would seem odd as the camera view appears to move rather than just be at the wrong resolution.

Logged


* March 11, 2016, 03:28:07 PM
#13
Strange,
It works for me. Saved to file works too.

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


March 11, 2016, 03:44:43 PM
#14
I'll have development look into it.

Logged
Thanks,
Dave Taylor
TurboCAD Product Manager


* March 11, 2016, 03:58:08 PM
#15
I'll have development look into it.

Dave - think you may have been right,  I went into file menu save-as BMP changed the resolution and switched to view, saved a bmp image, went back into AnimationLab and it now shows correctly in v2016, even when I reset BMP back down to its default.

The downside is Windows now cannot play the produced AVI saying wrong video format, (it didn't do that before ) so I'll probably have to re-install AL and see what happens after that.

Logged


* March 11, 2016, 04:28:12 PM
#16
OK latest scenario,  re-installed AL, windows still cannot play a new AVI, however is can play all AVI's saved prior to using TC's file menu Save-as bmp image, playing Gif's is not a problem.

This one is going to take some thinking about as I now can't save any AVI's from v2015 neither, I don't know what was wrong with the BMP thing but now wishing I hadn't altered it, next step is re-install 2016. 

Logged


* March 11, 2016, 05:27:38 PM
#17
OK figured out what's going on, somehow (no idea how) when I used file save-as bmp the Microsoft video 1 compressor got messed up or something like that, and because the compressor is messed up it affects everything even is I install a previous AL version for example one used with v2015, Ah well, Just posting my findings as this will probably be machine specific.

Dean, as yours works ok, can you please load an AVI template like 1200x720, go to the movie page and post what compression is on (if any) and what the settings are, on my machine this template automatically turns on Microsoft video 1.

Thanks 
« Last Edit: March 11, 2016, 05:37:28 PM by Andy H »

Logged


* March 11, 2016, 06:09:12 PM
#18
Here ya go, Andy

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* March 11, 2016, 06:20:37 PM
#19
Thanks for posting Dean.

From your pic I see your using a custom uncompressed template (well - I should say - that the one in your pic isn't available on my system).

## Edit ## OK, after a few tests, what seems to have happened is that, whether it should have been or not,  previously compression was defaulting to off on my system for the default templates, which is something I've never taken any notice of in the past as I just loaded a default template and ran the scenario, somehow compressions has now been set to default on, and its this that is causing video's not to play, whatever happened when I changed the save-as bmp setting earlier I don't know, but at least all I need to do now is set up some new templates with default compression off,    This has definitely been a weird little fault especially as until Dave posted I would never have thought that using save-as to save a standard single BMP image would have cured my  original AnimationLab fault (even if it did cause a new fault).  ## End Edit ##
« Last Edit: March 11, 2016, 07:50:09 PM by Andy H »

Logged


March 12, 2016, 06:16:34 AM
#20
Just thought I would give Andy's file a try . . .

Installed 2016, Lightworks and Animation Lab to defaults.

Ran animation, and can confirm that 2016 does not animate this file properly on my PC.

I noticed that all file sizes, in 2015, are approximately fives times greater than 2016 - see attachments.

Also the stereo images in 2016 are not correct.

Does this help?


Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Testing/using with Win 10 and various TurboCAD 64-bit versions.


* March 12, 2016, 07:50:41 AM
#21
Maybe it's a window 10 thing  ; I refuse to update to W10 even when they do offer it comes with a free personal assistant. :P
 I still can't reproduce any of the above issues.
Tim, what is your display adapter, Is it a Nvidia?

edit;
Is everyone creating a view, I mean,Andy's file didn't contain a saved view (only view 0) but it still worked for me at first try.
« Last Edit: March 12, 2016, 08:15:43 AM by Dean »

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


March 12, 2016, 08:33:27 AM
#22
Hi Dean,

no, I didn't create a view, but will try this shortly.
This is how I found the file worked, "straight out of the box" with everything in TC set to default.

I use an Nvidia Quadro 2200 display adapter, but, the error is the same when I use the on-board Intel VGA graphics.
I don't think this can be display related as it appears more akin to OS v TC problem - perhaps . . . ?  :-\

I'll try with TC 2016 (the same default set-up) on another PC, again using Win 10, and see what gives.

Regards Tim

**Later** Tried again with TC 2016 (the same default set-up) on another PC, again using Win 10, and result is the same.
« Last Edit: March 12, 2016, 09:28:50 AM by Tim Stewart »

Logged
You can design without engineering, but you cannot engineer without design.
Testing/using with Win 10 and various TurboCAD 64-bit versions.


* March 31, 2016, 09:11:39 AM
#23
I noticed that all file sizes, in 2015, are approximately fives times greater than 2016 - see attachments.

Tim,

Please try to change any parameter in "BMP file Export" dialog and click OK. And all should work.
(Sometime AniLab does not see a filter options if these options have not been initialized/changed at least once).

Vlad

Logged


March 31, 2016, 02:16:24 PM
#24
I noticed that all file sizes, in 2015, are approximately fives times greater than 2016 - see attachments.

Tim,

Please try to change any parameter in "BMP file Export" dialog and click OK. And all should work.
(Sometime AniLab does not see a filter options if these options have not been initialized/changed at least once).

Vlad

Vlad,

thank you for reply.
Yes, changing any parameter in the "BMP file Export" dialogue, solved the file size problem with 2016 and AniLab.
Very strange . . . ???

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Testing/using with Win 10 and various TurboCAD 64-bit versions.