TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

AnimLab and 2015
Read 4034 times
* July 07, 2015, 11:23:25 AM
Sorry - I know I've posted about this in the AnimLab forum, but figured I may as well wish it to happen  ::)

My wish is simple - I wish AnimLab would work properly in v2015 and future versions, its a pain having to keep saving back from v2015 to v21 just so I can animate something without error, made worse in that I can't have v2015 and v21 open at same time (causes crashes), though don't bother about that - that's just my computer problem.

Please sort it out so Animlab will work in 2015 properly (without the 'unusable' workaround) - ta.

Logged


July 07, 2015, 12:22:48 PM
#1
Andy can you please provide more details about this?
If there are any steps and samples you can provide to help troubleshoot, it will save time and help us fix the problem faster.

Logged
Thanks,
Dave Taylor
TurboCAD Product Manager


* July 07, 2015, 02:52:33 PM
#2
HI Dave

Sorry - I should have mentioned - its with respect to the undo buffer

This link shows the original problem http://forums.turbocad.com/index.php/topic,16469.0.html

I've just done a little video showing the steps taken for both scripts and keyframes - next to "undo buffer problem" click the button marked 'click for video' http://www.woodturningcad.co.uk/tcstuff.html

I should point out that IMSI tech support have looked into my original post but cannot reproduce then problem, so obviously cannot fix something they cannot reproduce.

I'm using fully patched v2015 64bit ##Edit## added Pro Paltinum ##End Edit##, RedSdk only (no lightworks), Intel I7, 24Gb ram, Gforce 660, Windows 8.1

Thanks
Andy
« Last Edit: July 08, 2015, 05:05:29 AM by Andy H »

Logged


* July 07, 2015, 05:06:25 PM
#3
Andy, check this out. http://forums.turbocad.com/index.php/topic,17192.msg100474.html#msg100474

The latest builds seem to work a little better. Have you tried creating a new file in the latest build using key-frame animation? Perhaps it's best to continue this in the Anilab section.

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* July 08, 2015, 02:00:14 AM
#4
HI Dean,

By latest build I assume you mean TC, I'm using pro platinum 22.1 build 30.1, the AnimationLab is the one posted by Travis on the forum.

One thing I've not tested, I only recently got my spare computer working again which has Window 7 on, so I'll try installing 2015 and AL on that one and report back.

Note for IMSI,  - its only a test I'll uninstall 2015 from it after testing so I don't break any licence agreement.

## Edit ## ok, just finished testing - using different computer, TC22.1 pro plat - build 30.1  Win7, 8 gig ram, graphics card not supported so used GDI mode, exact same results, undo buffer messed up in both script and keyframe editors, the only other test I can do is download the free trial of deluxe and try that. ## End edit ##
« Last Edit: July 08, 2015, 03:36:43 AM by Andy H »

Logged


* July 08, 2015, 04:56:01 AM
#5
OK, just downloaded the trial deluxe and AnimationLab works fine - no undo buffer problem, so I then tried just with pro (without the platinum tools activated) and tried a different theme / config, still faulty.

To me -  this confirms the problem is with 2015 pro / pro platinum, NOT AnimationLab,

IMSI, I'm sorry, but its still on my WISH LIST that AnimLab would work properly with 2015 Pro / Plat (even if I didn't word it correctly)

Dean, many thanks for checking this, you are better off using deluxe with AnimLab.
« Last Edit: July 08, 2015, 05:33:50 AM by Andy H »

Logged


* July 08, 2015, 06:25:58 AM
#6
Andy,
I tried an older file. This is a bit more complicated animation that I created following Kai's tutorial a few years back, i think. There are issues with the undo buffer with this file. When I hit undo a part of the fly wheel changes coordinates but the animation works. Some other files that I tested didn't have issues with the undo buffer. I chose to disable animation lab undo buffer and created this animation
 https://www.youtube.com/watch?v=twQjCP5F3nE.
I am still testing. The keyframes work ok. so far. The advanced redsdk renders work just takes a while to render. I agree though, we shouldn't be having any problems = at all :P

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* July 08, 2015, 08:13:32 AM
#7
very nice work Dean, and smooth running, did you use constraints with this ?

Logged


July 08, 2015, 12:24:20 PM
#8
Hi Guys,

I had a play with v22 and Animation Lab this afternoon, and, this is what happened:

Open file test-v22.tcw (refer to attachments), using GDI.

1.  Run scenario, with Add AnimationLab Scenario to undo buffer ticked under Preferences.
2.  Select Edit to undo AnimationLab Scenario - this appears to work as normal.
3.  Without altering anything, run scenario again.
4.  Option offered under Edit is to Redo AnimationLab Scenario not Undo AnimationLab Scenario.
5.  Select Redo AnimationLab Scenario - this doesn't work.
6.  Select all actors at last frame, in Key Frames editor, and undo manually - this works.

Under v21 the animation, and undo, work as intended.

I hope  this helps.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Testing/using with Win 10 and various TurboCAD 64-bit versions.


* July 09, 2015, 02:52:33 AM
#9
 ;D your file does do strange things with the buffer Tim, I played with it and ended up with the colour order on screen as per your second pic, but when I clicked each box their colour was as your first pic, pressed a few more buttons then TC crashed with a UE.

I then had another play, ran the scenario, but instead of using undo I drew another box (not animated), right clicked where it should have said undo box, but instead it said undo AnimationLab scenario, as you say it works fine in v21
 

Logged


* July 09, 2015, 05:27:50 AM
#10
I think the best way to work is to disable Anilab's undo buffer. Always let the animation finish if doing a test drive in modelspace. With the undo buffer enabled it also seems to screw up Turbo's undo. Different types of animated drawings give different results. Bottom line is that Anilab does work and it doesn't work :P Looney Bin time for sure ;D
I created the attached AVI animation using Tim's file slightly modified in turbo platinum then opened it in montage center and created a smaller Animation (cell phone). Keyframes and AVI give the best performance. 

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* July 09, 2015, 07:15:59 AM
#11
I think the best way to work is to disable Anilab's undo buffer.

Whilst a very good point Dean if using keyframes, The problem comes when using script commands, without the undo one has to keep closing and re-opening the file after every test (which is what IMSI advised me to do), great if one is good at animation, but me - I'm a not that good and may do up to 10 tests (with save frames turned off) before I like something or have the timings right, and that's assuming I don't forget not to save the file (a fatal error) or I forget to work on a backup copy.

Very Sorry - I'm not getting at you Dean, I know you are doing your best with what IMSI give us, its just so frustrating.

Thanks ......... Andy

Logged


July 09, 2015, 11:08:56 AM
#12
Thanks Dean for your efforts.  Saved me from doing the same thing!  ;D
Hopefully, this issue will be resolved soon?
I don't mind testing, when I have the time, but, seriously, any work-around like this is not good enough for long-term use, particularly when AnimationLab has been behaving well, with earlier versions of TurboCAD.
Looks like a 'bugette' has crept into the code!

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Testing/using with Win 10 and various TurboCAD 64-bit versions.


August 24, 2015, 03:43:42 PM
#13
We have not been able to reproduce the undo problem using TC 2015 and the build of Anilab that should be paired with it.
See this note

http://forums.turbocad.com/index.php/topic,17285.msg102004.html#msg102004




Logged
Thanks,
Dave Taylor
TurboCAD Product Manager


August 24, 2015, 04:12:53 PM
#14
I created a movie to show the behavior.
https://youtu.be/_njlqG_zOuY

Obviously the reason I to run the undo 2 times is because I ran the play scenario 2 times consecutively
« Last Edit: August 24, 2015, 04:22:20 PM by Dave Taylor »

Logged
Thanks,
Dave Taylor
TurboCAD Product Manager


August 24, 2015, 04:23:40 PM
#15
Sorry also realizing now that Tim's point about Redo Play scenario should work but to his point does not.
Also now going over Andy's movie showing his use case..stay tuned.

Logged
Thanks,
Dave Taylor
TurboCAD Product Manager


August 24, 2015, 04:46:10 PM
#16
I cannot reproduce the problem(s) demonstrated in Andy's movie however.
Both use cases seem to work as expected for me...

Logged
Thanks,
Dave Taylor
TurboCAD Product Manager


* August 24, 2015, 05:59:04 PM
#17
Thanks for looking into this Dave.

Alas, I uninstalled AnimationLab and reinstalled from the link you provided, and get exactly the same results on both my 2 files and Tim's file.

Do you wish me to post a video of what happens on my machines, I don't mind either way, v21 and Animations works perfectly well, there is obviously something different between our two machines but I've no idea what.

Thanks
Andy
Tested using windows7, TC pro platinum 2015 build 30.1, Lightworks NOT installed, (latest TC 2015 build obtained from the update and patches section of this forum).


 
« Last Edit: August 25, 2015, 05:46:51 AM by Andy H »

Logged


August 25, 2015, 11:06:48 AM
#18
Hi Andy.

I just want to be clear.  Are you now only having the problem Tim describes, specifically that Redo Scenario does not re-run the sequence but rather that it skips the last frame in the sequence?   I am able to repeat this one.

Or is there another problem?  If this is the case then use create a movie to demonstrate please.  As mentioned below I could not reproduce the problem you created the movie for where objects were disappearing or being displaced.  So i wan tot make sure that issue is resolved.


Logged
Thanks,
Dave Taylor
TurboCAD Product Manager


* August 25, 2015, 11:23:10 AM
#19
HI Dave,

For me the undo problems persist with thing moving out of position or disappearing,  I'll knock up a video, but I should add that Tim's problem isn't the redo, its the fact that after the first undo, and then re-running of the scenario, the undo is no longer available for selection (at least for Tim and myself).

Anyway as I say I'll do a video and post the link here..

Thanks

Logged


* August 25, 2015, 01:21:36 PM
#20
Dave,  Video uploaded, I've marked it as unlisted so you will need to use this link.

There are 3 examples, all three tests were done using 64 bit windows7 with default setup, using 2015 from the forum updates full build (no Lightworks), and AnimLab from the link you provided,  but as I don't have my recorder on that computer its recorded on my main computer on which I have the setup how I like it, the results are identical on both computers.

I realise if you cannot replicate the problem then it will not be possible to solve, but wanted to say thanks for looking into this.

https://youtu.be/m-zrLU9h5IY 

Thanks
Andy
« Last Edit: August 25, 2015, 02:12:56 PM by Andy H »

Logged


August 26, 2015, 02:36:02 PM
#21
Ok thanks for doing this.   I will discuss with QA and development, hopefully the can replicate and solve the problem.

Logged
Thanks,
Dave Taylor
TurboCAD Product Manager


August 26, 2015, 02:40:38 PM
#22
After thinking about it for a moment....have you tried to delete your built in folder?

C:\Users\<username>\AppData\Roaming\IMSIDesign\TurboCAD 2015\Professional x64\Profiles\Built-In


Logged
Thanks,
Dave Taylor
TurboCAD Product Manager


August 27, 2015, 06:28:15 AM
#23
Thanks to Andy for testing.

Dave: I have tried animating another 3D file, one which comes with TC.  Take a look at:

https://youtu.be/MsJNTO4Ew2E

this is my first attempt at illustrating this behaviour  - so not perfect yet!

The animation essentially moves all the lamp spins, except the base in a vertical direction and then returns them to the start position.
As you may notice, this gets a bit messy after a few runs.

NOTE: deleting the built-in folder made no difference.

I hope it helps resolve these issues.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Testing/using with Win 10 and various TurboCAD 64-bit versions.