TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

Testing Redsdk with Anilab 5
Read 2508 times
* June 25, 2015, 01:43:51 PM
Well i probably won't get a Nobel prize for this animation script but it does look like  photo-realistic animations might not be that far away using  Redsdk_Anilab 5 and Turbocad. This took about 1 hour to bake at 900x650 it's 41 frames and I used  key-frames. I used a custom Global illumination render style. I'll keep testing and keep this updated.
Watch it at full screen, It's pretty clear on my screen.

https://youtu.be/bwumUNyrwl4

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* June 25, 2015, 02:56:57 PM
#1
Very nice Dean, the reflections have rendered really well.

Logged


* July 07, 2015, 05:01:41 PM
#2
i tested Anilab 5 with Turbo deluxe latest build.(64 bit)
These are simple animations. I 'm taking small steps while testing but the latest builds seem to work better. Drawing was created in the latest build.I used two scripts. Rotate and light color on the spot. Redsdk draft render. This didn't take very long 1250x 650 bmp frames.

Here's the video    https://youtu.be/7ZUX2d7llXc

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* July 18, 2015, 05:24:57 AM
#3
Here's another old file that I dug up and I am able to post.
I think Henry and Branko were working on this file and I created the animation. Sorry but I don't remember :P
I tested this in Deluxe and Platinum 2015. The trick is to always let the animation finish when testing a preview. This was created in the script editor no key frames used.
This took about 20 min. @ 640x440 AVI.

Here's the animation  https://youtu.be/dSArY4rrMN0

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* July 18, 2015, 06:14:07 AM
#4
Very nice indeed Dean.

Can I ask - are you using RedSdk metal or using your own, I find RedSdk metals very slow on my machine, but 20 minutes seems a pretty good time for high quality render / Animation 

Logged


* July 18, 2015, 02:16:15 PM
#5
I tried the "Panorama360Steps" preset scenario on a simple drawing and it was a bust in my opinion. The first 80/90 frames were blank, then the rendered frames finally kicked in.

Logged
John R.

V17—V21, 2015, 2016, 2017
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* July 18, 2015, 06:14:29 PM
#6
I tried the "Panorama360Steps" preset scenario on a simple drawing and it was a bust in my opinion. The first 80/90 frames were blank, then the rendered frames finally kicked in.

That's strange, John >It worked for me. I tested a redsdk draft and a custom advanced GI quick style using my house wizard file. I find the AVI's with BMP images work the best. these didn't take very long to bake, maybe 5-10 mins. 640x440. I selected "play scenario" > Panorama

Redsdk custom GI animation >  https://youtu.be/yCugw59-CKs

Redsdk Draft animation > https://www.youtube.com/watch?v=boOSQ1qIic8

"Can I ask - are you using RedSdk metal or using your own, I find RedSdk metals very slow on my machine, but 20 minutes seems a pretty good time for high quality render / Animation"

Andy,
I created my own metal material but there shouldn’t be that much of difference in render times if using the default metals. I saw a 3 sec difference in my current scene. There must be something else in conjunction with the default metal material in your drawing causing it. Have you tried minimizing the drawing window? For ex: try setting it at 600x400, see if that helps to cut down the render time. I saw a 100 sec difference between a 640x440 and full screen Standard Global illumination render.
« Last Edit: July 18, 2015, 06:56:10 PM by Dean »

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


* July 19, 2015, 01:51:41 AM
#7
I think my installation is haunted as I just tried the panorama, I drew a box for a floor - 4 walls - roof - 5 windows and a door, a pretty simple house, I saved the file, deleted one of the windows and re-saved the file and immediately ran the panorama in wireframe, which actually worked ok, but, when the panorama finished it put back the window I had previously deleted  ???.

Perhaps TC thought my house looked better with 5 windows ;D

I'll give your suggestion regarding the drawing window a try ....... Thanks
« Last Edit: July 19, 2015, 01:53:45 AM by Andy H »

Logged


* July 20, 2015, 08:32:32 AM
#8
I tested animating a parametric symbol > set property value> and the 'undo buffer" was working.
Attached is the animation.
« Last Edit: July 20, 2015, 08:43:50 AM by Dean »

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100


July 20, 2015, 12:16:09 PM
#9
Dean,

would it be possible to try the same file?

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Testing/using with Win 10 and various TurboCAD 64-bit versions.


* July 20, 2015, 04:22:29 PM
#10
Better yet, Tim  ;D > try the MechTest sample drawing. i didn't experience any problems.

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2016-2017, TurboCad Platinum 21(Best working version,IMHO) Using Lightworks for reliability/stability and testing redsdk, Anilab lab 5, Renditioner Pro V3. ATI Mobility Radeon HD 4500/5100