TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

camera turns over 180 degrees
Read 1087 times
* March 05, 2015, 11:32:06 AM
Hi Guys,

Before I will throw out my computer I thought I would try and ask you if my camera issue can be fixed.

I try to have a camera as actor to follow a 3D spline around an object and this works fine.
Unfortunately when I give the co-ordinates for CameraLookAt (which is in the middle of the object) The camera looks precisely away from these co-ordinates, as if the lens were on the backside of the camera.

It must be something simple but it eludes me still. I am at the point of eating the mouse  >:(

Thanks for your help
Ralf

Logged
TC V20.2
TC V2015 pro
AnimationlabV5
Turbocad CAM


* March 05, 2015, 02:17:31 PM
#1
Had a play but not been able to reproduce your problem yet, can I ask how many windows do you have open (assuming the camera is one you have inserted), and are the coordinates correct - i.e. world coordinates. 

Logged


* March 05, 2015, 02:27:30 PM
#2
Yes I did worldsetting but tried all other settings too.
I even tried to put the CameraLookAt outside the spline and then it looks to the center of the spline. It is really trying to bulley me >:(

Anyway I am now running the scene with a mobile cam.

When I tried it with an inserted Cam (which I picked up from your Youtube clip for Walking through a house (Nice!)). I had two screens open.

I will try it again as I am circling a truck and want to do a walkthrough after that. It will be easier to do this with an inserted cam as I can have two screens then.

Ralf

Logged
TC V20.2
TC V2015 pro
AnimationlabV5
Turbocad CAM


* March 05, 2015, 02:41:37 PM
#3
I wouldn't advise animating using two windows when using any of the commands beginning with camera, I've seen it where the command switches to the default camera instead of the one inserted - even if one starts the animation in the correct window, I'd suggest setting things up using two windows (one associated with the camera), then before animation, turn off one of them leaving just the one used by the camera (there should be a tick next to camera in design director).

The camera commands should (hopefully) then work correctly

Logged