TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

Render speed in animationlab 5
Read 2666 times
* February 17, 2015, 01:26:53 AM
Hi

Does anyone knows what the bottleneck for rendering with Animationlab 5 is:
I work with TC v20.2 64 bit and animationlab 5 64 bit
GPU NVIDIA GT750M (not supported by Redway but I believe with Light works that does not matter)
CPU i7-4702MQ (intel)

See attached picture (it is wide so scroll to the right to see the Taskmanager and Nvidia monitor)
The GPU is completely flatlined all the time (not even a hickup while presenting the next frame)
The processor  runs on 19% capacity
RAM uses 58%

With my limited hardware knowledge I cannot figure this out but would like to know where to start improvements

Thanks
Ralf
« Last Edit: February 17, 2015, 01:29:07 AM by ralfkras »

Logged
TC V20.2
TC V2015 pro
AnimationlabV5
Turbocad CAM


February 17, 2015, 08:50:12 AM
#1
Hi Ralf,

the animation is running okay, as far as I can tell.
How many frames, what resolution?
It can take a long time, if you are rendering a complex image, and, you may notice that things start to slow down as the animation continues.
Example: 1000 frames @ 1024 x 768 might take 17 - 18 hours.
Are you saving each image for future use?
How much memory (16GB?) do you have installed? What OS are you using?  TurboCAD 32-bit or 64-bit?

Regards Tim
« Last Edit: February 17, 2015, 09:03:53 AM by Tim Stewart »

Logged
You can design without engineering, but you cannot engineer without design.
Testing/using with Win 10 and various TurboCAD 64-bit versions.


* February 17, 2015, 09:34:06 AM
#2
Thanks Tim for your reply,

I run Windows 8.1, with 16 GB RAM and an NVIDIA GeForce GT750M which has 4GB
For some reason TC 20.2 only uses about 9GB RAM during the rendering of the animation.
Also the NVIDIA GPU is not addressed at all
Further more the CPU does not get used over 18% capacity (on the taskbar while rendering)
A have set every setting I could find on max power / performance.

The animation consists of 181 frames of 1920 x 1080 I know this is pretty stressfull but
as far as I can see the hardware does not nearly get used to its full capacity and therefor I suspect a lack of knowledge from my side for setting up the hardware to its max .

Ralf
 



Logged
TC V20.2
TC V2015 pro
AnimationlabV5
Turbocad CAM


February 17, 2015, 11:32:55 AM
#3
Hi Ralf,

I suspect that TC uses only the CPU for calculating, and, can only address up to 8GB of RAM, but this is an educated guess.  :-\
Perhaps someone from IMSI could clarify this.
Have you set your programme (TC, Animation Lab) to run as a priority?

To do this, as with most programmes:

1.  Open task manager.
2.  Right click on TurboCAD and select Go to details.
3.  Right click tcw21.exe.
4.  Go down to Set priority and set to High (default is Normal).
5.  Run your animation and see if there is any improvement.

Hopefully, this will help.


Regards Tim
« Last Edit: February 17, 2015, 11:48:38 AM by Tim Stewart »

Logged
You can design without engineering, but you cannot engineer without design.
Testing/using with Win 10 and various TurboCAD 64-bit versions.


* February 18, 2015, 01:38:28 AM
#4
Hi Tim,

No I did not do that yet (did not know about this possibillity). for now I have to wait as it is still rendering.
But I see now that it is at frame 114 that it is using 9,2 GB RAM so as it progress it accumulates data in RAM
I wonder why the GPU is not addressed and if it will be addressed when using REDSDK rendering.

Ralf

Logged
TC V20.2
TC V2015 pro
AnimationlabV5
Turbocad CAM


February 18, 2015, 03:14:20 AM
#5
Hi Ralf,

so, did your animation finish?

I do not use Redsdk, so I cannot comment.
But, it is still likely that the majority of the work will be done by the CPU.  That's the way it is.
Anyway, experiment with GDI and Redsdk, using smaller animations.

It can help by allowing the PC to run the animation, overnight perhaps, without using your PC for other things.

Regards Tim

Logged
You can design without engineering, but you cannot engineer without design.
Testing/using with Win 10 and various TurboCAD 64-bit versions.


* February 18, 2015, 04:16:01 AM
#6
Hi Tim

It is now rendering for over 24 hours but the system is stable and gradualy going to the motions. The Time left is displaying -0.20:20 but as it still needs to do 61 frames I guess it will run well into the evening again.

I do not use this PC while it renders except for monitoring the performance of the CPU, Memory and GPU.

I now am using my classic AMD dual core ASUS which served me very well since 2007 :)
Just for prepping the scene's

Ralf

Logged
TC V20.2
TC V2015 pro
AnimationlabV5
Turbocad CAM


* February 20, 2015, 06:36:52 AM
#7
Hi Tim,

The Render is finished now and took 51 hours in total.
It still has some light problems causing shdes to move around unnatural.

I also found out that when I render in [Quality] instead of [Advanced], [depth of field], [none], it is unbelievable faster without losing  render quality.
I find that strange as Advanced rendering uses multi thread rendering while quality does not.
 I done some tweaking and as soon as it is done I will post it here.

Thanks again for your help,
Ralf

Logged
TC V20.2
TC V2015 pro
AnimationlabV5
Turbocad CAM


February 20, 2015, 07:59:55 AM
#8
Hi Ralf,

glad to hear your animation finished at last - phew - 51 hours!  ::)
Looking forward to seeing the result.

As an aid to decreasing the rendering time, it might also be worth trying the following:

1.  Do not allow Anilab to create a movie as it runs, un-tick Add new frames to movie immediately after creation, under  AnimationLab Options/Movie.

2.  Select None, under AnimationLab Options/Preferences.

3.  Click Save Frames as image files, under AnimationLab Options/Frames.

When the rendering has finished, you will have many image files, either BMP or JPG, and these can then be turned into an animation, using the IMSI Montage Center, Windows Movie Maker, or, any suitable programme.  Any sections that don't look natural can be rendered separately until you are happy with the result.  You don't have to render all frames each time, if one or two are wrong.

I hope this helps.

Regards Tim
 
« Last Edit: February 20, 2015, 08:10:43 AM by Tim Stewart »

Logged
You can design without engineering, but you cannot engineer without design.
Testing/using with Win 10 and various TurboCAD 64-bit versions.


* February 21, 2015, 04:02:56 AM
#9
The render is finally ready. Turns out I can do it in 4 hours in Quality mode.
That is a major improvement over 51 hours

Here is a link to the clips first scene. still 19 scene's to go :)

https://www.youtube.com/watch?v=mjDkE_eYjY0

Regards
Ralf

Logged
TC V20.2
TC V2015 pro
AnimationlabV5
Turbocad CAM


February 21, 2015, 05:20:24 AM
#10
Ralf,

excellent work.  I especially liked the braking and suspension movement.   8)

Regards Tim

EDIT:  Umm, I have never tried advanced rendering, with AnimationLab, so, your report is well worth recording for future use.
« Last Edit: February 21, 2015, 11:27:21 AM by Tim Stewart »

Logged
You can design without engineering, but you cannot engineer without design.
Testing/using with Win 10 and various TurboCAD 64-bit versions.


* February 21, 2015, 09:12:55 AM
#11
Very nice work, I too like the cab movement - a really nice touch.

and thanks for the tip regarding advanced render, never used it myself and going off your experience I don't think I'll bother trying it in an animation.

Logged


* February 22, 2015, 02:37:32 AM
#12
thanks Guys,

I will post the animation ones it is finished ( I hope in about two weeks)

Regards,
Ralf

Logged
TC V20.2
TC V2015 pro
AnimationlabV5
Turbocad CAM