TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

Patch for 21.2.59.0
Read 4083 times
November 22, 2014, 03:31:32 AM
Hi users

Haw can i get the new patch for  21.2.59.0?
Thank you

Logged
Architect living in Mali ( West Africa)
Turbocad from TC3 to TC pro Plat 2017 user
www.quarc-design.com


* November 22, 2014, 05:30:35 AM
#1
You can get the Full Builds below. Uninstall your current V21 Version and install the newer version. They may get the TurboCAD V21 board updated this weekend or Monday. I don't see an update for Deluxe yet.

V21 Professional 32-bit: http://downloads.imsidesign.com/ESD/TurboCAD_Pro_21-2_59-0_x86.exe

V21 Professional 64-bit: http://downloads.imsidesign.com/ESD/TurboCAD_Pro_21-2_59-0_x64.exe

Fix list: http://www.turbocad.com/Turbocad-212-Pro-Build-590 No change from the Build 550 list.
« Last Edit: November 22, 2014, 05:52:36 AM by John R »

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10 Pro, 64-bit


* December 02, 2014, 05:47:05 PM
#2
Hi John,

I have that build installed now (thank you for the post), and after having some problems (UE's), I gave a quick glance to see what the tcw21.ini file was about, and noticed this setting about 4 from the bottom:

;0,1; default=0
UNITSOFLENGHT_FROM_DRAWING=0

s/b units of length

Has nothing to do with my needs (it's under ## RAYTRACE ## entry), but you folks doing lighting technology might want useability from the setting.  I suppose it always just defaults.

Lee


Logged
V21 Plat build 59 x64  / LW / Win7 64; Intel 3000 GPU; 3.1GHZ; 16GB


* December 02, 2014, 06:01:57 PM
#3
Hi John,

I have that build installed now (thank you for the post), and after having some problems (UE's), I gave a quick glance to see what the tcw21.ini file was about, and noticed this setting about 4 from the bottom:

;0,1; default=0
UNITSOFLENGHT_FROM_DRAWING=0

s/b units of length

Has nothing to do with my needs (it's under ## RAYTRACE ## entry), but you folks doing lighting technology might want useability from the setting.  I suppose it always just defaults.

Lee

It's been misspelled for years.

If you set the value to 1 instead of 0, you might find that lights with the FallOFF parameter set to something other than "No Attenuation" will behave more realistically.

Henry H

Logged


* December 02, 2014, 08:25:37 PM
#4
The typo has been there since the beginning. There's a "Rendercore" page in the "LightWorks Help" file that attempts to explain that stuff. I've always had it set to "1" because I used Goniometric luminances with a "Lumen" intensity. If the "UNITSOFLENGHT…" setting was 0, the lumens specified in an IES file were too dark, but when it was set to 1, the luminances displayed the proper light intensity. I haven't tested anything with luminances in a long time.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10 Pro, 64-bit


* December 03, 2014, 01:25:32 AM
#5
Ah. So. . .
Well, I'm really not looking for things like this, honest, I'm just trying to secure my config (60 custom keys) through the UE's and reinstalls, etc. But in this build, under the 'My Documents' tree, in my ..\config\mykeys.xcfg file, I think the word should be theme, but is spelled 'thene=2' (above 'largeIcons=0'). So, 2 would correspond with 'default' in the 3 choices. -My setting.

I have no way of knowing if this matters to anyone, just hard not to make note of it, JIC. BTW, this folder full of config pairs saved me on one reinstall, as I had no Built-in copy.

For some reason it was empty the next time I needed it. Know what de-populates it? The uninstall didn't the first time.

Lee


Logged
V21 Plat build 59 x64  / LW / Win7 64; Intel 3000 GPU; 3.1GHZ; 16GB


* December 03, 2014, 09:21:36 AM
#6
Lee,

There are two Config folders. One is in the "Documents" or "My Documents" folder (such as ..\Documents\TurboCAD Professional 21x64\Config). This is where the custom and supplied Workspaces are stored. When one of these are loaded (you use the "Load From" button), the "Current.xml" and other files are updated in the Built-In folder. There is a second Config folder that is a sub-folder to the "Built-In" folder. I really don't know why it's there. It's always been empty for me.

There have been times when some hotkeys go on holiday, but it's an easy thing to reload my workspace and they're back. I've "looked" at the XML files briefly, but never tinkered with the coding. I have too many icon images in the file and don't want to mess those up.

The only thing I keep a copy of from the Built-In folder are the "tcw21_xml.ini" file and the "tcw21.ini" file. When I first install the program I'll go through the TurboCAD Explorer palette and make changes to the defaults settings (expand "Settings", then "Built-In(Current)). Once I've changed the various Tables, System & Drawing_Defaults and any other changes in the Options menu, I'll close the program and copy the "tcw21_xml.ini" to the "Profile" folder (one step up). The "tcw21.ini" file won't appear until you render one time. If there is a reinstall/update, the "Built-In" folder is wiped clean when the program starts and new "default" settings are used. After shutting it down, I can safely copy-n-paste the two INI files into the Built-in folder to replace the current ones, then restart. Load my custom workspace and I'm back in business with everything the way I want it.

Goodness, I'm writing a novel here.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10 Pro, 64-bit


* December 03, 2014, 05:06:37 PM
#7
I appreciate your novel, John. It's a good read.

I've done a mix of procedures from various posts and sites, across vss, not always successfully, so this is a boon. I'm not done with R&R, maybe for some time. Develops character, tho.

thanks, Lee


Logged
V21 Plat build 59 x64  / LW / Win7 64; Intel 3000 GPU; 3.1GHZ; 16GB