TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

DASHED LINE
Read 6465 times
* April 04, 2014, 04:02:00 PM
Never can seem to make my dashed lines keep the same spacing. Is there way to set this so it does change with a mind of it's own. If I edit it , it gets bigger.

Logged


* April 04, 2014, 04:10:55 PM
#1
Never can seem to make my dashed lines keep the same spacing. Is there way to set this so it does change with a mind of it's own. If I edit it , it gets bigger.

Pen Width setting to "World" or "Device Width".  "Device Width" applies the "Device" setting to the pen-width, but not the Dash Scale.
___
What you are asking... the issue you are describing... is very buggy indeed.  That's why I promote (if not doing the above; not electing to do the above has merit):
  • In Modelspace, set your Options/Space Units/"Type" and "Scale" to that matching your eventual Viewport in Paperspace.  (Yes, that means changing that setting to match whatever you are working on... for example:  standard USA floorplan Viewport: ¼"=1'; footing sectional detail: 1"=1'; etc.)
  • Zoom Printed Size in Modelspace to ascertain what the dashed-scale (Dashed, Hidden, etc.) is going to look like when actually printed

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* April 04, 2014, 04:11:38 PM
#2
Try the "Alignment" option in Pen Properties. It might help.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


* April 04, 2014, 04:21:59 PM
#3
To gain an understanding of how "Dashes" (not to be confused with the Dash pattern named "Dashed", which looks very much like "Hidden"), open your Line Styles Editor.  Look at the values of the "Dashed" and "Hidden" dash patterns.

Making sense of those will aid in making sense of how these Dash patterns are created, and why they seem to "have a mind of their own" in Device Pen Width "Scaling" setting (which is deceiving-- this setting effects the Dash Pattern as well).  Understanding how these Line Styles are created aids in understanding how the settings effect the Dash Pattern scale that is presented.

[for those following along:  Line Styles Editor is not available in Designer or Deluxe... at least not up through version-19.  In Deluxe (and Designer?) Line Styles' viewing and editing has to be accessed via a cumbersome method in TC Explorer Palette.)
« Last Edit: April 04, 2014, 04:26:28 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* April 04, 2014, 04:31:02 PM
#4
Alvin, I'll have to study your replies, thanks,

John, I tried that, but "alignment" is greyed out. When you say "in pen properties" where do you start that, just selecting a line or going into style manager or something?

Logged


* April 04, 2014, 04:43:03 PM
#5
Never can seem to make my dashed lines keep the same spacing. Is there way to set this so it does change with a mind of it's own. If I edit it , it gets bigger.

Being that I mostly draw (residential) construction plans, as you are working on currently Ivey, I know what you are trying to achieve.

The "Alignment" option (in most 2D Objects Properties' Pen page, under Dash Scale) I don't believe is what you are looking for.
That "Alignment" basically makes the corners of Rectangles, Squares, and other Polygons solid so that a space (within the Dash Pattern) does not occur at the "corners".

___
Can you explain and clarify what you are doing exactly when you say "If I edit it, it gets bigger".  How are you editing "it"; and what is "it"?

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* April 04, 2014, 05:02:09 PM
#6
At the moment I am drawing the switch leads to each light fixture it controls with dashed lines. I don't really make electrical plans like on commercial, but the electrician needs to see locations of devices and switch paths. But every line I make seems to have a mind of it's own, could be I am selecting two different types, there are two that look the same but are different. I usually get it figured out before I print, but I was hoping for an easier way than trial and error.

Logged


* April 04, 2014, 05:06:45 PM
#7
Yes, one is Hidden and the other is Dashed, I guess as you said, I seem to be getting mixed up, hidden on some lines and dashed on the others, I'll fix that, I guess dashed is what I want.

Logged


* April 04, 2014, 05:11:11 PM
#8
At the moment I am drawing the switch leads to each light fixture it controls with dashed lines. I don't really make electrical plans like on commercial, but the electrician needs to see locations of devices and switch paths. But every line I make seems to have a mind of it's own, could be I am selecting two different types, there are two that look the same but are different. I usually get it figured out before I print, but I was hoping for an easier way than trial and error.

If you are working in Modelspace (you should be for electrical wiring), go to Options/Space Units and change your Scale to "Architectural" and ¼"=1' (I am making the assumption that the Viewport your wiring is set to a Scale of ¼"=1').
>Set you view such that one of the wiring is in the middle of the screen.
>Go to View/Zoom, and select "Printed Size".  Don't Zoom in or out.
>I assume you are using a Bezier Curve for your wiring (I do).  Select that Bezier Curve and in its Properties/Pen page, select Scaling="Device" (I am making the assumption that you don't use the "World" scaling; doesn't seem that many of us do)
>In Dash Pattern, select "Hidden".
>In Dash Scale, select something like .4 (that's "point-4")
>Remember, you haven't zoomed out or in from "Printed Size"... keep not doing that
>Do you like the way the Dash Scale looks?  If not, change the Dash Scale... and memorize it; or create a Property Values Preset named "Wiring: Scale= ¼"=1' ", or something like that.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* April 04, 2014, 05:14:06 PM
#9
Yes, one is Hidden and the other is Dashed, I guess as you said, I seem to be getting mixed up, hidden on some lines and dashed on the others, I'll fix that, I guess dashed is what I want.

I've always liked "Hidden".  It's been so long ago that I made that decision, I don't remember what led me to that preference.  But I do remember years ago having a strong preference for "Hidden" over "Dashed".

Like I wrote previously, if look at them both via "Modify" in the Lines Style Editor (under "Options" or "Tools"), you can see the difference between how "Dashed" and "Hidden" Dash Patterns are created.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* April 04, 2014, 05:18:02 PM
#10
Thanks for that, that helps, right now I switched all of them to dashed, yes 1/4, so I'll study your advice, thanks,

Getting late over hear in Putnam County,

Talk to you later.

Logged


* April 04, 2014, 05:29:11 PM
#11
At the moment I am drawing the switch leads to each light fixture it controls with dashed lines. I don't really make electrical plans like on commercial, but the electrician needs to see locations of devices and switch paths. But every line I make seems to have a mind of it's own, could be I am selecting two different types, there are two that look the same but are different. I usually get it figured out before I print, but I was hoping for an easier way than trial and error.

Attached is a TurboCAD (version-19) file that has nothing in it other than a Bezier Curve with the Properties I use for electrical-wiring.

I put it on the 0-Layer so that you can Copy & Paste it into your drawing.

I also created a Property Values Preset in the Curves Tools for this electrical-wiring symbol.  It too is currently on the 0-Layer.

If you Copy & Paste it into your Drawing, then place it on your correct Layer, you can use Format Painter to "paint" the Properties onto another 2D entity (even if it is one you create just for this use), you can elect in Format Painters Local Menu to "Make property values preset...".
Alternatively, you can use the File/Extract From to extract the Property Values Preset from my Drawing.
You just have to remember to change the Layer after activating the Tool and the Property Value Preset, but before drawing the 2D entity.

___
Note:  This is the Dash Pattern ("Hidden") and Dash Scale I would use for ¼"=1', which is what I have this Drawing's Modelspace Space Units Scale set to (remember... that can be changed at anytime without causing any harm; it only effects at what Scale any printing from Modelspace will be done at).

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* April 04, 2014, 06:01:02 PM
#12
Difference between Dashed Pen Dash Pattern and Hidden Pen Dashed Pattern:

Reference the attached screen-capture of my TC-Explorer Palette/Line Styles.
I haven't added or changed any of the Line Styles; these are the TurboCAD-provided defaults.

Note that the "Dashed" Line Style has values of 2,.5,-.25
  • The first "cell" (that's what I will call each value between each of the commas) is 2.  That means that there are 2 values in the Line Style.  Two elements that will go into making the pattern of the Line Style.
  • The next cell is .5;  That means that the Line will be .5 Units long.
  • The next cell is -.25; the minus-sign-- or negative-symbol-- tells us that this will be a space.  How long?... .25 long.
  • Because the first cell was 2, we know this Line Style is "over"... it just repeats those values-- those pattern elements.
Now compare that-- with your new understanding of how Line Styles works... are "created"-- with the "Hidden" Line Style lower down in the table in the screen-capture.  See how the "Hidden" Line Style will have a Line that is .25 Units long, followed by a space that is .125 Units long; Repeat.

When we set our Dash Scale to 1 and our Pen Width Scaling to "World" or "Device Width", the Dash Pattern fully reflects the values assigned to the Line Style in the "Line Styles Editor", at a 1:1 scaling.  Tick "Geometry", and we can actually measure-- using a Dimension Tool-- to verify this.

Given that the "Dashed" Line Style and the "Hidden" Line Style both have only two elements-- a line followed by a space-- and in both Line Styles, the space is half the length of the line, with the correct Dash Scale assigned in Objects' Pen Properties, "Dashed" and "Hidden" would essentially be drawn the same.  As long as the Dash Scale we assign to the "Dashed" pattern is half of what we assign to the "Hidden" pattern (because the values in the "Dashed"-pattern Line Style are one-half the values of those in the "Hidden"-pattern Line Style).


I hope that at least takes some of the mystery out of what controls these Dash Patterns and how they are based on your Drawings Units, and not just some arbitrary, random, patterns.

Or... I may have just confused you and/or gave you some unnecessary, non-useful information.  I hope not.
« Last Edit: April 04, 2014, 06:08:00 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* April 04, 2014, 10:29:11 PM
#13
re: …I tried that, but "alignment" is greyed out.…

I see that "Alignment" isn't available for Curves, just Lines & Arcs. I like having it on, as it does smooth out the pattern; kinda like justified text.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


* April 05, 2014, 06:43:39 AM
#14
To try to illustrate what I was "talking" about in Reply #6, regarding how checking "Alignment" in an Object's Pen Properties Dash settings may result in a space in the Dash Pattern-- rather than a line of the Dash pattern-- occurring at the "corners" of an entity, I created the image below.

The image also attempts to illustrate what I was describing in my Reply #13, regarding the "Dashed" Dash Pattern being basically the same as the "Hidden" Dash Pattern, just that "Dashed" has a Line and a Space that are twice as long as that in "Hidden".
Note that the value in the Dash Scale for "Dashed" is set to 1; and the value in the Dash Scale for "Hidden" is set to 2.
   Also note that with "Alignment" checked, the dash pattern at the corners do not stay uniform.  TurboCAD adds a bit of line to fill in the corners, causing the dash pattern to not have a uniform appearance.
« Last Edit: April 05, 2014, 06:51:15 AM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* April 05, 2014, 07:09:40 AM
#15
Still the question, where are ya'll starting this procedure, from an idle screen with no tools selected ? My alignment is greyed out.

Logged


* April 05, 2014, 08:23:04 AM
#16
Still the question, where are ya'll starting this procedure, from an idle screen with no tools selected ? My alignment is greyed out.

In a Tool's Properties/Pen page.

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* April 05, 2014, 02:17:14 PM
#17
re: …where are ya'll starting this procedure…

Select any Line tool, Double Line tool, Circle tool or Arc tool, then go to the Pen page. "Alignment" should be a viable option, even though "Dash Scale" may not (if Continuous is selected).

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


* April 05, 2014, 04:13:12 PM
#18
Still the question, where are ya'll starting this procedure, from an idle screen with no tools selected ? My alignment is greyed out.

Ivey, I'm not so sure that Alignment becomes available for Curves.

Circles, Ellipses,... anything in the "Circles" Toolbar, yes.
Anything in the Arcs Toolbar... yes, as well.
But anything in the "Curves" Toolbar-- Bezier, Spline, etc.-- I don't think Alignment is available.

So, in your case, if you are using the Spline Curve, or Bezier Curve to draw-- in 2D-- wiring from switches to lights, I don't think the Alignment option is available.

Makes sense to me that this would be the case.
« Last Edit: April 05, 2014, 04:19:32 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)