TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Auto update TC Pro 20 32-bit
Read 6225 times
October 15, 2013, 08:50:21 PM
Hi,
I just tried to install the auto-update 20.2.51.3 for TC Pro 20 32-bit on Windows 7 via the pop-up window.
This process asks for you to insert the DVD installation disk, which I did.  I got an error - see image attached (can't copy and paste the text in the error box).
It then aborts the installation process
I haven't had this problem with the disk in previous updates.
Any ideas as to the problem or a workaround?
thanks.

Logged
Using Turbocad Professional V19 64 bit on Windows 7 64bit
Sony Vaio VPCSB 8gb ram Intel Core i5 2.4 Ghz

James Stephenson Architect
Brisbane, Qld, Australia


* October 15, 2013, 10:26:29 PM
#1
Temporarily turn off your AntiVirus software, then run the update (with DVD loaded). Maybe that will make a difference. Turn on the AV when done.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


October 15, 2013, 10:48:43 PM
#2
Thanks for tip. 
My DVD drive is in a PC in the local office network, not the machine on which TC is installed. 
I have Microsoft Security Essentials for antivirus, and after turning it off on both PCs the update still didn't work.
Previously using a network DVD drive has worked for installs and updates, but not this time.  Whether having to find the original DVD via the network is the issue or not I cannot tell.

Logged
Using Turbocad Professional V19 64 bit on Windows 7 64bit
Sony Vaio VPCSB 8gb ram Intel Core i5 2.4 Ghz

James Stephenson Architect
Brisbane, Qld, Australia


October 15, 2013, 10:55:11 PM
#3
So I will try copy the TurboCADProfessional20.msi file to the hard drive and point the install routine to that location.

Logged
Using Turbocad Professional V19 64 bit on Windows 7 64bit
Sony Vaio VPCSB 8gb ram Intel Core i5 2.4 Ghz

James Stephenson Architect
Brisbane, Qld, Australia


October 15, 2013, 11:00:19 PM
#4
Somehow, the Data1.cab file is reading as corrupt to the install routine.  Don't know how it could have become corrupt.  The disk is clean and the file copied to the hard drive of the PC with TC installed on it OK.  Unless the install software has a bug?
Oh well, I might wait till the dust settles on this one.

Logged
Using Turbocad Professional V19 64 bit on Windows 7 64bit
Sony Vaio VPCSB 8gb ram Intel Core i5 2.4 Ghz

James Stephenson Architect
Brisbane, Qld, Australia


* October 15, 2013, 11:09:02 PM
#5
Try the people at Support. I'm sure they've seen this problem before.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


October 15, 2013, 11:34:05 PM
#6
Yes - I will try them - thanks John

Logged
Using Turbocad Professional V19 64 bit on Windows 7 64bit
Sony Vaio VPCSB 8gb ram Intel Core i5 2.4 Ghz

James Stephenson Architect
Brisbane, Qld, Australia


* October 16, 2013, 01:40:36 AM
#7
I had the same problem. I downloaded from Forum "Updates and Patches" once more latest patch "19.3 and 27.4 to 20.1.32.4" for my 64 bit Win 7 (before the patch had been installed and everything was OK) and then easily installed TCPro 20.2. Of course, I can not explain it but it worked. You can at your own risk to try this. After installing patch you lose your UI, so if you want to restore you have to save them.
Marek

Logged
Marek

TC Pro 2016, TC Pro 2018, TC Plat 2019
Laptop Asus i7 6500U, dual-core 2,50GHz, NVIDIA GeForce GTX 950M, RAM 12 GB, SSD 480GB
Windows 10 64 bit


October 16, 2013, 03:36:12 AM
#8
OK, I lodge a ticket with IMSI support, but will try your solution Marek if I don't hear from them beforehand.
James

Logged
Using Turbocad Professional V19 64 bit on Windows 7 64bit
Sony Vaio VPCSB 8gb ram Intel Core i5 2.4 Ghz

James Stephenson Architect
Brisbane, Qld, Australia


* October 16, 2013, 03:47:21 AM
#9
The same pb for me, but I did not yet reinstall the old versions (which I still have on my HD)

Hoping that IMSI will come fast with a solution for helping to using their upgrade.

Leo

Logged


* October 16, 2013, 07:47:54 AM
#10
I amhaving the same problem with 64 bit. I wonder if Rip could post a direct link to a download of the update/full version?

Logged
Windows 8 64 bit
TurboCAD 19.2 build 54.2
HP Pavillion g6
AMD Quad core graphics


October 16, 2013, 01:10:49 PM
#11


October 16, 2013, 01:13:47 PM
#12
It is a pretty common problem with windows installer and has to do with the installer reading the signature database.  We are researching to see if there is anything we can do on our end. 

Logged
Rip Fowler
IMSIDesign LLC


* October 16, 2013, 03:28:34 PM
#13
Thanks Rip, that worked flawlessly.

There is a notable, and welcome, increase in speed. Is there a list of improvements and fixes?

Logged
Windows 8 64 bit
TurboCAD 19.2 build 54.2
HP Pavillion g6
AMD Quad core graphics


* October 17, 2013, 12:21:47 AM
#14
Hi Rip

to the new complete installation file my windows 7 was saying :
 
<< another version of this product is already installed. The installation of this version can not be continued. Use Control Panel "Programs and Features" to configure or to remove the installed version of this product.>>

I was asking whether I should deinstall the previous version , but when I start my work you are starting to sleep (Europe !!!)

Finally, I have let my windows 7 repair the previous install, I guess it updated / corrected this famous database and I could install the update, works fine ...

Thanks a lot all over there:

lEO

« Last Edit: October 17, 2013, 02:17:37 AM by Leo67201 »

Logged


* October 18, 2013, 12:23:47 PM
#15
re: …Is there a list of improvements and fixes?

It can be found here: TurboCAD v20.2 Improvements and Fixes

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


October 30, 2013, 10:08:17 PM
#16
Thanks for assistance, I ended up using the download link provided by Rip Fowler and problem was solved!

Logged
Using Turbocad Professional V19 64 bit on Windows 7 64bit
Sony Vaio VPCSB 8gb ram Intel Core i5 2.4 Ghz

James Stephenson Architect
Brisbane, Qld, Australia