TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Version 11.2: "Z"-Coordinate Keeps Unintenionally Locking
Read 2734 times
* February 20, 2013, 12:13:50 PM
Hello Everyone.

I don't do much 3D work, but I am doing a Pergola, Patio, & Trellis in 3D (after having completed the working-drawings in 2D).  Anyway, I have two annoying issues that always bug me, but I thought I'd get the remedy from you experts today.  I'll post one here, and the other on another Topic Thread.

----
When working in 3D, my "Z"- Coordinate just keeps locking inadvertently/unintentionally.  Any idea what causes that?  And how I can avoid it?  I don't have any Keyboard Shortcuts assigned to Lock "ModeLockZPosition" that I might inadvertently be hitting.

Thanks, Alvin

« Last Edit: February 20, 2013, 12:21:35 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* February 20, 2013, 01:50:12 PM
#1
Hitting the "Z" key can lock the "Z" coordinate field.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10 Pro, 64-bit


* February 20, 2013, 02:00:36 PM
#2
Hitting the "Z" key can lock the "Z" coordinate field.

Hi John.  Thanks for the Reply.  I have the "Z" key assigned to ZoomInByCursor, on my Laptop (which I am using now).  Have for a couple of years.  Now that I think of it, I think I've been having that inadvertent ModeLockZPosition for years as well.

But, even if that Keyboard Shortcut doesn't show up in my Tools|Customize|Keyboard shortcuts, does hitting the "Z" key still lock the "Z" coordinate field?

Thanks, Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* February 20, 2013, 02:08:01 PM
#3
Hitting the "Z" key can lock the "Z" coordinate field.

Scratch...scratch...scratch.  (That's me scratching my head.)  Just went back to my 3D drawing, and tapped the Z key a bunch of times, but the Z coordinate field didn't lock.  Can you elaborate some John on why that is, and how it's supposed to work.  Does it have something to do with my 3D Selector settings?

Thanks, Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* February 20, 2013, 02:18:00 PM
#4
Check in Keyboard, Modes category to see if it's assigned.

If the "Z" hotkey is set, you need to have a 3D tool active for it to lock.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10 Pro, 64-bit


* February 20, 2013, 02:25:20 PM
#5
Check in Keyboard, Modes category to see if it's assigned.

If the "Z" hotkey is set, you need to have a 3D tool active for it to lock.

No, I just checked my Keyboard assigments (under Help|Keyboard).  Neither my "Lock X", nor my "Lock Z" are in that list.  However, my Custom Keyboard settings are, so that tells me that list is updating correctly.

Also, I tried activating the 3D Box Tool, snapped X and Y, then just started tapping the Z key- Z coordinate didn't lock.

I'll try to keep a better eye on it while I doing this drawing, and try to identify what actions are causing the Z coordinates to lock.  If I see something I can't figure out, I'll Post back.

Thanks, John-  Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* February 20, 2013, 02:31:47 PM
#6
I hope you figure it out.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10 Pro, 64-bit


* February 22, 2013, 11:07:01 AM
#7
I never did get this figured out.  I've been drawing too fast, my actions are too fast, that when I notice the "Z" is locked, I can't ascertain what action- or combination of actions- caused it.  I tried slowing down- and looking at the "Z" coordinate to see if it was locked- after every action, but I can go through a whole lot of actions before it actually happens, that method didn't prove to be very productive.

I'd still be interested if anyone has input and advice as to the cause and the remedy for this inadvertent/unintentional occasional "Z"-locking.

Thanks, Alvin

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)