TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Line thickness in PDF's
Read 24518 times
* January 05, 2013, 10:35:12 AM
Is there a way to decrease line thickness so that the pdf's printed lines show thinner?

I have my line widths in properties set to zero and they show AOK in paperspace, but the printed lines in PDF files are a bit too thick for my purposes.

Logged


January 05, 2013, 10:48:56 AM
#1
If you are not already, you could use and free PDF printer tool like CutePDF.

All you do is click print and select CutePDF which will be one of your "printers" it will then ask for your filename and folder location etc.

Link to the free download - http://www.cutepdf.com/Products/CutePDF/writer.asp

Works for me and others that use it  :)

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* January 05, 2013, 11:17:13 AM
#2
Thanks I'll check it out!

I am however able to print PDF's fine with Deluxe and Pro, but is there a way to reduce the printed line thickness without using Cute?  Or is there a setting in Cute for PDF line thickness that is not either in TC or Acrobat distiller (I am using the pro version of Acro by the way)?

Logged


January 05, 2013, 12:37:48 PM
#3
What is your line thickness in model space?

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


January 05, 2013, 12:52:28 PM
#4
I use Primo pdf.
This works fine too.
Generally I set 0.5mm to drawing lines and 0.0mm to dimension lines.
« Last Edit: January 05, 2013, 12:56:02 PM by Dave C »

Logged
Dave C
TC Pro V14.2 - TC 21 Platinum 64 Bit Build 22.3
Intel i-4770K 3.5GHz
120GB ssd 2TB hd
16GB memory
64bit Windows 7 Pro

www.ipernity.com/fizzyfitz


* January 05, 2013, 01:08:08 PM
#5
What is your line thickness in model space?

Zero.

Logged


* January 05, 2013, 01:21:23 PM
#6
I also tried .01 and .001 in both model and paperspace.  .01 made the lines thicker, and .001 did not make much difference.

The pdf looks fine when you zoom in, lines are not bad, but at full page view in the pdf's screw threads and lines close together kind of blend together and it's hard to tell they are threads at full page view.

Logged


January 05, 2013, 01:34:16 PM
#7
Does your Properties/Pen match this below?

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* January 05, 2013, 06:09:43 PM
#8
The only difference I can see is that i have color set either white or black not by layer...

I selected one part of drawing and changed it by layer, and it made no difference...
« Last Edit: January 05, 2013, 06:15:20 PM by nadsab »

Logged


January 05, 2013, 06:47:43 PM
#9
Just googled your issue and it could be down to the program you are viewing the PDF in..

Try printing in out to see if it is just a limitation on screen.

"If the lines are really too thick - as shown by zoom,
where the linewidth grows proportionally - then the
information is already in the PDF. Perhaps by applying
'Fix Hairlines' in AcrobatPro.
In Acrobat use
Edit > Preferences > Page Display > SmoothLineArt=Off
The line is shown for all zoom factors by one-pixel
rendering.
For SmoothLineArt=On, the line looks considerably thicker,
but the visual linewidth is still independent of the zoom
factor."

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* January 05, 2013, 07:12:36 PM
#10
Thanks.  I am using Acrobat Pro Version 9 - found "Smooth Line Art" - it is checked, but it is grayed out, I can't un check it.

I also could not find "Fix Hairlines" in preferences.  I searched for "hairline" in acrobat help but nothing came up...
« Last Edit: January 05, 2013, 07:21:05 PM by nadsab »

Logged


January 05, 2013, 07:19:12 PM
#11
Have you tried a print out from Acrobat?

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


January 05, 2013, 07:22:01 PM
#12
See this - http://forums.adobe.com/thread/583219

how to disable "Use 2D graphics acceleration" in the registry?

Actually, I just found it:
 
[HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\9.0\AVDisplay]
"bUse2DGPUf"=dword:00000000

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* January 05, 2013, 07:22:35 PM
#13
Have you tried a print out from Acrobat?

Unfortunately I don't have a printer.  At any rate, the document i am creating is for monitor use only, so even if I can get it to print OK I don't think it would help me.  I could take a few prints to Kinkos tomorrow to see how it comes out though...

Logged


* January 05, 2013, 07:26:11 PM
#14
See this - http://forums.adobe.com/thread/583219

how to disable "Use 2D graphics acceleration" in the registry?

Actually, I just found it:
 
[HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\9.0\AVDisplay]
"bUse2DGPUf"=dword:00000000


I un checked "use 2d Graphics Acceleration" - that is not grayed out, but it did not make a difference.

Logged


January 05, 2013, 07:31:19 PM
#15
use Fix Hairlines with a sufficiently large
minimal linewidth, for instance 0.3 mm.?

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* January 05, 2013, 07:36:21 PM
#16
Actually I was able to uncheck "Smooth Line Art" - I changed some settings don't know how it came back on. anyway I unchecked it and the drawing came out worse - more grainy.

Logged


* January 05, 2013, 07:37:01 PM
#17
use Fix Hairlines with a sufficiently large
minimal linewidth, for instance 0.3 mm.?

Where are you finding "Fix hairlines"?  I can't find it in preferences...

Logged


January 05, 2013, 07:38:43 PM
#18
"Fix Hairlines" option is in the "Print Production" menu.

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


January 05, 2013, 07:42:11 PM
#19
Also to see if it is a paperspace problem in TC please trail a PDF from model space....

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* January 05, 2013, 07:44:48 PM
#20
"Fix Hairlines" option is in the "Print Production" menu.

In Acrobat?  Could not find it - is it a sub menu?  Or is it in Turbocad?

Logged


January 05, 2013, 07:50:43 PM
#21
Yeah, supposed to be in Acrobat.

I have just done three tests:

1. Model Space using Save As Pdf
2. Paper Space using Save As Pdf
3. Paper Space using CutePdf printer driver/creator

All lines look okay and identical to me
« Last Edit: January 05, 2013, 07:56:22 PM by Darrel Carl Durose »

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


January 05, 2013, 07:55:55 PM
#22
Also check you TC

Options/Drawing Setup as a long shot.

Mine is set like this image below:

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* January 05, 2013, 08:03:50 PM
#23
OK found fix hairlines.  What settings do you reccomend?

Logged


January 05, 2013, 08:08:25 PM
#24
they mention .25pt

One thing I should of asked are you using hidden line draw?

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* January 05, 2013, 08:28:05 PM
#25
Not sure - how would I check that?  Properties?

Logged


January 05, 2013, 08:35:32 PM
#26
yes, properties. If you are using either native hidden line or redsdk these will be raster images. Standard wireframe is vector which dont suffer from pixelization.This may not be applicable as i have just realised you are using deluxe which does not have Redsdk render modes i don't think.
« Last Edit: January 05, 2013, 08:51:12 PM by Darrel Carl Durose »

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


January 05, 2013, 08:52:27 PM
#27
can you post the tcw an pdf file?

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* January 05, 2013, 10:19:51 PM
#28
yes, properties. If you are using either native hidden line or redsdk these will be raster images. Standard wireframe is vector which dont suffer from pixelization.This may not be applicable as i have just realised you are using deluxe which does not have Redsdk render modes i don't think.

Hi,,

Acually I have Deluxe but I am trying out Pro trial version for another week.  I will have to go back to Deluxe next week.  I'll tinker around with this more tomorrow am thanks for all the advice maybe I can get this figured out tomorrow will post back later.

Logged


* January 06, 2013, 11:17:54 AM
#29
I'm using version 9 of the free Adobe Acrobat reader and if you uncheck the "Line Weights" option under the "View" menu the lines will be thin.

PS. I have no idea why it's showing three of the same image.
« Last Edit: January 06, 2013, 11:20:17 AM by rt1024 »

Logged


January 06, 2013, 11:21:29 AM
#30
rt1024

He says he is using Acrobat Pro which should have more options....Not sure he has already tried this?.....was a last night/early morning posting on this one  ???

Logged
Daz...
V2018 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows10 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* January 07, 2013, 09:28:18 AM
#31
I'm using version 9 of the free Adobe Acrobat reader and if you uncheck the "Line Weights" option under the "View" menu the lines will be thin.

PS. I have no idea why it's showing three of the same image.

Finally getting back to this LOL

Yeah that's the first thing I tried last week, unchecking line weights did not make a difference for me.  I an wondering, for the threads that show solid black at full page view - Some of them I did with a 1/64 and some with a 1/32" pitch.  I am wondering if printing to pdf just is not capable of showing 1/64 and 1/32 pitch threads in full page view?  I'm using portrait 8.5 x 11 in drawing setup

Also is there a way to globally set line thickness for a drawing?  I know when I click on a part in a drawing I can bring up the properties up for that part of the drawing and set line thickness for that part of the drawing, but where would I set line thickhess for an entire drawing - is that possible?

So in TC itself, are all the options that have anything to do with setting line thickness in paperspace (for on screen viewing & PDF printing) are accessed by

1.)  Properties/Pen (by left clicking on the object)
2.)  Drawing Setup/Display
3.)  File>Page Setup>Rendering
4.)  Print
5.)  Print>Properties>Layout>Advanced (for PDF)
6.)  Options>Drawing Setup

Have I missed anything?


Logged


* April 20, 2015, 12:11:14 PM
#32
I am re visiting this after two years.   Anyone have any ideas - particularly in regard to my previous post Jan 7 2013?
« Last Edit: April 21, 2015, 08:46:14 AM by nadsab »

Logged


* February 03, 2017, 11:03:44 AM
#33
Hi,
Just came across your question. In case you haven't already found the answer, you could check out Options>>Drawing setup. Here you get a field called "device pen width when zero value is used". Change the values here and experiment.


Logged