TurboCAD Forums

Turbo Talk => Problems => Topic started by: Sully on June 22, 2018, 10:18:57 AM

Title: TC Deluxe graphics problems
Post by: Sully on June 22, 2018, 10:18:57 AM
Hi all,
 
I’m brand new to TurboCad and am teaching myself CAD for a personal project I’m working on. I just purchased TurboCad 2018 Deluxe (64 bit) and find the graphics performance to be really poor when working in 3D.
 
I have a Lenovo Y70 laptop computer (about 3 years old) with:

It’s not the meatiest machine on the block but it should have more than enough muscle to rotate 3D objects.
 
When I use TC I have noticed a number of problems:

My version does not have the RedSDK option, but still it seems like something is wrong. My machine also has an on-board Intel graphics card and I’m wondering if TC is using that and not the NVIDIA.
 
Thanks in advance for any help.
 
-Sully
Title: Re: TC Deluxe graphics problems
Post by: Dean on June 22, 2018, 04:13:34 PM
Sully,
You should have good 3D navigation in a shaded view if all the "foreground wireframe" settings are unchecked. (see attached)
Use a LightWorks Draft smooth opengl render.
When you start a render there's usually a warning that pops up telling you that 'foreground wireframe" is checked.
If you want "Lines' to be visible it's best to avoid 3d navigating in a shaded view.

Also,  "flicker free draw" should be checked in options > Native draw
Title: Re: TC Deluxe graphics problems
Post by: Sully on June 23, 2018, 05:23:57 PM
Thanks Dean. Unfortunately I had to reset my Windows installation and now TC won't install. I'll return to this once I get it running.  -Sully
Title: Re: TC Deluxe graphics problems
Post by: Sully on June 24, 2018, 11:16:31 AM
Ok, I got the 32 bit version installed (no luck with 64-bit) and the suggested changes seem to help. Hidden lines and draft mode are much more responsive now. Quality rendering is still slow, but I don't need that for now.

Thanks again.

-Sully