TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Bug TC2016-2018 PP
Read 432 times
* May 14, 2018, 10:40:22 AM
Hello,
I use TC 2016PP and TC 2017PP.
I found a bug in this versions of TC.
There are 2 PPM parts. If I use drafting, the cut is not in the right way (see attachment).
I think this is a bug in these versions.
I have a testversion from TC2018PP.
The bug is the same.
Regards

Logged
Turbocad 19 Platinum
Turbocad 2016 Platinum
Turbocad 2017 Platinum


May 14, 2018, 10:27:48 PM
#1
If you have ACIS History ON (the installation default), then you could try selecting the object and using the Explode command to simplify it to an ACIS object before creating the Draft View. Use the Selection Info palette to see what you have.

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* May 14, 2018, 11:47:30 PM
#2
Does it happen with every instance of two PPM parts, or is it only these two?  Are the two parts located parametrically in creation, or after the event?   Is it reproducible with new files?       

Logged


* May 15, 2018, 02:04:26 AM
#3
Can you upload the ppm or at least a drawing with the ppm inserted

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* May 15, 2018, 05:08:46 AM
#4
How are you creating the parametric parts?
With scripts or constraints?
Angles can be temperamental when using constraints?

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* May 15, 2018, 11:51:16 AM
#5
Hello,

these parts are not constrains.
It is right, if I use the command explode, then the view is right.
But this can't be the solution.
Because if I have to change the part in the future, the part is only a acis and cannot be changed with the parameter.
In the attachment, there are the drawing and in the zip file, there are the macros.

regards
Carsten

Logged
Turbocad 19 Platinum
Turbocad 2016 Platinum
Turbocad 2017 Platinum


* May 15, 2018, 04:48:48 PM
#6
I take a quick look at your ppm files and believe you miss a Mainfile to collect the part to a symbol, as the Parameters should not be active in the same file that make the symbol and put it out,( together with the "Input")

There are 2 parameters with the same name (N1), and N3z want to use a value from N3, only there is no N3, but it seems like N3z is not in use so ….

The gap in Draft is heigth of Pipe/ 2 + Heigth of Flange/ 2 so maybe an refPoint issue as TC lift it half the distance of total heigth when they stand on top of each other.
Maybe the Flange should have been lifted to the top of the pipe when inserted, then it will already be in correct position when Drafting update and make the Draft Object ??
And if you update the ppm it will go to its original position and you will need to move it again if there is not a "lift" value in it

Attach a pic of a house ppm where i use the draft on it and there is no parts that are moving there, but if i copy it and set them on top of each other and then make a Draft there will be a gap for about 2 meter or so in Front View, but no problem in Left view ?? :)
So something "funny"is going on here

Torfinn
Edit:
Just added a new pic and report it as a bug
« Last Edit: May 16, 2018, 12:48:53 AM by Torfinn »

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB