TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

toggling from 2d to 3d in TC 20.2 Deluxe
Read 100 times
* December 06, 2017, 02:50:11 PM
If I select an object & move it, I get this window that pops up.

"Editing the selected 2D object in the 3D mode changes the object's WorkPlane.
To set the WorkPlane, use the 'Place on WorkPlane' option from the Modify menu"

When I look for "Place on a WorkPlane", it's not in the modify menu, but it's in the format menu.

Am I missing something?

I've tried using the Format menu's "Place on a WorkPlane", but it doesn't work apparently.

Logged


* December 06, 2017, 05:34:04 PM
#1
If I select an object & move it, I get this window that pops up.

"Editing the selected 2D object in the 3D mode changes the object's WorkPlane.
To set the WorkPlane, use the 'Place on WorkPlane' option from the Modify menu"

When I look for "Place on a WorkPlane", it's not in the modify menu, but it's in the format menu.

Am I missing something?

I've tried using the Format menu's "Place on a WorkPlane", but it doesn't work apparently.

What makes you think the "Place on [a] Workplane" Command isn't working?

Why are you toggling the Selector mode from 2D to 3D?

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* December 07, 2017, 01:31:31 AM
#2
After selecting object's, then set the worplane where you want it, and after that again, Place on Workplane, do it in this order and it will work.
In the time where your version is from they moved the tool's all over the Place( menu's) for every version, now they seems to be on the same place       basically.
The txt is just simply from an maybe older version and not follow your version, and also in TC there are a great deal of freedom to set up the UI after your own preferences, the mainthing is that you have found it and know where it is.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* December 07, 2017, 02:02:56 PM
#3
Sorry, I'm not understanding your reply's.

When I open a new Turbo cad file, I only have X & Y coordinates.  I right click on the drawing & there's a toggle 2D/3D option, so I can manipulate everything with the Z access.  Does that help?

I already have a work plane set when I start my drawing, so I don't know why I would need to set a work plane?

Logged


* December 07, 2017, 03:34:15 PM
#4
If the drawing only show x and y when open a new drawing, it only tell that you are now in 2D mode, but the way you explaine it, the workplane it is not on the same workplane like the objects you try to move, whatever that workplane migth be, so then you can use worplane by entety and select that object, and then moving the object, and there will be no warnings.
Because like it is now, everything is not on the same workplane, 2D or not 2D

Maybe you should attach/ upload an example, then it is more likely sombody will tell you  what causes your issue.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* December 07, 2017, 05:35:58 PM
#5
TurboCAD will do this (it was developed this way on purpose-- presumably with purpose):

When selecting with the Selector Tool a previously drawn 2D Object while the Selector Tool is in "3D mode", and moving and/or rotating that 2D Object, TurboCAD will change that 2D Object's "internal"-- "inherent"-- Workplane (Coordinate System) to reflect the move and/or rotation.

This can be benign, unfavorable, or useful, depending on the User's knowledge or intention.

Some Forum members might suggest simply ticking "Don't show this message again"; but that's usually the more experienced Users.  My suggestion is to keep the Warning Dialog as showing, but learn how and why this behavior occurs; an unknowing User can run into hair-pulling troubles and frustrations if they ignore the Warning Dialog and simply tick "Don't show this message again", and continue on with a complex drawing.
« Last Edit: December 07, 2017, 06:04:32 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)