TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Can't start TC16 Deluxe
Read 12954 times
* November 19, 2009, 02:48:57 PM
Just installed TC16 Delux on new computer (Acer X3812,  Pentium Dual Core, 3GB RAM) running Windows 7 Home Premium, and it crashes every time I try to open a new drawing.  DEP is set as recommended in forum.  Patched to 16.2, no difference.  Any ideas please? Here's a snippet from the error log:

System:  Unknown version of Windows based on NT, version 6.1.7600
Reason:
Tcw16.exe caused an EXCEPTION_ACCESS_VIOLATION in module DBAPI16.dll at 0023:060FC284, DrawingGetStyleProperty()+0404 byte(s)

Logged


* November 19, 2009, 03:36:57 PM
#1
What happens if you run the .exe startup file in compatibility mode with XP or Vista?

Logged


* November 19, 2009, 05:48:11 PM
#2
Your lucky I can't even get the CD to read. Neither of my CD-Rom drives will read the CD. Any one have any suggestions? I have made sure the CD is clean. Both drives will read other CD's when loaded, just not the TurboCAD 16 deluxe.

Logged


* November 19, 2009, 08:12:26 PM
#3
Have you tried another machine?I don't know what it is but this file gave problems in Vista and Xp machines(DBAPI16.dll) with Version 14.If the disc is corrupt or damage send to IMSI for elevation and or replacement.Worse case scenario it may not run on that machine.Next thing is do a clean install which requires a third party application.And digging in the registry and clean out any remnant of TC.Best thing is to do get touch with Rip and let him access the situation.It might need a patch also I think there up to 16.2.
« Last Edit: April 18, 2011, 05:32:03 AM by wd »

Logged
Even a mistake may turn out to be the one thing necessary to a worthwhile achievement Henry Ford
If I have ever made any valuable discoveries it has been owing more to patient attention than to any other talent Isaac Newton
I have not failed Ive just found 10,000 ways that won't work Thomas Edison


* November 22, 2009, 04:20:04 AM
#4
TC16 deluxe crashes when trying to open drawings on my Win 7 machine, as stated before.  Trying XP compatibility mode makes no difference.  It used to work on my old laptop, but no longer starts on that, which is why I'm trying my new Win 7 machine.  The software was downloaded from Imsi's site, not run from CD.  Any ideas?

Logged


* November 22, 2009, 08:49:18 AM
#5
The software was downloaded from Imsi's site, not run from CD.  Any ideas?

I had the same issue with Ver.15.And that was from the trial version.Perhaps request for disc there may be a small cost involved .I given up on there downloads from there site.I just buy out right from another cad dealer at reduce cost.If you explore the web there are cheaper prices than buying from Digital River.All along it may burp up a file some where in the down load process.

Logged
Even a mistake may turn out to be the one thing necessary to a worthwhile achievement Henry Ford
If I have ever made any valuable discoveries it has been owing more to patient attention than to any other talent Isaac Newton
I have not failed Ive just found 10,000 ways that won't work Thomas Edison


November 23, 2009, 03:55:50 PM
#6
Your lucky I can't even get the CD to read. Neither of my CD-Rom drives will read the CD. Any one have any suggestions? I have made sure the CD is clean. Both drives will read other CD's when loaded, just not the TurboCAD 16 deluxe.

Its on DVD send me an e-mail and we should be able to straighten this out.

Logged
Rip Fowler
IMSIDesign LLC


November 23, 2009, 03:58:57 PM
#7
TC16 deluxe crashes when trying to open drawings on my Win 7 machine, as stated before.  Trying XP compatibility mode makes no difference.  It used to work on my old laptop, but no longer starts on that, which is why I'm trying my new Win 7 machine.  The software was downloaded from Imsi's site, not run from CD.  Any ideas?

Sound like this is happening with new files as well as old ones. I have run all of microsofts windows 7 compatibility tests and TC has passed all of them, that said there are OEM versions of windows 7 and many hardware configurations that could potentially cause problems. 

Try right clicking the TC icon on the desktop and choose run as administrator.

Logged
Rip Fowler
IMSIDesign LLC


* November 24, 2009, 05:25:43 PM
#8
Try turning UAC off. I had this problem in Vista the first time I tried to use TC 15. After that, it didn't matter whether UAC was on or off.

Logged


* December 02, 2009, 03:17:52 PM
#9
Just installed TC16 Delux on new computer (Acer X3812,  Pentium Dual Core, 3GB RAM) running Windows 7 Home Premium, and it crashes every time I try to open a new drawing.  DEP is set as recommended in forum.  Patched to 16.2, no difference.  Any ideas please? Here's a snippet from the error log:

System:  Unknown version of Windows based on NT, version 6.1.7600
Reason:
Tcw16.exe caused an EXCEPTION_ACCESS_VIOLATION in module DBAPI16.dll at 0023:060FC284, DrawingGetStyleProperty()+0404 byte(s)


I am having the same problem. I am trying to run TurboCAD Deluxe 16.2 on Windows XP. I was running 16 essentially trouble free for about 10 days and then it started having the ACCESS_VIOLATION problems. I then upgraded to 16.2. Now I can't open any file nor start a new drawing. For what it is worth, it seemed like there was a brief period where I could get something open a drawing and get something done before TC crashed. That quickly became less and less until I can no longer do anything. This is what I think are the relevent portions of the crash details:
Code: [Select]
System:  Windows XP, version 5.1.2600 Service Pack 3
Reason:
Tcw16.exe caused an EXCEPTION_ACCESS_VIOLATION in module DBAPI16.dll at 001B:060FC284, DrawingGetStyleProperty()+0404 byte(s)

Registers:
EAX=00129A8C  EBX=00000000  ECX=00000000  EDX=00129A8C  ESI=00000000
EDI=02B93050  EBP=00129A48  ESP=001299E4  EIP=060FC284  FLG=00210246
CS=001B   DS=0023  SS=0023  ES=0023   FS=003B  GS=0000

Stack:
001B:060FC284 DBAPI16.dll, DrawingGetStyleProperty()+0404 byte(s)
001B:0334B234 TCTable.dll, TCTABLERequest()+31844 byte(s)
001B:033486DB TCTable.dll, TCTABLERequest()+20747 byte(s)
001B:060E71DB DBAPI16.dll, RegenMethodRequestEx()+0139 byte(s)
001B:060FFA52 DBAPI16.dll, DrawingStyleRequest()+0498 byte(s)
001B:060F8AE4 DBAPI16.dll, SectorsCheck()+4180 byte(s)
001B:06006AC6 DBAPI16.dll, AppDrawingNewEx()+0054 byte(s)
001B:005E0BF0 Tcw16.exe, CMetricsDialog::OnSendNotificationSequence()+496256 byte(s)
001B:005E085C Tcw16.exe, CMetricsDialog::OnSendNotificationSequence()+495340 byte(s)
001B:005E37F9 Tcw16.exe, CMetricsDialog::OnSendNotificationSequence()+507529 byte(s)
001B:005E295C Tcw16.exe, CMetricsDialog::OnSendNotificationSequence()+503788 byte(s)
001B:00600425 Tcw16.exe, CMetricsDialog::OnSendNotificationSequence()+625333 byte(s)
001B:006006C8 Tcw16.exe, CMetricsDialog::OnSendNotificationSequence()+626008 byte(s)
001B:006007CA Tcw16.exe, CMetricsDialog::OnSendNotificationSequence()+626266 byte(s)
001B:7822E780 MFC80.DLL


Modules:
...
0x06000000: 16.2.53.2, C:\Program Files\IMSIDesign\TCW16\Program\DBAPI16.dll
...


Logged


December 02, 2009, 03:30:40 PM
#10

Quote
I am having the same problem. I am trying to run TurboCAD Deluxe 16.2 on Windows XP. I was running 16 essentially trouble free for about 10 days and then it started having the ACCESS_VIOLATION problems. I then upgraded to 16.2. Now I can't open any file nor start a new drawing. For what it is worth, it seemed like there was a brief period where I could get something open a drawing and get something done before TC crashed. That quickly became less and less until I can no longer do anything. This is what I think are the relevent portions of the crash details:

Unhandled exception errors can happen for a variety of reasons, the first step in trouble shooting should be a re-installation of TurboCAD.

Using add or remove programs remove all versions of TurboCAD and symbols installs.

Delete the following folders.

C:\Documents and Settings\your user name\Application Data\IMSIDesign

C:\Documents and Settings\your user name\Application Data\IMSI

C:\Program Files\IMSI

C:\Program Files\IMSIDesign

Download and install TurboCAD Deluxe 16.2

http://support.turbocad.com/dl/confirm.php?get=TurboCAD-Pro-16-2.exe&pna


Logged
Rip Fowler
IMSIDesign LLC


* December 02, 2009, 04:17:48 PM
#11
Thank you, Rip. I followed your instructions (substituting Deluxe for Pro in the download link) and TurboCAD Deluxe 16.2 is now starting and running without errors.

Logged


December 02, 2009, 04:19:10 PM
#12
Good intuition,

I provided the wrong link, DOH  ???

Logged
Rip Fowler
IMSIDesign LLC


* December 07, 2009, 06:12:21 AM
#13
 :(

Logged


* December 24, 2009, 07:08:15 AM
#14
Your lucky I can't even get the CD to read. Neither of my CD-Rom drives will read the CD. Any one have any suggestions? I have made sure the CD is clean. Both drives will read other CD's when loaded, just not the TurboCAD 16 deluxe.

Its on DVD send me an e-mail and we should be able to straighten this out.

Rip did you get my message?
FYI, I have TurboCAD 16 Deluxe 2D/3D for PC purchased at Staples in Bay City, Michigan, USA. I am running XP and my machine is well beyond the requirements listed on the box.

Logged


December 28, 2009, 10:42:24 AM
#15
Did not get your message, try e-mailing me directly.

rfowler@imsidesign.com

Logged
Rip Fowler
IMSIDesign LLC


* March 14, 2010, 12:49:12 AM
#16
I had the same problem after a completely new install of win7 and tc16 pro.

I resolved it by changing the Virtual memory settings, follow these steps

http://windows.microsoft.com/en-US/windows-vista/Change-the-size-of-virtual-memory

after step 5 (Clear the Automatically manage paging file size for all drives check box.)

check the option "System managed size"

this worked for me

good luck




Logged


* March 25, 2010, 05:56:32 AM
#17
I have TCW16 Deluxe, W7 Home Premium, Pentium Dual Core 2.6 Mhz processor, 6GM Ram and TCW16 won't start. I've done all the steps listed in earlier posts to clean the system, downloaded and installed the full 16.2, used various compatibility methods, UAC and DEP off/on. No go.

Any other suggestions?

Here's a snippet of the error message:

System:  Unknown version of Windows based on NT, version 6.1.7600
Reason:
Tcw16.exe caused an EXCEPTION_ACCESS_VIOLATION in module DBAPI16.dll at 0023:0613CE34, TableGetPropertyInfo()+0212 byte(s)

Registers:
EAX=0018C854  EBX=FFFFFFFF  ECX=00000001  EDX=00000000  ESI=007486E0
EDI=007486E0  EBP=0018C860  ESP=0018C830  EIP=0613CE34  FLG=00210246
CS=0023   DS=002B  SS=002B  ES=002B   FS=0053  GS=002B

Stack:
0023:0613CE34 DBAPI16.dll, TableGetPropertyInfo()+0212 byte(s)
0023:0600C958 DBAPI16.dll, Get_TcEdition()+8936 byte(s)
0023:060083D8 DBAPI16.dll, AppNewEx()+1160 byte(s)
0023:005A18AF Tcw16.exe, CMetricsDialog::OnSendNotificationSequence()+237375 byte(s)
0023:0059FA4C Tcw16.exe, CMetricsDialog::OnSendNotificationSequence()+229596 byte(s)
0023:6BA1CCCB MFC80.DLL


Modules:
0x00400000: 16.2.53.2,    C:\Program Files (x86)\IMSIDesign\TCW16\Program\Tcw16.exe


Brian

Logged


* March 25, 2010, 04:27:21 PM
#18
couple of things you could try-

Try running the .exe by right clicking on it and selecting "run as administrator".

A really strange one-

Open the taskbar properties, taskbar and checkmark "store and display of list of recently opened files".

The latter helped in another program running in Win 7.

Logged


* March 26, 2010, 06:24:25 AM
#19
I turned a trouble ticket into IMSI Support. The identified the problem as an XML-based configuration problem. They sent me a  small file to execute and it seems to have solved the startup problem.

Logged


* May 10, 2010, 02:15:40 AM
#20
I am getting exactly the same as bschwarz, With TC 16 on Windows 7.   It is running on a Sony Vaio with Intel Core(TM)2 Duo T6600 @2.2GHz 4GB Ram

All offered sugested fixes above have been tried except I am not able to turn off DEP.  The ATI HD4570 driver simply will not allow that setting to be changed. 

There are no Windows 7 specific instructions on the TurboCAD support pages so I have cleaned the registry and defragmented as per the XP instructions.  None of this has worked - so next step was opening a ticket but the hope is that it is the above problem - an XML-based configuration. Can anyone from IMSI send me the solution file to try?

Cheers
Iain

Reason:
Tcw16.exe caused an EXCEPTION_ACCESS_VIOLATION in module DBAPI16.dll at 0023:06137B76, TableGetPropertyInfo()+0214 byte(s)

Registers:
EAX=00000000  EBX=FFFFFFFF  ECX=0018C85C  EDX=00000001  ESI=0074F2B0
EDI=0074F2B0  EBP=0018C868  ESP=0018C838  EIP=06137B76  FLG=00210246
CS=0023   DS=002B  SS=002B  ES=002B   FS=0053  GS=002B

Stack:
0023:06137B76 DBAPI16.dll, TableGetPropertyInfo()+0214 byte(s)
0023:0600C7C8 DBAPI16.dll, Get_TcEdition()+8600 byte(s)
0023:060083C8 DBAPI16.dll, AppNewEx()+1160 byte(s)
0023:005A778F Tcw16.exe, CMetricsDialog::OnSendNotificationSequence()+236559 byte(s)
0023:005A5937 Tcw16.exe, CMetricsDialog::OnSendNotificationSequence()+228791 byte(s)
0023:72BFCC98 MFC80.DLL


Logged


* May 10, 2010, 06:08:54 AM
#21
My mistake - not the DEP - that I have tried both on and off but the Display Driver Acceleration cannot be changed.

Anyway - I've tried everything sugested.

Iain

Logged


* May 13, 2010, 04:38:20 AM
#22
Sorted with a TcUpdateManifest.exe file provided by IMSI

Logged


* May 17, 2010, 10:26:09 AM
#23
Hi

I'm a noobie here and have only just bought my first version of TC (V16). Having immense issues trying to launch once installed. Error log is attached. Have tried all possible solutions mentioned above (except of course the exe file, which I cannot find on any of TC's resource pages) - to no avail. Many thanks in advance.

Logged